aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-08-26 09:45:15 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-08-26 09:45:15 +0000
commit9d1b6274661c1e47b8767c9ee72a0b45fe7f185d (patch)
tree1069a726cdd785c2d041671de933662492dc7b52 /x11-drivers
parent0c5e0fd5eaad561ed44d0fa0e0fa39fefb0fba62 (diff)
downloadports-9d1b6274661c1e47b8767c9ee72a0b45fe7f185d.tar.gz
ports-9d1b6274661c1e47b8767c9ee72a0b45fe7f185d.zip
Change bsd.xorg.mk to USES=xorg and USES=xorg-cat
Change the handling of xorg dependencies to use the USES framework instead of bsd.xorg.mk. bsd.xorg.mk is split into two parts: * USES=xorg for ports depending on xorg ports with USE_XORG * USES=xorg-cat for xorg ports with XORG_CAT USES=xorg is fairly straight forward. The components needed are specified with USE_XORG, and USES=xorg is needed to pull in this part of the framework. USES=xorg-cat requires that the category, previously specified with XORG_CAT, now be passed as an argument to xorg-cat, like this USES=xorg-cat:category. Not specifying a category is an error. Further, it is also possible to specify which build system to use. The default if nothing is specified is autoconf, but meson will also be supported. This is added with a second argument: USES=xorg-cat:category[,buildsystem]. Detailed changelog: * Add support in Uses/xorg-cat.mk to specify build system. Previously, only autoconf was supported for xorg ports, but with this change, it's possible to use meson instead. Autoconf is still the defaultx, if nothing else is specified. The meson support is still disabled, and requires more testing. * Add support in Uses/xorg-cat.mk to pull sources from freedesktop.org gitlab. When specifying USE_GITLAB in a port using xorg-cat, then various GL_* variables will be set up automatically, as well as needed changes to the build. * Switch x11-drivers/xf86-video-intel to use the USE_GITLAB framework. * While touching xf86-video-intel, switch to USES=xorg xorg-cat:driver, and pet portlint. * Add compat shims and warnings to bsd.port.mk, which will handle the old style ports Makefiles. * Change Uses/gl.mk and Uses/motif.mk to use this new framework. * Change Uses/autoreconf.mk to check and add dependencies later. This is needed because xorg-cat uses autoreconf, and without this fix dependencies were not added properly. * Be stricter about checking for arguments in USE_XORG, previously, :build and :run were accepted, but not supported. Only the default or :both supported. * Change multimedia/gstreamer1-vaapi to handle the stricter argument checking in USE_XORG, and add USES=xorg * change x11/xscope to get distinfo from xorg-cat, instead of rolling it's own, and add USES=xorg-cat PR: 238988 (exp-run) Reviewed by: antoine, tcberner, tijl, mat, tobik Approved by: portmgr (antoine) Obtained from: FreeBSD Graphics Team development repo https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/usesxorg Sponsored by: B3 Init (zeising) Differential Revision: https://reviews.freebsd.org/D20724
Notes
Notes: svn path=/head/; revision=509895
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-intel/Makefile18
-rw-r--r--x11-drivers/xf86-video-intel/distinfo6
2 files changed, 10 insertions, 14 deletions
diff --git a/x11-drivers/xf86-video-intel/Makefile b/x11-drivers/xf86-video-intel/Makefile
index 0fb1a85e00b6..a2cfac4e9aaa 100644
--- a/x11-drivers/xf86-video-intel/Makefile
+++ b/x11-drivers/xf86-video-intel/Makefile
@@ -4,8 +4,6 @@
PORTNAME= xf86-video-intel
PORTVERSION= 2.99.917.20181203
CATEGORIES= x11-drivers
-MASTER_SITES= http://cgit.freedesktop.org/xorg/${XORG_CAT}/${PORTNAME}/snapshot/
-DISTNAME= ${PORTNAME}-${COMMIT_ID}
MAINTAINER= x11@FreeBSD.org
COMMENT= Driver for Intel integrated graphics chipsets
@@ -13,21 +11,19 @@ COMMENT= Driver for Intel integrated graphics chipsets
LICENSE= MIT # various
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libxcb-util.so:x11/xcb-util \
- libdrm.so:graphics/libdrm
-
-COMMIT_ID= e5ff8e1828f97891c819c919d7115c6e18b2eb1f
-
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Intel integrated GPU only exists in Intel x86 processors/chipsets
-USE_GL= gl
+LIB_DEPENDS= libxcb-util.so:x11/xcb-util \
+ libdrm.so:graphics/libdrm
-USE_LDCONFIG= yes
-XORG_CAT= driver
+USES= cpe xorg xorg-cat:driver
+USE_GITLAB= yes
+GL_COMMIT= e5ff8e1828f97891c819c919d7115c6e18b2eb1f
+USE_GL= gl
USE_XORG= pciaccess pixman x11 xcb xext xrender xv xvmc
+USE_LDCONFIG= yes
-USES+= cpe autoreconf
CPE_VENDOR= x
OPTIONS_SINGLE= ACCEL
diff --git a/x11-drivers/xf86-video-intel/distinfo b/x11-drivers/xf86-video-intel/distinfo
index cf690c5b8e04..d1ed106cd013 100644
--- a/x11-drivers/xf86-video-intel/distinfo
+++ b/x11-drivers/xf86-video-intel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1543827685
-SHA256 (xorg/driver/xf86-video-intel-e5ff8e1828f97891c819c919d7115c6e18b2eb1f.tar.bz2) = 11b7e70c6efecad6540eda24c7370b47597f92dea9b24ca031d83b89eb6a8337
-SIZE (xorg/driver/xf86-video-intel-e5ff8e1828f97891c819c919d7115c6e18b2eb1f.tar.bz2) = 1247314
+TIMESTAMP = 1561472772
+SHA256 (xorg/driver/driver-xf86-video-intel-e5ff8e1828f97891c819c919d7115c6e18b2eb1f_GL0.tar.gz) = cbb6a10695b9e8b41fef1bafe5c4d9ddf710acb1ccba8e141378493bacda982e
+SIZE (xorg/driver/driver-xf86-video-intel-e5ff8e1828f97891c819c919d7115c6e18b2eb1f_GL0.tar.gz) = 1693563