aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2017-01-30 01:42:13 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2017-01-30 01:42:13 +0000
commit2fb1e2b64a5e3b3f5753b6c33d3f0bae0c552105 (patch)
tree3250b1b719ba14e497e5fea0fbbd7561e7dff99f /x11-drivers
parent0a3f2e2222a1f3f28b8e9f43e6c615b8e5fb4f49 (diff)
downloadports-2fb1e2b64a5e3b3f5753b6c33d3f0bae0c552105.tar.gz
ports-2fb1e2b64a5e3b3f5753b6c33d3f0bae0c552105.zip
Add xf86-video-ast driver for ASPEED graphics controllers in recent server motherboards.
PR: 194705 Submitted by: nwhitehorn@freebsd.org Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D9309
Notes
Notes: svn path=/head/; revision=432816
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xf86-video-ast/Makefile19
-rw-r--r--x11-drivers/xf86-video-ast/distinfo3
-rw-r--r--x11-drivers/xf86-video-ast/pkg-descr3
-rw-r--r--x11-drivers/xorg-drivers/Makefile1
5 files changed, 27 insertions, 0 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index 8ce8c6a67a7d..d039c1560a18 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -20,6 +20,7 @@
SUBDIR += xf86-input-wacom
SUBDIR += xf86-video-apm
SUBDIR += xf86-video-ark
+ SUBDIR += xf86-video-ast
SUBDIR += xf86-video-ati
SUBDIR += xf86-video-chips
SUBDIR += xf86-video-cirrus
diff --git a/x11-drivers/xf86-video-ast/Makefile b/x11-drivers/xf86-video-ast/Makefile
new file mode 100644
index 000000000000..f9516d2ba2a8
--- /dev/null
+++ b/x11-drivers/xf86-video-ast/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= xf86-video-ast
+PORTVERSION= 1.1.5
+CATEGORIES= x11-drivers
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org ASPEED display driver
+
+LICENSE= MIT
+LICENSE_FILES= ${WRKSRC}/COPYING
+
+XORG_CAT= driver
+USE_XORG= xf86driproto glproto
+INSTALL_TARGET= install-strip
+
+PLIST_FILES= lib/xorg/modules/drivers/ast_drv.so
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-ast/distinfo b/x11-drivers/xf86-video-ast/distinfo
new file mode 100644
index 000000000000..c50662023881
--- /dev/null
+++ b/x11-drivers/xf86-video-ast/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485310562
+SHA256 (xorg/driver/xf86-video-ast-1.1.5.tar.bz2) = 1edbbc55d47d3fd71dec99b15c2483e22738c642623a0fb86ef4a81a9067a2de
+SIZE (xorg/driver/xf86-video-ast-1.1.5.tar.bz2) = 339848
diff --git a/x11-drivers/xf86-video-ast/pkg-descr b/x11-drivers/xf86-video-ast/pkg-descr
new file mode 100644
index 000000000000..55f336f44a89
--- /dev/null
+++ b/x11-drivers/xf86-video-ast/pkg-descr
@@ -0,0 +1,3 @@
+This package contains the X.Org xf86-video-ast driver.
+
+WWW: http://www.x.org
diff --git a/x11-drivers/xorg-drivers/Makefile b/x11-drivers/xorg-drivers/Makefile
index e5e378db6854..916852f39f66 100644
--- a/x11-drivers/xorg-drivers/Makefile
+++ b/x11-drivers/xorg-drivers/Makefile
@@ -32,6 +32,7 @@ VIDEO_DRIVERS= mach64 \
vesa \
apm \
ark \
+ ast \
chips \
dummy \
glint \