aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-01-13 23:36:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-01-13 23:36:24 +0000
commitde40123f7536c7868e25cd3c488ebeb92b9c1833 (patch)
tree612f9e92f04059c0644a2977295196fcf5a79005 /x11-drivers
parent686c8e83e86667bb1f47d59609045e0540cb86da (diff)
downloadports-de40123f7536c7868e25cd3c488ebeb92b9c1833.tar.gz
ports-de40123f7536c7868e25cd3c488ebeb92b9c1833.zip
Add a patch to fix an unitialized variable
While here add license PR: 214589 Submitted by: matthew@reztek.cz
Notes
Notes: svn path=/head/; revision=431443
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-openchrome/Makefile3
-rw-r--r--x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c11
2 files changed, 14 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-openchrome/Makefile b/x11-drivers/xf86-video-openchrome/Makefile
index 4ab6773a781d..b5b74e25197b 100644
--- a/x11-drivers/xf86-video-openchrome/Makefile
+++ b/x11-drivers/xf86-video-openchrome/Makefile
@@ -8,6 +8,9 @@ CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org openChrome display driver
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GL= gl
XORG_CAT= driver
diff --git a/x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c b/x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c
new file mode 100644
index 000000000000..e7b63c200dc8
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/files/patch-src__via_driver.c
@@ -0,0 +1,11 @@
+--- src/via_driver.c.orig 2015-11-19 15:49:03.658837000 +0100
++++ src/via_driver.c 2015-11-19 15:51:11.689034000 +0100
+@@ -806,7 +806,7 @@ via_xf86crtc_resize(ScrnInfoPtr scrn, in
+ {
+ xf86CrtcConfigPtr xf86_config = XF86_CRTC_CONFIG_PTR(scrn);
+ struct buffer_object *old_front = NULL, *new_front = NULL;
+- int old_width, old_height, old_dwidth, format;
++ int old_width = 0, old_height = 0, old_dwidth = 0, format;
+ int cpp = (scrn->bitsPerPixel + 7) >> 3, i;
+ ScreenPtr screen = scrn->pScreen;
+ VIAPtr pVia = VIAPTR(scrn);