aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-12-19 09:09:11 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-12-19 09:09:11 +0000
commit248c6b5c09f123b4b2cbda5d5a71292f914516d0 (patch)
tree573e75ef1898d818b9f9ec7c562fec3bc1120a64 /x11-drivers
parent81f404a02706a759b935d2bcadb05e3f6caae3f0 (diff)
downloadports-248c6b5c09f123b4b2cbda5d5a71292f914516d0.tar.gz
ports-248c6b5c09f123b4b2cbda5d5a71292f914516d0.zip
Split out evdev headers from multimedia/v4l_compat
Split out evdev headers (input.h, input-event-codes.h, uinput.h) into their own port, devel/evdev-proto, and update those to be current with the Linux 4.19 kernel. This is done in order to be able to update the rest of the FreeBSD input stack, which is forthcoming. By splititng out the evdev headers we can update them independent of other updates in v4l_compat, which makes it easier for the graphics team to keep track of them and keep them updated as needed. Update devel/libevdev from 1.4.4 to 1.5.9 instead of trying to make it work with the updated headers. This will be further updated. Update devel/py-evdev from 0.5.0 to 0.8.1 instead of trying to make it work with the updated evdev headers. Update consumers to use devel/evdev-proto rather than multimedia/v4l_compat as needed, and bump portrevisions. This is the first step in getting the FreeBSD input stack (libevdev, libinput and so on) updated to newer versions. Many thanks to all who have helped out with testing, code and exp-runs. Apologies if I've forgotten to add any names. PR: 222905, 217248, (based on, in part), 233787 (exp-run) Submitted by: Greg V, wulf Tested by: tcberner, kde Exp-run by: antoine Approved by: portmgr (antoine) Obtained from: FreeBSDDesktop development repo https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/input https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/input-ports
Notes
Notes: svn path=/head/; revision=487789
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/Makefile4
-rw-r--r--x11-drivers/xf86-input-libinput/Makefile3
-rw-r--r--x11-drivers/xf86-input-synaptics/Makefile4
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile4
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-wcmConfig.c6
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c12
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-wcmUSB.c10
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-wcmValidateDevice.c21
-rw-r--r--x11-drivers/xf86-video-qxl/Makefile4
9 files changed, 39 insertions, 29 deletions
diff --git a/x11-drivers/xf86-input-evdev/Makefile b/x11-drivers/xf86-input-evdev/Makefile
index 1efc0c58ee77..a5f1a651f6c0 100644
--- a/x11-drivers/xf86-input-evdev/Makefile
+++ b/x11-drivers/xf86-input-evdev/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-input-evdev
PORTVERSION= 2.10.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= X.Org event device input driver
LICENSE= MIT # various styles
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= v4l_compat>=1.0.20110603:multimedia/v4l_compat
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
LIB_DEPENDS= libevdev.so:devel/libevdev \
libmtdev.so:devel/libmtdev
RUN_DEPENDS= webcamd>=3.1.0.1:multimedia/webcamd
diff --git a/x11-drivers/xf86-input-libinput/Makefile b/x11-drivers/xf86-input-libinput/Makefile
index b0e672dfc716..86aa1f11608c 100644
--- a/x11-drivers/xf86-input-libinput/Makefile
+++ b/x11-drivers/xf86-input-libinput/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-input-libinput
PORTVERSION= 0.25.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -11,6 +11,7 @@ COMMENT= X.Org libinput input driver
LICENSE= MIT # various styles
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
LIB_DEPENDS= libinput.so:x11/libinput
XORG_CAT= driver
diff --git a/x11-drivers/xf86-input-synaptics/Makefile b/x11-drivers/xf86-input-synaptics/Makefile
index 277426717d59..98d8ac0b9dea 100644
--- a/x11-drivers/xf86-input-synaptics/Makefile
+++ b/x11-drivers/xf86-input-synaptics/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-input-synaptics
PORTVERSION= 1.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= EVDEV
EVDEV_DESC= Use evdev for input events (requires kernel support)
EVDEV_CONFIGURE_ENV= BUILD_EVENTCOMM=yes
-EVDEV_BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
+EVDEV_BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
EVDEV_LIB_DEPENDS= libevdev.so:devel/libevdev
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index af2a169716e1..6909c075afc3 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-input-wacom
PORTVERSION= 0.36.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-drivers
MASTER_SITES= https://github.com/linuxwacom/${PORTNAME}/releases/download/${DISTNAME}/
@@ -11,7 +11,7 @@ COMMENT= X.Org Wacom tablet driver
LICENSE= GPLv2+
-BUILD_DEPENDS= v4l_compat>=1.0.20110603:multimedia/v4l_compat
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
RUN_DEPENDS= webcamd>=3.1.0.1:multimedia/webcamd
USES= gmake pathfix
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-wcmConfig.c b/x11-drivers/xf86-input-wacom/files/patch-src-wcmConfig.c
index 76f05c9506c1..b3c447fbf58b 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-wcmConfig.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-wcmConfig.c
@@ -1,6 +1,6 @@
---- src/wcmConfig.c~
+--- src/wcmConfig.c.orig 2018-02-12 16:43:12 UTC
+++ src/wcmConfig.c
-@@ -307,7 +307,7 @@ out:
+@@ -311,7 +311,7 @@ out:
*/
static void wcmSplitName(char* devicename, char *basename, char *subdevice, char *tool, size_t len)
{
@@ -9,7 +9,7 @@
char *a, *b;
*basename = *subdevice = *tool = '\0';
-@@ -325,6 +325,7 @@ static void wcmSplitName(char* devicenam
+@@ -338,6 +338,7 @@ static void wcmSplitName(char* devicename, char *basen
strncat(tool, a+1, len-1);
}
strncat(basename, name, len-1);
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c b/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c
index 0d6aaa3ccbf9..198d7e3943e5 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c
@@ -1,4 +1,4 @@
---- src/wcmISDV4.c~
+--- src/wcmISDV4.c.orig 2017-05-30 18:42:52 UTC
+++ src/wcmISDV4.c
@@ -24,14 +24,19 @@
#include "xf86Wacom.h"
@@ -22,7 +22,7 @@
#define RESET_RELATIVE(ds) do { (ds).relwheel = 0; } while (0)
/* resolution in points/m */
-@@ -192,10 +197,15 @@ static int wcmSerialValidate(InputInfoPt
+@@ -195,10 +200,15 @@ static int wcmSerialValidate(InputInfoPtr pInfo, const
static Bool isdv4Detect(InputInfoPtr pInfo)
{
@@ -39,7 +39,7 @@
if (rc == -1)
return FALSE;
-@@ -959,6 +969,7 @@ static Bool get_keys_vendor_tablet_id(ch
+@@ -968,6 +978,7 @@ static Bool get_keys_vendor_tablet_id(char *name, Waco
return TRUE;
}
@@ -47,7 +47,7 @@
/**
* Return the content of id file from sysfs: /sys/.../device/id
*
-@@ -1004,6 +1015,7 @@ out:
+@@ -1017,6 +1028,7 @@ out:
return ret;
}
@@ -55,7 +55,7 @@
/**
* Query the device's fd for the key bits and the tablet ID. Returns the ID
-@@ -1018,11 +1030,16 @@ out:
+@@ -1031,11 +1043,16 @@ out:
*/
static int isdv4ProbeKeys(InputInfoPtr pInfo)
{
@@ -73,7 +73,7 @@
return 0;
common->tablet_id = 0x90;
-@@ -1037,9 +1054,11 @@ static int isdv4ProbeKeys(InputInfoPtr p
+@@ -1050,9 +1067,11 @@ static int isdv4ProbeKeys(InputInfoPtr pInfo)
common->wcmProtocolLevel = WCM_PROTOCOL_GENERIC;
if (!get_keys_vendor_tablet_id(pInfo->name, common)) {
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-wcmUSB.c b/x11-drivers/xf86-input-wacom/files/patch-src-wcmUSB.c
index cc0ec54e2877..33a46dff83de 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-wcmUSB.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-wcmUSB.c
@@ -1,4 +1,4 @@
---- src/wcmUSB.c~
+--- src/wcmUSB.c.orig 2018-03-12 16:31:49 UTC
+++ src/wcmUSB.c
@@ -23,10 +23,17 @@
@@ -18,15 +18,15 @@
#define MAX_USB_EVENTS 32
-@@ -276,6 +283,11 @@ static struct WacomModelDesc
+@@ -280,6 +287,11 @@ static struct WacomModelDesc
+ { WACOM_VENDOR_ID, 0x314,200000, 200000, &usbIntuosPro, "Intuos Pro S" },
{ WACOM_VENDOR_ID, 0x315,200000, 200000, &usbIntuosPro, "Intuos Pro M" },
{ WACOM_VENDOR_ID, 0x317,200000, 200000, &usbIntuosPro, "Intuos Pro L" },
-
++
+ { WACOM_VENDOR_ID, 0x33B,200000, 200000, &usbIntuos5, "Intuos Draw small" },
+ { WACOM_VENDOR_ID, 0x33C,200000, 200000, &usbIntuos5, "Intuos Art/Photo/Comic small"},
+ { WACOM_VENDOR_ID, 0x33D,200000, 200000, &usbIntuos5, "Intuos Draw medium" },
+ { WACOM_VENDOR_ID, 0x33E,200000, 200000, &usbIntuos5, "Intuos Art medium" },
-+
+
{ WACOM_VENDOR_ID, 0x3F, 200000, 200000, &usbCintiqV5, "Cintiq 21UX" },
{ WACOM_VENDOR_ID, 0xC5, 200000, 200000, &usbCintiqV5, "Cintiq 20WSX" },
- { WACOM_VENDOR_ID, 0xC6, 200000, 200000, &usbCintiqV5, "Cintiq 12WX" },
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-wcmValidateDevice.c b/x11-drivers/xf86-input-wacom/files/patch-src-wcmValidateDevice.c
index 71a40cffabae..1b8ebfd5f6d3 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-wcmValidateDevice.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-wcmValidateDevice.c
@@ -1,6 +1,6 @@
---- src/wcmValidateDevice.c.orig 2015-10-23 17:26:33 UTC
+--- src/wcmValidateDevice.c.orig 2018-02-13 17:35:29 UTC
+++ src/wcmValidateDevice.c
-@@ -34,6 +34,7 @@ static Bool wcmCheckSource(InputInfoPtr
+@@ -34,6 +34,7 @@ static Bool wcmCheckSource(InputInfoPtr pInfo, dev_t m
{
int match = 0;
InputInfoPtr pDevices = xf86FirstLocalDevice();
@@ -8,7 +8,7 @@
for (; !match && pDevices != NULL; pDevices = pDevices->next)
{
-@@ -51,7 +52,6 @@ static Bool wcmCheckSource(InputInfoPtr
+@@ -51,7 +52,6 @@ static Bool wcmCheckSource(InputInfoPtr pInfo, dev_t m
if (pInfo != pDevices)
{
WacomCommonPtr pCommon = ((WacomDevicePtr)pDevices->private)->common;
@@ -16,7 +16,7 @@
char* psource = xf86CheckStrOption(pDevices->options, "_source", "");
if (pCommon->min_maj &&
-@@ -62,10 +62,11 @@ static Bool wcmCheckSource(InputInfoPtr
+@@ -62,10 +62,11 @@ static Bool wcmCheckSource(InputInfoPtr pInfo, dev_t m
if (strcmp(fsource, psource))
match = 1;
}
@@ -29,7 +29,16 @@
if (match)
xf86Msg(X_WARNING, "%s: device file already in use by %s. "
"Ignoring.\n", pInfo->name, pDevices->name);
-@@ -205,6 +206,10 @@ int wcmDeviceTypeKeys(InputInfoPtr pInfo
+@@ -123,7 +124,7 @@ ret:
+ static struct
+ {
+ const char* type;
+- __u16 tool[3]; /* tool array is terminated by 0 */
++ uint16_t tool[3]; /* tool array is terminated by 0 */
+ } wcmType [] =
+ {
+ { "stylus", { BTN_TOOL_PEN, 0 } },
+@@ -212,6 +213,10 @@ int wcmDeviceTypeKeys(InputInfoPtr pInfo)
case 0x314: /* Intuos Pro S */
case 0x315: /* Intuos Pro M */
case 0x317: /* Intuos Pro L */
@@ -40,7 +49,7 @@
case 0x26: /* I5 */
case 0x27: /* I5 */
case 0x28: /* I5 */
-@@ -623,8 +628,10 @@ int wcmNeedAutoHotplug(InputInfoPtr pInf
+@@ -659,8 +664,10 @@ int wcmNeedAutoHotplug(InputInfoPtr pInfo, char **type
if (!source) /* xorg.conf device, don't auto-pick type */
goto out;
diff --git a/x11-drivers/xf86-video-qxl/Makefile b/x11-drivers/xf86-video-qxl/Makefile
index 8034e645554a..d7c0ebd74406 100644
--- a/x11-drivers/xf86-video-qxl/Makefile
+++ b/x11-drivers/xf86-video-qxl/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-video-qxl
DISTVERSION= 0.1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-drivers
MAINTAINER= ports@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= X.Org X server -- QXL display driver
LICENSE= MIT
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol \
- ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
+ ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
LIB_DEPENDS= libspice-server.so:devel/libspice-server
USES= localbase:ldflags pkgconfig python:2.7 shebangfix