aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-02-20 19:56:48 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-02-20 19:56:48 +0000
commit283ece0414829d4100dc0c6fdcc0489fa39b91f1 (patch)
treeacd9b8b08babaa304bf28c4bd3452c8a2c198d6a /x11-drivers
parent26c6eed4d9f19f511ddee9ff6625918e90d62a1b (diff)
downloadports-283ece0414829d4100dc0c6fdcc0489fa39b91f1.tar.gz
ports-283ece0414829d4100dc0c6fdcc0489fa39b91f1.zip
x11-drivers/xf86-video-apm: Update to 1.3.0
Update xf86-video-apm to 1.3.0. Remove patches that are incorporated upstream. This has not been run time tested due to lack of hardware. PR: 235839 Submitted by: pete@nomadlogic.org
Notes
Notes: svn path=/head/; revision=493437
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-apm/Makefile3
-rw-r--r--x11-drivers/xf86-video-apm/distinfo5
-rw-r--r--x11-drivers/xf86-video-apm/files/patch-src_apm.h24
-rw-r--r--x11-drivers/xf86-video-apm/files/patch-src_apm__driver.c60
4 files changed, 4 insertions, 88 deletions
diff --git a/x11-drivers/xf86-video-apm/Makefile b/x11-drivers/xf86-video-apm/Makefile
index fc2ea68600e9..4d2b16fd80f9 100644
--- a/x11-drivers/xf86-video-apm/Makefile
+++ b/x11-drivers/xf86-video-apm/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-apm
-PORTVERSION= 1.2.5
-PORTREVISION= 10
+PORTVERSION= 1.3.0
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-apm/distinfo b/x11-drivers/xf86-video-apm/distinfo
index cd9591f9e068..7fd22899a5b4 100644
--- a/x11-drivers/xf86-video-apm/distinfo
+++ b/x11-drivers/xf86-video-apm/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xorg/driver/xf86-video-apm-1.2.5.tar.bz2) = 953b04320117b14c5b7efb37de45cef45592409f639c2aa87b7e2d77dc8d3d0f
-SIZE (xorg/driver/xf86-video-apm-1.2.5.tar.bz2) = 325277
+TIMESTAMP = 1550522074
+SHA256 (xorg/driver/xf86-video-apm-1.3.0.tar.bz2) = 808189b9a933fcad1761cb9cd498f9267dfbacee1059859282712e8598c3dc7e
+SIZE (xorg/driver/xf86-video-apm-1.3.0.tar.bz2) = 352759
diff --git a/x11-drivers/xf86-video-apm/files/patch-src_apm.h b/x11-drivers/xf86-video-apm/files/patch-src_apm.h
deleted file mode 100644
index bbe1dcc08757..000000000000
--- a/x11-drivers/xf86-video-apm/files/patch-src_apm.h
+++ /dev/null
@@ -1,24 +0,0 @@
-From 9f67408e4f078e907fbf4feb45cfdcfd0cdebcca Mon Sep 17 00:00:00 2001
-From: Adam Jackson <ajax@redhat.com>
-Date: Wed, 9 Jan 2013 22:03:29 -0500
-Subject: Remove #include "mibstore.h"
-
-Signed-off-by: Adam Jackson <ajax@redhat.com>
-
-diff --git a/src/apm.h b/src/apm.h
-index a3c06f8..365e5e2 100644
---- src/apm.h 2012-07-17 04:52:01 UTC
-+++ src/apm.h
-@@ -33,9 +33,6 @@
- /* All drivers initialising the SW cursor need this */
- #include "mipointer.h"
-
--/* All drivers implementing backing store need this */
--#include "mibstore.h"
--
- /* I2C support */
- #include "xf86i2c.h"
-
---
-cgit v0.10.2
-
diff --git a/x11-drivers/xf86-video-apm/files/patch-src_apm__driver.c b/x11-drivers/xf86-video-apm/files/patch-src_apm__driver.c
deleted file mode 100644
index a086ffb786f5..000000000000
--- a/x11-drivers/xf86-video-apm/files/patch-src_apm__driver.c
+++ /dev/null
@@ -1,60 +0,0 @@
-# Remove miInitializeBackingStore; it no longer exists and
-# should have been removed with the mibstore.h include
-#
-# Replace xf86UnMapVidMem with pci_device_unmap_range
-#
-# Correct one string that should be const
-#
---- src/apm_driver.c.orig 2012-07-17 04:52:01 UTC
-+++ src/apm_driver.c
-@@ -355,7 +355,8 @@ ApmPreInit(ScrnInfoPtr pScrn, int flags)
- EntityInfoPtr pEnt;
- vgaHWPtr hwp;
- MessageType from;
-- char *mod = NULL, *req = NULL, *s;
-+ char *mod = NULL, *req = NULL;
-+ const char *s;
- ClockRangePtr clockRanges;
- int i;
- xf86MonPtr MonInfo = NULL;
-@@ -751,7 +752,11 @@ ApmPreInit(ScrnInfoPtr pScrn, int flags)
- LinMap[0xFFECDB] = db;
- LinMap[0xFFECD9] = d9;
- /*pciWriteLong(pApm->PciTag, PCI_CMD_STAT_REG, save);*/
-+#ifndef XSERVER_LIBPCIACCESS
- xf86UnMapVidMem(pScrn->scrnIndex, (pointer)LinMap, pApm->LinMapSize);
-+#else
-+ pci_device_unmap_range(pApm->PciInfo, (pointer)LinMap, pApm->LinMapSize);
-+#endif
- from = X_PROBED;
- }
- else {
-@@ -1134,12 +1139,19 @@ ApmUnmapMem(ScrnInfoPtr pScrn)
- WRXB(0xDB, pApm->db);
- }
- WRXB(0xC9, pApm->c9);
-+#ifndef XSERVER_LIBPCIACCESS
- xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pApm->LinMap, pApm->LinMapSize);
-+#else
-+ pci_device_unmap_range(pApm->PciInfo, (pointer)pApm->LinMap, pApm->LinMapSize);
-+#endif
- pApm->LinMap = NULL;
- }
- else if (pApm->FbBase)
-+#ifndef XSERVER_LIBPCIACCESS
- xf86UnMapVidMem(pScrn->scrnIndex, (pointer)pApm->LinMap, 0x10000);
--
-+#else
-+ pci_device_unmap_range(pApm->PciInfo, (pointer)pApm->LinMap, 0x10000);
-+#endif
- return TRUE;
- }
-
-@@ -1784,7 +1796,6 @@ ApmScreenInit(SCREEN_INIT_ARGS_DECL)
- }
- #endif
-
-- miInitializeBackingStore(pScreen);
- xf86SetBackingStore(pScreen);
- xf86SetSilkenMouse(pScreen);
-