aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-04-18 15:34:36 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-04-18 15:34:36 +0000
commit1fc509c59162d92657bb57ee9b52ad6f0c5eaff6 (patch)
tree50d837d122ae52af042914c64739f37a28d78d4d /x11-drivers
parent94d9cc888384fb1f2922ae9ea63553b257426582 (diff)
downloadports-1fc509c59162d92657bb57ee9b52ad6f0c5eaff6.tar.gz
ports-1fc509c59162d92657bb57ee9b52ad6f0c5eaff6.zip
Notes
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-mouse/Makefile3
-rw-r--r--x11-drivers/xf86-input-mouse/distinfo4
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c80
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in6
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src_mouse.c30
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src_mouse.h8
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src_mousePriv.h6
-rw-r--r--x11-drivers/xf86-input-synaptics/Makefile3
-rw-r--r--x11-drivers/xf86-input-synaptics/distinfo4
-rw-r--r--x11-drivers/xf86-video-i740/Makefile3
-rw-r--r--x11-drivers/xf86-video-i740/distinfo4
-rw-r--r--x11-drivers/xf86-video-i740/files/patch-src_i740__driver.c21
-rw-r--r--x11-drivers/xf86-video-mga/Makefile3
-rw-r--r--x11-drivers/xf86-video-mga/distinfo4
-rw-r--r--x11-drivers/xf86-video-tdfx/Makefile3
-rw-r--r--x11-drivers/xf86-video-tdfx/distinfo4
-rw-r--r--x11-drivers/xf86-video-tdfx/files/patch-src_tdfx__driver.c21
-rw-r--r--x11-drivers/xf86-video-vmware/Makefile3
-rw-r--r--x11-drivers/xf86-video-vmware/distinfo4
19 files changed, 80 insertions, 134 deletions
diff --git a/x11-drivers/xf86-input-mouse/Makefile b/x11-drivers/xf86-input-mouse/Makefile
index c70cd0e3c4d9..e84acae49bd1 100644
--- a/x11-drivers/xf86-input-mouse/Makefile
+++ b/x11-drivers/xf86-input-mouse/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-mouse
-PORTVERSION= 1.9.0
-PORTREVISION= 6
+PORTVERSION= 1.9.1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-input-mouse/distinfo b/x11-drivers/xf86-input-mouse/distinfo
index 00bb525f0db8..900699e0397d 100644
--- a/x11-drivers/xf86-input-mouse/distinfo
+++ b/x11-drivers/xf86-input-mouse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-mouse-1.9.0.tar.bz2) = 5d601e4bae53d5e9ead4ecd700f1beb5aeaf78b79e634c4aa381a9ce00276488
-SIZE (xorg/driver/xf86-input-mouse-1.9.0.tar.bz2) = 353339
+SHA256 (xorg/driver/xf86-input-mouse-1.9.1.tar.bz2) = 3485d375779c08406f0789feedde15933dc703158a086ddac638598f479fc5ce
+SIZE (xorg/driver/xf86-input-mouse-1.9.1.tar.bz2) = 348244
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
index 1996722fd2eb..f4d39fabf24b 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
+++ b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
@@ -1,5 +1,5 @@
---- src/bsd_mouse.c.orig 2012-10-08 03:40:07.000000000 +0200
-+++ src/bsd_mouse.c 2013-07-03 01:00:50.897361950 +0200
+--- src/bsd_mouse.c.orig 2014-08-12 06:36:34 UTC
++++ src/bsd_mouse.c
@@ -26,6 +26,24 @@
* authorization from the copyright holder(s) and author(s).
*/
@@ -59,7 +59,7 @@
#define HUP_GENERIC_DESKTOP 0x0001
#define HUP_BUTTON 0x0009
-@@ -75,11 +104,13 @@
+@@ -75,11 +104,13 @@ static const char *FindDevice(InputInfoP
#define DEFAULT_MOUSE_DEV "/dev/mouse"
#define DEFAULT_SYSMOUSE_DEV "/dev/sysmouse"
#define DEFAULT_PS2_DEV "/dev/psm0"
@@ -73,20 +73,16 @@
NULL
};
#elif (defined(__OpenBSD__) || defined(__NetBSD__)) && defined(WSCONS_SUPPORT)
-@@ -100,7 +131,11 @@
- #if defined(__NetBSD__)
- return MSE_SERIAL | MSE_BUS | MSE_PS2 | MSE_AUTO;
- #elif defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)
-- return MSE_SERIAL | MSE_BUS | MSE_PS2 | MSE_AUTO | MSE_MISC;
-+ return MSE_SERIAL | MSE_BUS | MSE_PS2 |
-+#ifdef XPS2_SUPPORT
-+ MSE_XPS2 |
-+#endif
-+ MSE_AUTO | MSE_MISC;
+@@ -97,7 +128,7 @@ static const char *mouseDevs[] = {
+ static int
+ SupportedInterfaces(void)
+ {
+-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__) || defined(__NetBSD__)
++#if defined(__NetBSD__)
+ return MSE_SERIAL | MSE_BUS | MSE_PS2 | MSE_AUTO | MSE_MISC;
#else
return MSE_SERIAL | MSE_BUS | MSE_PS2 | MSE_XPS2 | MSE_AUTO | MSE_MISC;
- #endif
-@@ -180,9 +215,30 @@
+@@ -178,9 +209,30 @@ static struct {
{ MOUSE_PROTO_SYSMOUSE, "SysMouse" }
};
@@ -117,7 +113,7 @@
int i;
mousehw_t hw;
mousemode_t mode;
-@@ -190,7 +246,13 @@
+@@ -188,7 +240,13 @@ SetupAuto(InputInfoPtr pInfo, int *proto
if (pInfo->fd == -1)
return NULL;
@@ -131,7 +127,7 @@
i = 1;
ioctl(pInfo->fd, MOUSE_SETLEVEL, &i);
-@@ -209,9 +271,18 @@
+@@ -207,9 +265,18 @@ SetupAuto(InputInfoPtr pInfo, int *proto
protoPara[0] = mode.syncmask[0];
protoPara[1] = mode.syncmask[1];
}
@@ -152,7 +148,7 @@
}
}
}
-@@ -234,41 +305,41 @@
+@@ -232,41 +299,41 @@ SetSysMouseRes(InputInfoPtr pInfo, const
(protocol && xf86NameCmp(protocol, "SysMouse") == 0)) {
/*
* As the FreeBSD sysmouse driver defaults to protocol level 0
@@ -211,7 +207,7 @@
}
return FALSE;
}
-@@ -276,17 +347,17 @@
+@@ -274,17 +341,17 @@ MousedRunning(void)
static const char *
FindDevice(InputInfoPtr pInfo, const char *protocol, int flags)
{
@@ -233,7 +229,7 @@
#endif
} else {
/*
-@@ -295,28 +366,32 @@
+@@ -293,28 +360,32 @@ FindDevice(InputInfoPtr pInfo, const cha
* the test for whether /dev/sysmouse is usable can be made.
*/
if (!strcmp(*pdev, DEFAULT_MOUSE_DEV)) {
@@ -279,7 +275,7 @@
break;
}
}
-@@ -468,30 +543,78 @@
+@@ -486,30 +557,78 @@ wsconsPreInit(InputInfoPtr pInfo, const
#if defined(USBMOUSE_SUPPORT)
@@ -366,7 +362,7 @@
switch (what) {
case DEVICE_INIT:
-@@ -500,38 +623,96 @@
+@@ -518,38 +637,96 @@ usbMouseProc(DeviceIntPtr pPointer, int
for (nbuttons = 0; nbuttons < MSE_MAXBUTTONS; ++nbuttons)
map[nbuttons + 1] = nbuttons + 1;
@@ -486,7 +482,7 @@
}
pMse->lastButtons = 0;
pMse->lastMappedButtons = 0;
-@@ -553,6 +734,7 @@
+@@ -571,6 +748,7 @@ usbMouseProc(DeviceIntPtr pPointer, int
xf86CloseSerial(pInfo->fd);
pInfo->fd = -1;
}
@@ -494,7 +490,7 @@
pPointer->public.on = FALSE;
usleep(300000);
break;
-@@ -568,45 +750,154 @@
+@@ -586,45 +764,154 @@ usbReadInput(InputInfoPtr pInfo)
{
MouseDevPtr pMse;
UsbMsePtr pUsbMse;
@@ -551,11 +547,6 @@
- dy = hid_get_data(pBuf, &pUsbMse->loc_y);
- dz = hid_get_data(pBuf, &pUsbMse->loc_z);
- dw = hid_get_data(pBuf, &pUsbMse->loc_w);
--
-- buttons = 0;
-- for (n = 0; n < pMse->buttons; n++) {
-- if (hid_get_data(pBuf, &pUsbMse->loc_btn[n]))
-- buttons |= (1 << UMS_BUT(n));
+ for (nacol = 0; nacol < pUsbMse->nacols; nacol++) {
+ acol = &pUsbMse->acols[nacol];
+ if (acol->pInfo == NULL)
@@ -565,7 +556,11 @@
+ dx = dy = dz = dw = dp = 0;
+ for (nlcol = 0; nlcol < pUsbMse->acols[nacol].nlcols; nlcol++) {
+ lcol = &acol->lcols[nlcol];
-+
+
+- buttons = 0;
+- for (n = 0; n < pMse->buttons; n++) {
+- if (hid_get_data(pBuf, &pUsbMse->loc_btn[n]))
+- buttons |= (1 << UMS_BUT(n));
+ if (lcol->loc_valid.usage != 0 && rid == lcol->loc_valid.report_ID &&
+ hid_get_data(pBuf, &lcol->loc_valid) == 0)
+ continue;
@@ -671,7 +666,7 @@
}
static void
-@@ -615,14 +906,17 @@
+@@ -633,14 +920,17 @@ usbSigioReadInput (int fd, void *closure
usbReadInput ((InputInfoPtr) closure);
}
@@ -692,7 +687,7 @@
pUsbMse = malloc(sizeof(UsbMseRec));
if (pUsbMse == NULL) {
-@@ -631,12 +925,7 @@
+@@ -649,12 +939,7 @@ usbPreInit(InputInfoPtr pInfo, const cha
return FALSE;
}
@@ -706,7 +701,7 @@
/* Check if the device can be opened. */
pInfo->fd = xf86OpenSerial(pInfo->options);
-@@ -652,19 +941,134 @@
+@@ -670,19 +955,134 @@ usbPreInit(InputInfoPtr pInfo, const cha
}
/* Get USB informations */
reportDesc = hid_get_report_desc(pInfo->fd);
@@ -716,13 +711,6 @@
- xf86Msg(X_ERROR, "Error ioctl USB_GET_REPORT_ID on %s : %s\n",
- pInfo->name, strerror(errno));
- return FALSE;
-- }
-- pUsbMse->packetSize = hid_report_size(reportDesc, hid_input,
-- pUsbMse->iid);
--#else
-- pUsbMse->packetSize = hid_report_size(reportDesc, hid_input,
-- &pUsbMse->iid);
--#endif
+ mdepth = 0;
+ pUsbMse->nacols = 0;
+ acol = &pUsbMse->acols[pUsbMse->nacols];
@@ -842,7 +830,13 @@
+ default:
+ break;
+ }
-+ }
+ }
+- pUsbMse->packetSize = hid_report_size(reportDesc, hid_input,
+- pUsbMse->iid);
+-#else
+- pUsbMse->packetSize = hid_report_size(reportDesc, hid_input,
+- &pUsbMse->iid);
+-#endif
+ if (lcolused)
+ acol->nlcols++;
+ if (acolused)
@@ -854,7 +848,7 @@
/* Allocate buffer */
if (pUsbMse->packetSize <= 8) {
pUsbMse->buffer = pMse->protoBuf;
-@@ -674,56 +1078,129 @@
+@@ -692,56 +1092,129 @@ usbPreInit(InputInfoPtr pInfo, const cha
if (pUsbMse->buffer == NULL) {
xf86Msg(X_ERROR, "%s: cannot allocate buffer\n", pInfo->name);
free(pUsbMse);
@@ -1021,7 +1015,7 @@
/* Setup the local procs. */
pInfo->device_control = usbMouseProc;
pInfo->read_input = usbReadInput;
-@@ -766,7 +1243,9 @@
+@@ -784,7 +1257,9 @@ OSMouseInit(int flags)
p->CheckProtocol = CheckProtocol;
#if (defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)) && defined(MOUSE_PROTO_SYSMOUSE)
p->SetupAuto = SetupAuto;
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in b/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in
index 5b1c89921ea5..ba7c09e4fe00 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in
+++ b/x11-drivers/xf86-input-mouse/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- ./src/Makefile.in.orig 2011-07-05 18:09:54.000000000 +0200
-+++ ./src/Makefile.in 2012-03-02 14:02:43.000000000 +0100
-@@ -279,7 +279,7 @@
+--- src/Makefile.in.orig 2015-03-03 05:17:45 UTC
++++ src/Makefile.in
+@@ -344,7 +344,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include $(
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c b/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c
index 27118de48943..d4884b7ad585 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c
+++ b/x11-drivers/xf86-input-mouse/files/patch-src_mouse.c
@@ -1,6 +1,6 @@
---- src/mouse.c.orig 2012-10-08 03:40:07.000000000 +0200
-+++ src/mouse.c 2013-07-03 01:04:45.398343993 +0200
-@@ -280,13 +280,39 @@
+--- src/mouse.c.orig 2014-08-12 06:36:34 UTC
++++ src/mouse.c
+@@ -293,13 +293,39 @@ MouseCommonOptions(InputInfoPtr pInfo)
pMse = pInfo->private;
@@ -41,7 +41,7 @@
pMse->emulate3Buttons = xf86SetBoolOption(pInfo->options,
"Emulate3Buttons", FALSE);
if (!xf86FindOptionValue(pInfo->options,"Emulate3Buttons")) {
-@@ -298,6 +324,8 @@
+@@ -311,6 +337,8 @@ MouseCommonOptions(InputInfoPtr pInfo)
"Emulate3Timeout", 50);
if (pMse->emulate3Buttons || pMse->emulate3ButtonsSoft) {
MessageType from = X_CONFIG;
@@ -50,7 +50,7 @@
if (pMse->emulate3ButtonsSoft)
from = X_DEFAULT;
xf86Msg(from, "%s: Emulate3Buttons, Emulate3Timeout: %d\n",
-@@ -305,6 +333,8 @@
+@@ -318,6 +346,8 @@ MouseCommonOptions(InputInfoPtr pInfo)
}
pMse->chordMiddle = xf86SetBoolOption(pInfo->options, "ChordMiddle", FALSE);
@@ -59,7 +59,7 @@
pMse->flipXY = xf86SetBoolOption(pInfo->options, "FlipXY", FALSE);
if (xf86SetBoolOption(pInfo->options, "InvX", FALSE)) {
pMse->invX = -1;
-@@ -315,7 +345,7 @@
+@@ -328,7 +358,7 @@ MouseCommonOptions(InputInfoPtr pInfo)
} else
pMse->invY = 1;
pMse->angleOffset = xf86SetIntOption(pInfo->options, "AngleOffset", 0);
@@ -68,7 +68,7 @@
if (pMse->pDragLock)
free(pMse->pDragLock);
-@@ -425,14 +455,17 @@
+@@ -438,14 +468,17 @@ MouseCommonOptions(InputInfoPtr pInfo)
free(s);
}
@@ -88,7 +88,7 @@
pMse->negativeZ = pMse->positiveZ = MSE_MAPTOX;
msg = xstrdup("X axis");
} else if (!xf86NameCmp(s, "y")) {
-@@ -568,29 +601,6 @@
+@@ -594,29 +627,6 @@ MouseCommonOptions(InputInfoPtr pInfo)
pInfo->name, wheelButton, pMse->wheelInertia,
pMse->wheelButtonTimeout);
}
@@ -118,7 +118,7 @@
if (origButtons != pMse->buttons)
buttons_from = X_CONFIG;
xf86Msg(buttons_from, "%s: Buttons: %d\n", pInfo->name, pMse->buttons);
-@@ -668,7 +678,6 @@
+@@ -698,7 +708,6 @@ MouseHWOptions(InputInfoPtr pInfo)
}
pMse->sampleRate = xf86SetIntOption(pInfo->options, "SampleRate", 0);
pMse->resolution = xf86SetIntOption(pInfo->options, "Resolution", 0);
@@ -126,7 +126,7 @@
}
static void
-@@ -959,6 +968,8 @@
+@@ -986,6 +995,8 @@ MousePreInit(InputDriverPtr drv, InputIn
/* Default Mapping: 1 2 3 8 9 10 11 ... */
for (i = 0; i < MSE_MAXBUTTONS; i++)
pMse->buttonMap[i] = 1 << (i > 2 && i < MSE_MAXBUTTONS-4 ? i+4 : i);
@@ -135,7 +135,7 @@
protocol = MousePickProtocol(pInfo, device, protocol, &protocolID);
-@@ -2136,7 +2147,7 @@
+@@ -2181,7 +2192,7 @@ MouseDoPostEvent(InputInfoPtr pInfo, int
if (pMse->emulateWheel) {
/* Emulate wheel button handling */
@@ -144,7 +144,7 @@
wheelButtonMask = 0;
else
wheelButtonMask = 1 << (pMse->wheelButton - 1);
-@@ -2220,6 +2231,9 @@
+@@ -2271,6 +2282,9 @@ MouseDoPostEvent(InputInfoPtr pInfo, int
}
}
}
@@ -154,7 +154,7 @@
}
/* Absorb the mouse movement while the wheel button is pressed. */
-@@ -2237,7 +2251,7 @@
+@@ -2288,7 +2302,7 @@ MouseDoPostEvent(InputInfoPtr pInfo, int
if (pMse->emulate3ButtonsSoft && pMse->emulate3Pending && (dx || dy))
buttonTimer(pInfo);
@@ -163,7 +163,7 @@
xf86PostMotionEvent(pInfo->dev, 0, 0, 2, dx, dy);
if (change) {
-@@ -2349,12 +2363,10 @@
+@@ -2401,12 +2415,10 @@ MousePostEvent(InputInfoPtr pInfo, int t
int dx, int dy, int dz, int dw)
{
MouseDevPtr pMse;
@@ -176,7 +176,7 @@
if (pMse->protocolID == PROT_MMHIT)
b = reverseBits(hitachMap, truebuttons);
-@@ -2447,11 +2459,11 @@
+@@ -2499,11 +2511,11 @@ MousePostEvent(InputInfoPtr pInfo, int t
/* Accumulate the scaled dx, dy in the private variables
fracdx,fracdy and return the integer number part */
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src_mouse.h b/x11-drivers/xf86-input-mouse/files/patch-src_mouse.h
index abb2ac9565b2..2001c5b43698 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src_mouse.h
+++ b/x11-drivers/xf86-input-mouse/files/patch-src_mouse.h
@@ -1,6 +1,6 @@
---- src/mouse.h.orig 2012-07-27 08:10:56.000000000 +0200
-+++ src/mouse.h 2012-07-30 00:41:02.000000000 +0200
-@@ -217,10 +217,13 @@
+--- src/mouse.h.orig 2014-08-12 06:36:34 UTC
++++ src/mouse.h
+@@ -220,10 +220,13 @@ typedef struct _MouseDevRec {
Bool emulate3ButtonsSoft;
int emulate3Timeout;/* Timeout for 3 button emulation */
Bool chordMiddle;
@@ -14,7 +14,7 @@
int negativeZ; /* button mask */
int positiveZ; /* button mask */
int negativeW; /* button mask */
-@@ -259,6 +262,8 @@
+@@ -262,6 +265,8 @@ typedef struct _MouseDevRec {
int doubleClickOldSourceState;
int lastMappedButtons;
int buttonMap[MSE_MAXBUTTONS];
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src_mousePriv.h b/x11-drivers/xf86-input-mouse/files/patch-src_mousePriv.h
index 8abb8c3e83fc..d53173133fa7 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src_mousePriv.h
+++ b/x11-drivers/xf86-input-mouse/files/patch-src_mousePriv.h
@@ -1,6 +1,6 @@
---- src/mousePriv.h.orig 2012-07-27 08:10:56.000000000 +0200
-+++ src/mousePriv.h 2012-07-30 00:39:00.000000000 +0200
-@@ -63,8 +63,6 @@
+--- src/mousePriv.h.orig 2014-08-12 06:36:34 UTC
++++ src/mousePriv.h
+@@ -63,8 +63,6 @@ typedef struct {
int acc;
CARD32 pnpLast;
Bool disablePnPauto;
diff --git a/x11-drivers/xf86-input-synaptics/Makefile b/x11-drivers/xf86-input-synaptics/Makefile
index 064b462ba894..b6e5f64e4c73 100644
--- a/x11-drivers/xf86-input-synaptics/Makefile
+++ b/x11-drivers/xf86-input-synaptics/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-synaptics
-PORTVERSION= 1.7.4
-PORTREVISION= 3
+PORTVERSION= 1.8.2
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-input-synaptics/distinfo b/x11-drivers/xf86-input-synaptics/distinfo
index 47b09f20ac7f..1e3f7c49bbdb 100644
--- a/x11-drivers/xf86-input-synaptics/distinfo
+++ b/x11-drivers/xf86-input-synaptics/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-synaptics-1.7.4.tar.bz2) = 56a2d2df7bd39e29f56102c62f153e023f3e9b2f5e255309d33fab8e81945af7
-SIZE (xorg/driver/xf86-input-synaptics-1.7.4.tar.bz2) = 451614
+SHA256 (xorg/driver/xf86-input-synaptics-1.8.2.tar.bz2) = 7b0e164ebd02a680e0c695955e783059f37edb0c2656398e0a972adc8e698c80
+SIZE (xorg/driver/xf86-input-synaptics-1.8.2.tar.bz2) = 484261
diff --git a/x11-drivers/xf86-video-i740/Makefile b/x11-drivers/xf86-video-i740/Makefile
index 1fa29f88a72c..3efba7c01b21 100644
--- a/x11-drivers/xf86-video-i740/Makefile
+++ b/x11-drivers/xf86-video-i740/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-i740
-PORTVERSION= 1.3.4
-PORTREVISION= 5
+PORTVERSION= 1.3.5
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-i740/distinfo b/x11-drivers/xf86-video-i740/distinfo
index 1907b7d40e0a..9595d0b8566b 100644
--- a/x11-drivers/xf86-video-i740/distinfo
+++ b/x11-drivers/xf86-video-i740/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-video-i740-1.3.4.tar.bz2) = 1a24009bb2223b722fb41e1a2737a6e74bfecb0829e5583e270d267ee4ecca78
-SIZE (xorg/driver/xf86-video-i740-1.3.4.tar.bz2) = 316654
+SHA256 (xorg/driver/xf86-video-i740-1.3.5.tar.bz2) = 1ce02dd0a11fbf6b43b8bca6663c67149d7d740c8985ae18bd956eddeaffe324
+SIZE (xorg/driver/xf86-video-i740-1.3.5.tar.bz2) = 321050
diff --git a/x11-drivers/xf86-video-i740/files/patch-src_i740__driver.c b/x11-drivers/xf86-video-i740/files/patch-src_i740__driver.c
deleted file mode 100644
index b35e670aae0e..000000000000
--- a/x11-drivers/xf86-video-i740/files/patch-src_i740__driver.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/i740_driver.c.orig 2012-07-17 04:52:30 UTC
-+++ src/i740_driver.c
-@@ -63,10 +63,6 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN
-
- #include "compiler.h"
-
--/* Drivers using the mi implementation of backing store need: */
--
--#include "mibstore.h"
--
- /* All drivers using the vgahw module need this */
- /* This driver needs to be modified to not use vgaHW for multihead operation */
- #include "vgaHW.h"
-@@ -1558,7 +1554,6 @@ I740ScreenInit(SCREEN_INIT_ARGS_DECL) {
- }
- }
-
-- miInitializeBackingStore(pScreen);
- xf86SetBackingStore(pScreen);
- xf86SetSilkenMouse(pScreen);
-
diff --git a/x11-drivers/xf86-video-mga/Makefile b/x11-drivers/xf86-video-mga/Makefile
index ded2e09bcb2a..50de347658ea 100644
--- a/x11-drivers/xf86-video-mga/Makefile
+++ b/x11-drivers/xf86-video-mga/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-mga
-PORTVERSION= 1.6.3
-PORTREVISION= 5
+PORTVERSION= 1.6.4
PORTEPOCH= 3
CATEGORIES= x11-drivers
diff --git a/x11-drivers/xf86-video-mga/distinfo b/x11-drivers/xf86-video-mga/distinfo
index 69c06dacd5c6..a8fea5b4099d 100644
--- a/x11-drivers/xf86-video-mga/distinfo
+++ b/x11-drivers/xf86-video-mga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-video-mga-1.6.3.tar.bz2) = 7704b1ea35098769787a9c93e903b827be97a99facfb1696aa5236a58ff1c7d7
-SIZE (xorg/driver/xf86-video-mga-1.6.3.tar.bz2) = 454763
+SHA256 (xorg/driver/xf86-video-mga-1.6.4.tar.bz2) = 48c6690b6751c76f53de64f8dbeaa9d6c62dbcfe890c768fd87167951247d44f
+SIZE (xorg/driver/xf86-video-mga-1.6.4.tar.bz2) = 475858
diff --git a/x11-drivers/xf86-video-tdfx/Makefile b/x11-drivers/xf86-video-tdfx/Makefile
index 372e4b9acd7b..44934653d1a6 100644
--- a/x11-drivers/xf86-video-tdfx/Makefile
+++ b/x11-drivers/xf86-video-tdfx/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-tdfx
-PORTVERSION= 1.4.5
-PORTREVISION= 7
+PORTVERSION= 1.4.6
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-tdfx/distinfo b/x11-drivers/xf86-video-tdfx/distinfo
index c726ba67740a..91a5d711ee9d 100644
--- a/x11-drivers/xf86-video-tdfx/distinfo
+++ b/x11-drivers/xf86-video-tdfx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-video-tdfx-1.4.5.tar.bz2) = 70d5fbadfb60fc25e4f90f2a1aad258f64fa3953efbc1059103a8d845870d859
-SIZE (xorg/driver/xf86-video-tdfx-1.4.5.tar.bz2) = 339623
+SHA256 (xorg/driver/xf86-video-tdfx-1.4.6.tar.bz2) = 3a8a88867c40ad61f1c9a09ffd7ac64102fa821685855d50ce66c7603dcc6d37
+SIZE (xorg/driver/xf86-video-tdfx-1.4.6.tar.bz2) = 368300
diff --git a/x11-drivers/xf86-video-tdfx/files/patch-src_tdfx__driver.c b/x11-drivers/xf86-video-tdfx/files/patch-src_tdfx__driver.c
deleted file mode 100644
index b8f9003c3c55..000000000000
--- a/x11-drivers/xf86-video-tdfx/files/patch-src_tdfx__driver.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/tdfx_driver.c.orig 2012-07-17 05:21:16 UTC
-+++ src/tdfx_driver.c
-@@ -62,10 +62,6 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN
-
- #include "compiler.h"
-
--/* Drivers using the mi implementation of backing store need: */
--
--#include "mibstore.h"
--
- /* All drivers using the vgahw module need this */
- /* This driver needs to be modified to not use vgaHW for multihead operation */
- #include "vgaHW.h"
-@@ -2373,7 +2369,6 @@ TDFXScreenInit(SCREEN_INIT_ARGS_DECL) {
- }
- }
-
-- miInitializeBackingStore(pScreen);
- xf86SetBackingStore(pScreen);
- xf86SetSilkenMouse(pScreen);
-
diff --git a/x11-drivers/xf86-video-vmware/Makefile b/x11-drivers/xf86-video-vmware/Makefile
index 1fb5928e816a..07f5cf1ca3eb 100644
--- a/x11-drivers/xf86-video-vmware/Makefile
+++ b/x11-drivers/xf86-video-vmware/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-vmware
-PORTVERSION= 13.0.1
-PORTREVISION= 5
+PORTVERSION= 13.1.0
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-vmware/distinfo b/x11-drivers/xf86-video-vmware/distinfo
index 1265b6e3b2e8..da0c9d176441 100644
--- a/x11-drivers/xf86-video-vmware/distinfo
+++ b/x11-drivers/xf86-video-vmware/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-video-vmware-13.0.1.tar.bz2) = 802dda415c22412edad6c3df44fe18a06e91d0f8456d9a58bac0d340fdf8fe3d
-SIZE (xorg/driver/xf86-video-vmware-13.0.1.tar.bz2) = 432401
+SHA256 (xorg/driver/xf86-video-vmware-13.1.0.tar.bz2) = 3c1d244e4b1b77e92126957965cdc9fb82de4c215c0706a3a8aaff6939e4a0cc
+SIZE (xorg/driver/xf86-video-vmware-13.1.0.tar.bz2) = 459255