aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/binder/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-05-06 13:47:46 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-05-06 13:47:46 +0000
commit8a4b81194c1c9a497c2e84027c7d41be869c65e9 (patch)
tree031a630a61fe3cc0194ed2f25645bbcb75a69767 /x11-fm/binder/Makefile
parentb2104665fe60216163957a1946c3512fd2aa0e99 (diff)
downloadports-8a4b81194c1c9a497c2e84027c7d41be869c65e9.tar.gz
ports-8a4b81194c1c9a497c2e84027c7d41be869c65e9.zip
Notes
Diffstat (limited to 'x11-fm/binder/Makefile')
-rw-r--r--x11-fm/binder/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-fm/binder/Makefile b/x11-fm/binder/Makefile
new file mode 100644
index 000000000000..db93fad27e7b
--- /dev/null
+++ b/x11-fm/binder/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: JDE's Binder
+# Version required: 1.3
+# Date created: 25 March 1999
+# Whom: KIRIYAMA Kazuhiko <kiri@pis.toba-cmt.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= Binder-1.3
+PKGNAME= ${LANGPREFIX}binder-1.3
+CATEGORIES= ${CATEGORY_LIST}
+MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/JDE/dist/
+
+MAINTAINER= kiri@pis.toba-cmt.ac.jp
+
+RUN_DEPENDS= ${RUN_DEP_LIST}
+
+EXTRACT_ONLY= # extracted directly in install target
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_X_PREFIX= yes
+SCRIPTS_ENV= LANG=C LN=${LN} PERL=${PERL} LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
+PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
+
+# This port is for both x11-fm/binder and japanese/binder.
+# But x11-fm/binder and japanese/binder are mutually exclusive and
+# SHOULD NOT BE INSTALLED SIMULTANEOUSLY!
+TKSTEPVERSION= 8.0
+PIXMAPPATH?= ${PREFIX}/share/WindowMaker/Pixmaps
+LANGUAGE?=
+.if (${LANGUAGE} == "Japanese")
+LANGPREFIX= ja-
+CATEGORY_LIST= x11-fm windowmaker tkstep80 japanese
+RUN_DEP_LIST= ${LOCALBASE}/lib/Img1.2/libimg12.so.1:${PORTSDIR}/japanese/libimg \
+ ${LOCALBASE}/lib/tkstep8.0jp/tkstep.tcl:${PORTSDIR}/japanese/tkstep80
+.else
+CATEGORY_LIST= x11-fm windowmaker tkstep80
+RUN_DEP_LIST= ${LOCALBASE}/lib/Img1.2/libimg12.so.1:${PORTSDIR}/graphics/libimg \
+ ${LOCALBASE}/share/tkstep8.0/tkstep.tcl:${PORTSDIR}/x11-toolkits/tkstep80
+.endif
+
+do-install:
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTNAME}.tar.gz \
+ ${EXTRACT_AFTER_ARGS} -C ${PREFIX}
+ ${MKDIR} ${PIXMAPPATH}
+ ${INSTALL_DATA} ${PREFIX}/JDE/Binder/docs/Binder.xpm \
+ ${PREFIX}/JDE/Binder/misc/Mounter/DiskHardDrive.xpm \
+ ${PIXMAPPATH}
+
+.include <bsd.port.mk>