aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/doublecmd
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-03-22 19:33:08 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-03-22 19:33:08 +0000
commitea52a4dba6ba605051860199d04d1e73e2f18ab7 (patch)
tree66964936280829a8df01ac0c6d3376877e71c8fc /x11-fm/doublecmd
parentb4de3a0cdf87ed74e698119afc9736c489ab94d1 (diff)
downloadports-ea52a4dba6ba605051860199d04d1e73e2f18ab7.tar.gz
ports-ea52a4dba6ba605051860199d04d1e73e2f18ab7.zip
Notes
Diffstat (limited to 'x11-fm/doublecmd')
-rw-r--r--x11-fm/doublecmd/Makefile32
-rw-r--r--x11-fm/doublecmd/distinfo8
-rw-r--r--x11-fm/doublecmd/files/patch-src_platform_uosforms.pas29
3 files changed, 51 insertions, 18 deletions
diff --git a/x11-fm/doublecmd/Makefile b/x11-fm/doublecmd/Makefile
index cb073030500d..d928c8ad65b4 100644
--- a/x11-fm/doublecmd/Makefile
+++ b/x11-fm/doublecmd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= doublecmd
-PORTVERSION= 0.5.11
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= x11-fm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/Double%20Commander%20Source
@@ -34,7 +33,7 @@ LAZARUS_VER= 1.2.6
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d --pcp=${WRKSRC}/tmppcp
LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
-HELPVERSION= 0.5.5
+HELPVERSION= 0.6.0
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
DOCSRC= ${WRKDIR}/${PORTNAME}-help-${HELPVERSION}
@@ -49,8 +48,8 @@ WLX_DESC= Lister plugins
DSX_DESC= Search plugins
OPTIONS_GROUP_WCX= WCX_CPIO \
WCX_DEB \
- WCX_LZMA \
WCX_RPM \
+ WCX_UNBZ2 \
WCX_UNRAR \
WCX_ZIP
OPTIONS_GROUP_WDX= WDX_RPM \
@@ -66,7 +65,6 @@ OPTIONS_GROUP_DSX= DSX_LOCATE
OPTIONS_DEFAULT= GTK2 \
WCX_CPIO \
WCX_DEB \
- WCX_LZMA \
WCX_RPM \
WCX_UNRAR \
WCX_ZIP \
@@ -139,9 +137,9 @@ do-build:
@cd ${WRKSRC}/plugins && \
${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/deb/src/deb.lpi"
.endif
-.if ${PORT_OPTIONS:MWCX_LZMA}
+.if ${PORT_OPTIONS:MWCX_UNBZ2}
@cd ${WRKSRC}/plugins && \
- ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/lzma/src/lzma.lpi"
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/unbz2/src/unbz2.lpi"
.endif
.if ${PORT_OPTIONS:MWCX_RPM}
@cd ${WRKSRC}/plugins && \
@@ -201,18 +199,24 @@ post-build:
pre-install:
@${RM} -f ${PLIST}
+ @${ECHO_CMD} "@dir %%DATADIR%%/plugins/wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dir %%DATADIR%%/plugins/wdx" >> ${PLIST}
+ @${ECHO_CMD} "@dir %%DATADIR%%/plugins/wfx" >> ${PLIST}
+ @${ECHO_CMD} "@dir %%DATADIR%%/plugins/wlx" >> ${PLIST}
+ @${ECHO_CMD} "@dir %%DATADIR%%/plugins/dsx" >> ${PLIST}
+
.if ${PORT_OPTIONS:MWCX_CPIO}
@${ECHO_CMD} "%%DATADIR%%/plugins/wcx/cpio/cpio.wcx" >> ${PLIST}
.endif
.if ${PORT_OPTIONS:MWCX_DEB}
@${ECHO_CMD} "%%DATADIR%%/plugins/wcx/deb/deb.wcx" >> ${PLIST}
.endif
-.if ${PORT_OPTIONS:MWCX_LZMA}
- @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/lzma/lzma.wcx" >> ${PLIST}
-.endif
.if ${PORT_OPTIONS:MWCX_RPM}
@${ECHO_CMD} "%%DATADIR%%/plugins/wcx/rpm/rpm.wcx" >> ${PLIST}
.endif
+.if ${PORT_OPTIONS:MWCX_UNBZ2}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/unbz2/unbz2.wcx" >> ${PLIST}
+.endif
.if ${PORT_OPTIONS:MWCX_UNRAR}
@${ECHO_CMD} "%%DATADIR%%/plugins/wcx/unrar/unrar.wcx" >> ${PLIST}
.endif
@@ -285,14 +289,14 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/plugins/wcx/deb
${INSTALL_LIB} ${WRKSRC}/plugins/wcx/deb/lib/deb.wcx ${STAGEDIR}${DATADIR}/plugins/wcx/deb/
.endif
-.if ${PORT_OPTIONS:MWCX_LZMA}
- @${MKDIR} ${STAGEDIR}${DATADIR}/plugins/wcx/lzma/
- ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/lzma/lib/lzma.wcx ${STAGEDIR}${DATADIR}/plugins/wcx/lzma/
-.endif
.if ${PORT_OPTIONS:MWCX_RPM}
@${MKDIR} ${STAGEDIR}${DATADIR}/plugins/wcx/rpm/
${INSTALL_LIB} ${WRKSRC}/plugins/wcx/rpm/lib/rpm.wcx ${STAGEDIR}${DATADIR}/plugins/wcx/rpm/
.endif
+.if ${PORT_OPTIONS:MWCX_UNBZ2}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/plugins/wcx/unbz2/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/unbz2/lib/unbz2.wcx ${STAGEDIR}${DATADIR}/plugins/wcx/unbz2/
+.endif
.if ${PORT_OPTIONS:MWCX_UNRAR}
@${MKDIR} ${STAGEDIR}${DATADIR}/plugins/wcx/unrar/
${INSTALL_LIB} ${WRKSRC}/plugins/wcx/unrar/lib/unrar.wcx ${STAGEDIR}${DATADIR}/plugins/wcx/unrar/
diff --git a/x11-fm/doublecmd/distinfo b/x11-fm/doublecmd/distinfo
index e55c0322630a..d1e1217d101e 100644
--- a/x11-fm/doublecmd/distinfo
+++ b/x11-fm/doublecmd/distinfo
@@ -1,4 +1,4 @@
-SHA256 (doublecmd-0.5.11-src.tar.gz) = a7d31243f9e8fc69ed6854a264d78ee59bfe3dd89e2bb19043c715e3b3d114ea
-SIZE (doublecmd-0.5.11-src.tar.gz) = 4753635
-SHA256 (doublecmd-help-0.5.5-src.tar.gz) = 5c5d00187df811df0734bf751a581bce7e1bdd4cf4639b2a1101f1da8743daaf
-SIZE (doublecmd-help-0.5.5-src.tar.gz) = 10762769
+SHA256 (doublecmd-0.6.0-src.tar.gz) = 809b182eb03ed3a07f21d6690f0289ab80eefbe3ca0a998efe65742d5f0c4a4f
+SIZE (doublecmd-0.6.0-src.tar.gz) = 6443975
+SHA256 (doublecmd-help-0.6.0-src.tar.gz) = d50a58f0e8c25c07720f2afd987213f330dfce268e2aef349d1da3de2eef1c39
+SIZE (doublecmd-help-0.6.0-src.tar.gz) = 11514996
diff --git a/x11-fm/doublecmd/files/patch-src_platform_uosforms.pas b/x11-fm/doublecmd/files/patch-src_platform_uosforms.pas
new file mode 100644
index 000000000000..44ac5dfd7def
--- /dev/null
+++ b/x11-fm/doublecmd/files/patch-src_platform_uosforms.pas
@@ -0,0 +1,29 @@
+--- src/platform/uosforms.pas.orig 2014-07-27 14:35:14 UTC
++++ src/platform/uosforms.pas
+@@ -96,7 +96,7 @@ procedure ShowDriveContextMenu(Parent: T
+ }
+ function ShowOpenIconDialog(Owner: TCustomControl; var sFileName : String) : Boolean;
+
+-{$IF DEFINED(LINUX)}
++{$IF DEFINED(UNIX) AND NOT DEFINED(DARWIN)}
+ {en
+ Show open with dialog
+ @param(FileList List of files to open with)
+@@ -121,7 +121,7 @@ uses
+ {$ELSE}
+ , MacOSAll
+ {$ENDIF}
+- {$IFDEF LINUX}
++ {$IF NOT DEFINED(DARWIN)}
+ , fOpenWith, uKde
+ {$ENDIF}
+ {$ENDIF};
+@@ -547,7 +547,7 @@ begin
+ FreeAndNil(opdDialog);
+ end;
+
+-{$IF DEFINED(LINUX)}
++{$IF DEFINED(UNIX) AND NOT DEFINED(DARWIN)}
+ procedure ShowOpenWithDialog(const FileList: TStringList);
+ begin
+ if not (UseKde and uKde.ShowOpenWithDialog(FileList)) then begin