aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/emelfm2/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:49:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:49:38 +0000
commitca2db075882e53d0366a90c16433dc843a81313a (patch)
tree080e00e879cbc67e37769a2dd2bd42ccce5d8421 /x11-fm/emelfm2/Makefile
parentf8f6c822b606a887620b757a853823472eda5364 (diff)
downloadports-ca2db075882e53d0366a90c16433dc843a81313a.tar.gz
ports-ca2db075882e53d0366a90c16433dc843a81313a.zip
Notes
Diffstat (limited to 'x11-fm/emelfm2/Makefile')
-rw-r--r--x11-fm/emelfm2/Makefile45
1 files changed, 43 insertions, 2 deletions
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
index 2a36f6208fe3..25c397132cf4 100644
--- a/x11-fm/emelfm2/Makefile
+++ b/x11-fm/emelfm2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= emelfm2
-PORTVERSION= 0.3.3
-PORTREVISION= 1
+PORTVERSION= 0.3.4
CATEGORIES= x11-fm
MASTER_SITES= http://www.emelfm2.net/rel/ \
${MASTER_SITE_LOCAL}
@@ -28,8 +27,50 @@ LDFLAGS+= ${PTHREAD_LIBS}
MAKE_ENV= CC=${CC} LDFLAGS="${LDFLAGS}" DOC_DIR="${DOCSDIR}/"
MAN1= emelfm2.1
+OPTIONS= DEBUG "Enable debugging messages" off \
+ GAMIN "Enable Gamin for file monitoring" off \
+ FAM "Enable FAM for file monitoring" off \
+ THUMB "Enable the thumbnail plugin" off \
+ TRACKER "Enable the tracker plugin" off \
+ NLS "Enable gettext support" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_DEBUG)
+MAK_ENV+= DEBUG=1
+.endif
+
+.if defined(WITH_GAMIN) && defined(WITH_FAM)
+BROKEN= "WITH_GAMIN and WITH_FAM cannot be enabled at the same time for this port"
+.endif
+
+.if defined(WITH_GAMIN)
+USE_FAM= yes
+WANT_FAM_SYSTEM=gamin
+MAKE_ENV+= USE_GAMIN=1
+.endif
+
+.if defined(WITH_FAM)
+USE_FAM= yes
+WANT_FAM_SYSTEM=fam
+MAKE_ENV+= USE_FAM=1
+.endif
+
+.if defined(WITH_THUMB)
+LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp
+MAKE_ENV+= WITH_THUMB=1
+PLIST_SUB+= THUMB=""
+.else
+PLIST_SUB+= THUMB="@comment "
+.endif
+
+.if defined(WITH_TRACKER)
+MAKE_ENV+= WITH_TRACKER=1
+PLIST_SUB+= TRACKER=""
+.else
+PLIST_SUB+= TRACKER="@comment "
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
INSTALL_TARGET+=install_i18n