aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/emelfm2/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-12-07 18:31:48 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-12-07 18:31:48 +0000
commit8ce0f9ca47caa441a7ab4887e2bfbdbc9753d87c (patch)
treeb7fe680cb1935e9dd69ef6f401f9fd2826484d80 /x11-fm/emelfm2/Makefile
parent0b8d74f7587c67e034a3a19fffeaa60fb4fb0f57 (diff)
Notes
Diffstat (limited to 'x11-fm/emelfm2/Makefile')
-rw-r--r--x11-fm/emelfm2/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
new file mode 100644
index 000000000000..73232d04d27c
--- /dev/null
+++ b/x11-fm/emelfm2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: emelfm2
+# Date created: 01 Novemeber 2003
+# Whom: Marcus von Appen
+#
+# $FreeBSD$
+#
+
+PORTNAME= emelfm2
+PORTVERSION= 0.0.3
+CATEGORIES= x11-fm
+MASTER_SITES= http://dasui.prima.de/~tooar/
+
+MAINTAINER= mva@sysfault.org
+COMMENT= The gtk2 port of emelfm, a fast graphical filemanager
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GCC= 3.3
+USE_GETOPT_LONG=yes
+INSTALLS_SHLIB= yes
+
+MAKE_ENV= CC=${CC} LDLIBS="${LDFLAGS}" DOCSDIR="${DOCSDIR}"
+
+PLUGINDIR= ${WRKSRC}/objs/plugins
+PLUGINS= cdburner.so clone.so copy_to_clipboard.so du.so for_each.so \
+ glob.so pack.so rename_ext.so sort_by_ext.so unpack.so view.so
+
+.if defined(NOPORTDOCS)
+do-install::
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.for pfile in ${PLUGINS}
+ @${MKDIR} ${PREFIX}/lib/emelfm2/plugins
+ ${INSTALL_PROGRAM} ${PLUGINDIR}/${pfile} ${PREFIX}/lib/emelfm2/plugins
+.endfor
+.endif
+
+.include <bsd.port.mk>