aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/gentoo/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-10 15:46:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-10 15:46:00 +0000
commit5cf6fb6e264d1961af4e4ed2f8f85fb8928b4ae1 (patch)
tree014f224e53c95cf097d2268d19e24a3aaa197d7d /x11-fm/gentoo/Makefile
parentc5831866db4afd4f9590ccded2df027c5beb7fe1 (diff)
downloadports-5cf6fb6e264d1961af4e4ed2f8f85fb8928b4ae1.tar.gz
ports-5cf6fb6e264d1961af4e4ed2f8f85fb8928b4ae1.zip
Notes
Diffstat (limited to 'x11-fm/gentoo/Makefile')
-rw-r--r--x11-fm/gentoo/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-fm/gentoo/Makefile b/x11-fm/gentoo/Makefile
index 50a630cd034c..2d9cef3aabb7 100644
--- a/x11-fm/gentoo/Makefile
+++ b/x11-fm/gentoo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gentoo
-PORTVERSION= 0.11.49
+PORTVERSION= 0.11.51
CATEGORIES= x11-fm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,6 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-fam
MAN1= gentoo.1
@@ -34,6 +33,12 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if defined(WITH_FAM)
+LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
+.else
+CONFIGURE_ARGS+= --disable-fam
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|^CFLAGS = @GENTOO_CFLAGS@|CFLAGS = @CFLAGS@|g' \