aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nautilus/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /x11-fm/nautilus/Makefile
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
Notes
Diffstat (limited to 'x11-fm/nautilus/Makefile')
-rw-r--r--x11-fm/nautilus/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index df3c9a8c157f..0dd6ac8f5785 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -1,9 +1,8 @@
# Created by: ade, archie
# $FreeBSD$
-# $MCom: ports/trunk/x11-fm/nautilus/Makefile 20076 2014-11-13 08:59:08Z gusi $
PORTNAME= nautilus
-PORTVERSION= 3.14.2
+PORTVERSION= 3.16.2
CATEGORIES= x11-fm gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,15 +18,15 @@ LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+PORTSCOUT= limitw:1,even
+
USES= desktop-file-utils gettext gmake libtool pathfix \
- pkgconfig shared-mime-info tar:xz
-USE_GNOME= gnomeprefix intlhack gnomedesktop3 libxml2 \
- gvfs introspection:build
+ pkgconfig tar:xz
+USE_GNOME= intlhack gnomedesktop3 libxml2 gvfs introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LIBS="-pthread"
CONFIGURE_ARGS= --disable-packagekit
INSTALL_TARGET= install-strip
@@ -40,8 +39,4 @@ TRACKER_DESC= Tracker support
TRACKER_LIB_DEPENDS= libtracker-control-1.0.so:${PORTSDIR}/sysutils/tracker
TRACKER_CONFIGURE_ENABLE= tracker
-post-patch:
- @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>