aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nautilus/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-01-12 19:59:39 +0000
committerAde Lovett <ade@FreeBSD.org>2001-01-12 19:59:39 +0000
commit8d590d9928b801e3fa9dfbd457a954a701a2de9f (patch)
tree0248b61f6e409b6fcefe5d04976412b55b944392 /x11-fm/nautilus/Makefile
parent8eab677955e80c4559cf3e5a5eb89ed3c72574e6 (diff)
downloadports-8d590d9928b801e3fa9dfbd457a954a701a2de9f.tar.gz
ports-8d590d9928b801e3fa9dfbd457a954a701a2de9f.zip
Notes
Diffstat (limited to 'x11-fm/nautilus/Makefile')
-rw-r--r--x11-fm/nautilus/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index b270ce8b42c6..2a97c4d2a8fa 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nautilus
-PORTVERSION= 0.1.0
-PORTREVISION= 2
+PORTVERSION= 0.5
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/nautilus
@@ -18,9 +17,8 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/misc/rpm
LIB_DEPENDS= medusa.0:${PORTSDIR}/sysutils/medusa \
gtkhtml.6:${PORTSDIR}/www/gtkhtml \
ghttp.1:${PORTSDIR}/www/libghttp \
- bz2.1:${PORTSDIR}/archivers/bzip2
-
-BROKEN= "Build failures with new bonobo"
+ bz2.1:${PORTSDIR}/archivers/bzip2 \
+ freetype.6:${PORTSDIR}/print/freetype2
.if defined(WITH_MOZILLA)
MOZILLA= mozilla-embedded
@@ -35,6 +33,8 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-pthread -L${LOCALBASE}/lib" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}"
+CONFIGURE_ARGS= --with-freetype2-lib-place=${LOCALBASE}/lib \
+ --with-freetype2-include-place=${LOCALBASE}/include/freetype2
.if defined(WITH_MOZILLA)
CONFIGURE_ARGS+= --with-mozilla-lib-place=${X11BASE}/lib/${MOZILLA} \
@@ -42,6 +42,7 @@ CONFIGURE_ARGS+= --with-mozilla-lib-place=${X11BASE}/lib/${MOZILLA} \
MOZILLA_LIBS= "-L${X11BASE}/lib/${MOZILLA}"
PLIST_SUB+= MOZILLA:=""
.else
+CONFIGURE_ARGS+= --disable-mozilla-component
MOZILLA_LIBS= ""
PLIST_SUB+= MOZILLA:="@comment "
.endif