aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nautilus2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /x11-fm/nautilus2/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Notes
Diffstat (limited to 'x11-fm/nautilus2/Makefile')
-rw-r--r--x11-fm/nautilus2/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index 3e6398200b0f..b77b277daaa2 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -3,15 +3,14 @@
# Whom: ade, archie
#
# $FreeBSD$
-# $MCom: ports/x11-fm/nautilus2/Makefile,v 1.90 2005/10/03 16:24:38 marcus Exp $
+# $MCom: ports/x11-fm/nautilus2/Makefile,v 1.105 2006/04/13 07:52:42 bland Exp $
#
PORTNAME= nautilus2
-PORTVERSION= 2.12.2
-PORTREVISION= 1
+PORTVERSION= 2.14.1
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= nautilus-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,13 +21,13 @@ LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop eel2 \
librsvg2 desktopfileutils
GNOME_DESKTOP_VERSION=2
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -liconv" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz"