aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nautilus
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-fm/nautilus
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'x11-fm/nautilus')
-rw-r--r--x11-fm/nautilus/Makefile56
-rw-r--r--x11-fm/nautilus/distinfo4
-rw-r--r--x11-fm/nautilus/files/patch-data_nautilus.desktop.in.in8
-rw-r--r--x11-fm/nautilus/files/patch-src_file-manager_fm-properties-window.c12
-rw-r--r--x11-fm/nautilus/pkg-plist196
5 files changed, 55 insertions, 221 deletions
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index f319dbb79ab9..7377f91d6f9c 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -1,49 +1,47 @@
# Created by: ade, archie
# $FreeBSD$
-# $MCom: ports/x11-fm/nautilus/Makefile,v 1.212 2012/09/03 16:28:29 mezz Exp $
+# $MCom: ports/trunk/x11-fm/nautilus/Makefile 19960 2014-10-15 14:24:24Z gusi $
PORTNAME= nautilus
-PORTVERSION= 2.32.2.1
-PORTREVISION= 7
+PORTVERSION= 3.14.0
CATEGORIES= x11-fm gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT?= File manager for the GNOME desktop
+COMMENT= File manager for the GNOME desktop
+BUILD_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif \
- libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
libexempi.so:${PORTSDIR}/textproc/exempi
+RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
-CONFLICTS= nautilus-3.[0-9]*
-
-INSTALLS_ICONS= yes
-USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
- pkgconfig shared-mime-info tar:bzip2
-USE_GNOME= gnomeprefix intlhack gnomedesktop \
- librsvg2 gvfs introspection:build
-INSTALL_TARGET= install-strip
+USES= desktop-file-utils gettext gmake libtool pathfix \
+ pkgconfig shared-mime-info tar:xz
+USE_GNOME= gnomeprefix intlhack gnomedesktop3 libxml2 \
+ gvfs introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBPNG="-L${LOCALBASE}/lib -lpng -lz" \
- EXTRA_CORE_MODULES="gmodule-2.0"
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-CONFIGURE_ARGS= --enable-static --disable-packagekit --disable-update-mimedb
-MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LIBS="-pthread"
+CONFIGURE_ARGS= --disable-packagekit
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.gnome.nautilus.gschema.xml
-GCONF_SCHEMAS= apps_nautilus_preferences.schemas
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= TRACKER
+OPTIONS_DEFAULT=TRACKER
+TRACKER_DESC= Tracker support
+TRACKER_LIB_DEPENDS= libtracker-control-1.0.so:${PORTSDIR}/sysutils/tracker
+TRACKER_CONFIGURE_ENABLE= tracker
post-patch:
- @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
- ${WRKSRC}/eel/eel-*.[ch] \
- ${WRKSRC}/libnautilus-private/*.[ch] \
- ${WRKSRC}/src/nautilus-zoom-control.c
- @${REINPLACE_CMD} -e 's|-DG_DISABLE_DEPRECATED||g' \
- ${WRKSRC}/configure ${WRKSRC}/eel/Makefile.in
-
-post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/nautilus/extensions-2.0
+ @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11-fm/nautilus/distinfo b/x11-fm/nautilus/distinfo
index 462ba68884af..2c7fe8981c67 100644
--- a/x11-fm/nautilus/distinfo
+++ b/x11-fm/nautilus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/nautilus-2.32.2.1.tar.bz2) = 802dacc98c697afea2e6201dab1c8c800809f235fff39857983efb4340ecc303
-SIZE (gnome2/nautilus-2.32.2.1.tar.bz2) = 6350203
+SHA256 (gnome3/nautilus-3.14.0.tar.xz) = 6f909ed9afa9abffe489b80b57888bd7bc7acea2cf48717c54362bd3b6aee0d4
+SIZE (gnome3/nautilus-3.14.0.tar.xz) = 3332224
diff --git a/x11-fm/nautilus/files/patch-data_nautilus.desktop.in.in b/x11-fm/nautilus/files/patch-data_nautilus.desktop.in.in
deleted file mode 100644
index 448a4f6b0035..000000000000
--- a/x11-fm/nautilus/files/patch-data_nautilus.desktop.in.in
+++ /dev/null
@@ -1,8 +0,0 @@
---- data/nautilus.desktop.in.in.orig 2009-04-25 17:13:18.000000000 -0400
-+++ data/nautilus.desktop.in.in 2009-04-25 17:13:32.000000000 -0400
-@@ -15,4 +15,5 @@ X-GNOME-Bugzilla-Version=@VERSION@
- X-GNOME-Autostart-Phase=Desktop
- X-GNOME-Autostart-Notify=true
- X-GNOME-AutoRestart=true
-+AutostartCondition=GNOME /apps/nautilus/preferences/show_desktop
- X-GNOME-Provides=filemanager
diff --git a/x11-fm/nautilus/files/patch-src_file-manager_fm-properties-window.c b/x11-fm/nautilus/files/patch-src_file-manager_fm-properties-window.c
deleted file mode 100644
index d709dec1e833..000000000000
--- a/x11-fm/nautilus/files/patch-src_file-manager_fm-properties-window.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/file-manager/fm-properties-window.c.orig Mon May 14 20:58:01 2007
-+++ src/file-manager/fm-properties-window.c Mon May 14 20:58:42 2007
-@@ -89,9 +89,7 @@
- #if HAVE_SYS_VFS_H
- #include <sys/vfs.h>
- #elif HAVE_SYS_MOUNT_H
--#if HAVE_SYS_PARAM_H
- #include <sys/param.h>
--#endif
- #include <sys/mount.h>
- #endif
-
diff --git a/x11-fm/nautilus/pkg-plist b/x11-fm/nautilus/pkg-plist
index badb680d4f4a..79784412393f 100644
--- a/x11-fm/nautilus/pkg-plist
+++ b/x11-fm/nautilus/pkg-plist
@@ -1,7 +1,7 @@
bin/nautilus
bin/nautilus-autorun-software
bin/nautilus-connect-server
-bin/nautilus-file-management-properties
+etc/xdg/autostart/nautilus-autostart.desktop
include/nautilus/libnautilus-extension/nautilus-column-provider.h
include/nautilus/libnautilus-extension/nautilus-column.h
include/nautilus/libnautilus-extension/nautilus-extension-types.h
@@ -13,54 +13,50 @@ include/nautilus/libnautilus-extension/nautilus-menu-provider.h
include/nautilus/libnautilus-extension/nautilus-menu.h
include/nautilus/libnautilus-extension/nautilus-property-page-provider.h
include/nautilus/libnautilus-extension/nautilus-property-page.h
-lib/girepository-1.0/Nautilus-2.0.typelib
-lib/libnautilus-extension.a
-lib/libnautilus-extension.la
+lib/girepository-1.0/Nautilus-3.0.typelib
lib/libnautilus-extension.so
lib/libnautilus-extension.so.1
-lib/libnautilus-extension.so.1.2.0
+lib/libnautilus-extension.so.1.4.0
+lib/nautilus/extensions-3.0/libnautilus-sendto.so
libexec/nautilus-convert-metadata
libdata/pkgconfig/libnautilus-extension.pc
man/man1/nautilus-connect-server.1.gz
-man/man1/nautilus-file-management-properties.1.gz
man/man1/nautilus.1.gz
+share/GConf/gsettings/nautilus.convert
+share/appdata/org.gnome.Nautilus.appdata.xml
share/applications/nautilus-autorun-software.desktop
-share/applications/nautilus-browser.desktop
-share/applications/nautilus-computer.desktop
-share/applications/nautilus-file-management-properties.desktop
-share/applications/nautilus-folder-handler.desktop
-share/applications/nautilus-home.desktop
-share/applications/nautilus.desktop
-share/applications/network-scheme.desktop
+share/applications/nautilus-classic.desktop
+share/applications/nautilus-connect-server.desktop
+share/applications/org.gnome.Nautilus.desktop
+share/dbus-1/services/org.freedesktop.FileManager1.service
+share/dbus-1/services/org.gnome.Nautilus.service
share/doc/libnautilus-extension/ch01.html
share/doc/libnautilus-extension/home.png
share/doc/libnautilus-extension/index.html
share/doc/libnautilus-extension/index.sgml
share/doc/libnautilus-extension/ix01.html
+share/doc/libnautilus-extension/left-insensitive.png
share/doc/libnautilus-extension/left.png
-share/doc/libnautilus-extension/libnautilus-extension.devhelp
share/doc/libnautilus-extension/libnautilus-extension.devhelp2
-share/doc/libnautilus-extension/libnautilus-extension-nautilus-column.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-column-provider.html
+share/doc/libnautilus-extension/libnautilus-extension-nautilus-column.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-extension-types.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-file-info.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-info-provider.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-location-widget-provider.html
-share/doc/libnautilus-extension/libnautilus-extension-nautilus-menu.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-menu-provider.html
+share/doc/libnautilus-extension/libnautilus-extension-nautilus-menu.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-property-page.html
share/doc/libnautilus-extension/libnautilus-extension-nautilus-property-page-provider.html
share/doc/libnautilus-extension/pt01.html
+share/doc/libnautilus-extension/right-insensitive.png
share/doc/libnautilus-extension/right.png
share/doc/libnautilus-extension/style.css
+share/doc/libnautilus-extension/up-insensitive.png
share/doc/libnautilus-extension/up.png
-share/gir-1.0/Nautilus-2.0.gir
-share/icons/hicolor/16x16/apps/nautilus.png
-share/icons/hicolor/22x22/apps/nautilus.png
-share/icons/hicolor/24x24/apps/nautilus.png
-share/icons/hicolor/32x32/apps/nautilus.png
-share/icons/hicolor/scalable/apps/nautilus.svg
+share/gir-1.0/Nautilus-3.0.gir
share/locale/af/LC_MESSAGES/nautilus.mo
+share/locale/an/LC_MESSAGES/nautilus.mo
share/locale/am/LC_MESSAGES/nautilus.mo
share/locale/ar/LC_MESSAGES/nautilus.mo
share/locale/as/LC_MESSAGES/nautilus.mo
@@ -71,6 +67,7 @@ share/locale/be@latin/LC_MESSAGES/nautilus.mo
share/locale/bg/LC_MESSAGES/nautilus.mo
share/locale/bn/LC_MESSAGES/nautilus.mo
share/locale/bn_IN/LC_MESSAGES/nautilus.mo
+share/locale/bo/LC_MESSAGES/nautilus.mo
share/locale/br/LC_MESSAGES/nautilus.mo
share/locale/bs/LC_MESSAGES/nautilus.mo
share/locale/ca/LC_MESSAGES/nautilus.mo
@@ -92,9 +89,10 @@ share/locale/eu/LC_MESSAGES/nautilus.mo
share/locale/fa/LC_MESSAGES/nautilus.mo
share/locale/fi/LC_MESSAGES/nautilus.mo
share/locale/fr/LC_MESSAGES/nautilus.mo
-share/locale/fy/LC_MESSAGES/nautilus.mo
share/locale/fur/LC_MESSAGES/nautilus.mo
+share/locale/fy/LC_MESSAGES/nautilus.mo
share/locale/ga/LC_MESSAGES/nautilus.mo
+share/locale/gd/LC_MESSAGES/nautilus.mo
share/locale/gl/LC_MESSAGES/nautilus.mo
share/locale/gu/LC_MESSAGES/nautilus.mo
share/locale/gv/LC_MESSAGES/nautilus.mo
@@ -116,6 +114,7 @@ share/locale/km/LC_MESSAGES/nautilus.mo
share/locale/kn/LC_MESSAGES/nautilus.mo
share/locale/ko/LC_MESSAGES/nautilus.mo
share/locale/ku/LC_MESSAGES/nautilus.mo
+share/locale/ky/LC_MESSAGES/nautilus.mo
share/locale/li/LC_MESSAGES/nautilus.mo
share/locale/lt/LC_MESSAGES/nautilus.mo
share/locale/lv/LC_MESSAGES/nautilus.mo
@@ -127,6 +126,7 @@ share/locale/ml/LC_MESSAGES/nautilus.mo
share/locale/mn/LC_MESSAGES/nautilus.mo
share/locale/mr/LC_MESSAGES/nautilus.mo
share/locale/ms/LC_MESSAGES/nautilus.mo
+share/locale/my/LC_MESSAGES/nautilus.mo
share/locale/nb/LC_MESSAGES/nautilus.mo
share/locale/nds/LC_MESSAGES/nautilus.mo
share/locale/ne/LC_MESSAGES/nautilus.mo
@@ -153,6 +153,7 @@ share/locale/sr@ije/LC_MESSAGES/nautilus.mo
share/locale/sv/LC_MESSAGES/nautilus.mo
share/locale/ta/LC_MESSAGES/nautilus.mo
share/locale/te/LC_MESSAGES/nautilus.mo
+share/locale/tg/LC_MESSAGES/nautilus.mo
share/locale/th/LC_MESSAGES/nautilus.mo
share/locale/tk/LC_MESSAGES/nautilus.mo
share/locale/tr/LC_MESSAGES/nautilus.mo
@@ -169,151 +170,6 @@ share/locale/zh_CN/LC_MESSAGES/nautilus.mo
share/locale/zh_HK/LC_MESSAGES/nautilus.mo
share/locale/zh_TW/LC_MESSAGES/nautilus.mo
share/locale/zu/LC_MESSAGES/nautilus.mo
+share/gnome-shell/search-providers/nautilus-search-provider.ini
+share/mime/application/x-gnome-saved-search.xml
share/mime/packages/nautilus.xml
-%%DATADIR%%/browser.xml
-%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-note.png
-%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-note.png
-%%DATADIR%%/icons/hicolor/48x48/emblems/emblem-note.png
-%%DATADIR%%/nautilus-extras.placeholder
-%%DATADIR%%/nautilus-suggested.placeholder
-%%DATADIR%%/patterns/blue_gray_rough.png
-%%DATADIR%%/patterns/blue_ridge.png
-%%DATADIR%%/patterns/blue_type.png
-%%DATADIR%%/patterns/brushed_metal.png
-%%DATADIR%%/patterns/burlap.jpg
-%%DATADIR%%/patterns/camouflage.png
-%%DATADIR%%/patterns/chalk.jpg
-%%DATADIR%%/patterns/cork.png
-%%DATADIR%%/patterns/countertop.png
-%%DATADIR%%/patterns/dark-gnome.jpg
-%%DATADIR%%/patterns/dots.png
-%%DATADIR%%/patterns/fibers.png
-%%DATADIR%%/patterns/fleur_de_lis.png
-%%DATADIR%%/patterns/floral.png
-%%DATADIR%%/patterns/fossil.png
-%%DATADIR%%/patterns/gnome.jpg
-%%DATADIR%%/patterns/green_weave.png
-%%DATADIR%%/patterns/ice.png
-%%DATADIR%%/patterns/manila_paper.png
-%%DATADIR%%/patterns/moss_ridge.png
-%%DATADIR%%/patterns/numbers.png
-%%DATADIR%%/patterns/ocean_stripes.png
-%%DATADIR%%/patterns/purple_marble.png
-%%DATADIR%%/patterns/reset.png
-%%DATADIR%%/patterns/ridged_paper.png
-%%DATADIR%%/patterns/rough_paper.png
-%%DATADIR%%/patterns/sky_ridge.png
-%%DATADIR%%/patterns/snow_ridge.png
-%%DATADIR%%/patterns/stucco.jpg
-%%DATADIR%%/patterns/terracotta.png
-%%DATADIR%%/patterns/wavy_white.png
-%%DATADIR%%/ui/nautilus-bookmarks-window.ui
-%%DATADIR%%/ui/nautilus-file-management-properties.ui
-%%DATADIR%%/ui/nautilus-desktop-icon-view-ui.xml
-%%DATADIR%%/ui/nautilus-directory-view-ui.xml
-%%DATADIR%%/ui/nautilus-icon-view-ui.xml
-%%DATADIR%%/ui/nautilus-list-view-ui.xml
-%%DATADIR%%/ui/nautilus-navigation-window-ui.xml
-%%DATADIR%%/ui/nautilus-shell-ui.xml
-%%DATADIR%%/ui/nautilus-spatial-window-ui.xml
-share/pixmaps/nautilus/audio.svg
-share/pixmaps/nautilus/backgrounds.png
-share/pixmaps/nautilus/chit_frame.png
-share/pixmaps/nautilus/colors.png
-share/pixmaps/nautilus/emblems.png
-share/pixmaps/nautilus/erase.png
-share/pixmaps/nautilus/knob.png
-share/pixmaps/nautilus/thumbnail_frame.png
-@dirrm share/pixmaps/nautilus
-@dirrm %%DATADIR%%/ui
-@dirrm %%DATADIR%%/patterns
-@dirrmtry %%DATADIR%%/icons/hicolor/48x48/emblems
-@dirrmtry %%DATADIR%%/icons/hicolor/48x48
-@dirrmtry %%DATADIR%%/icons/hicolor/24x24/emblems
-@dirrmtry %%DATADIR%%/icons/hicolor/24x24
-@dirrmtry %%DATADIR%%/icons/hicolor/16x16/emblems
-@dirrmtry %%DATADIR%%/icons/hicolor/16x16
-@dirrmtry %%DATADIR%%/icons/hicolor
-@dirrmtry %%DATADIR%%/icons
-@dirrm %%DATADIR%%
-@dirrmtry lib/nautilus/extensions-2.0
-@dirrmtry lib/nautilus
-@dirrm include/nautilus/libnautilus-extension
-@dirrm include/nautilus
-@dirrm share/doc/libnautilus-extension
-@dirrmtry share/locale/zu/LC_MESSAGES
-@dirrmtry share/locale/zu
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/yo/LC_MESSAGES
-@dirrmtry share/locale/yo
-@dirrmtry share/locale/yi/LC_MESSAGES
-@dirrmtry share/locale/yi
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
-@dirrmtry share/locale/uz@cyrillic
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/sr@ije/LC_MESSAGES
-@dirrmtry share/locale/sr@ije
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/nso/LC_MESSAGES
-@dirrmtry share/locale/nso
-@dirrmtry share/locale/nds/LC_MESSAGES
-@dirrmtry share/locale/nds
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mi/LC_MESSAGES
-@dirrmtry share/locale/mi
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/km/LC_MESSAGES
-@dirrmtry share/locale/km
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/io/LC_MESSAGES
-@dirrmtry share/locale/io
-@dirrmtry share/locale/ig/LC_MESSAGES
-@dirrmtry share/locale/ig
-@dirrmtry share/locale/hy/LC_MESSAGES
-@dirrmtry share/locale/hy
-@dirrmtry share/locale/ha/LC_MESSAGES
-@dirrmtry share/locale/ha
-@dirrmtry share/locale/gv/LC_MESSAGES
-@dirrmtry share/locale/gv
-@dirrmtry share/locale/fy/LC_MESSAGES
-@dirrmtry share/locale/fy
-@dirrmtry share/locale/fur/LC_MESSAGES
-@dirrmtry share/locale/fur
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/crh/LC_MESSAGES
-@dirrmtry share/locale/crh
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as