aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/pcmanfm/Makefile
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2010-09-30 14:48:13 +0000
committerKris Moore <kmoore@FreeBSD.org>2010-09-30 14:48:13 +0000
commit7c51ebafe8a72be8923ad507e7afaad22be44bd4 (patch)
tree2a215016e61aa764eaf31004f8a2736cd7f4f5cd /x11-fm/pcmanfm/Makefile
parente0af562ef037e726ac064e3f050c1edb3de023fd (diff)
downloadports-7c51ebafe8a72be8923ad507e7afaad22be44bd4.tar.gz
ports-7c51ebafe8a72be8923ad507e7afaad22be44bd4.zip
Notes
Diffstat (limited to 'x11-fm/pcmanfm/Makefile')
-rw-r--r--x11-fm/pcmanfm/Makefile25
1 files changed, 5 insertions, 20 deletions
diff --git a/x11-fm/pcmanfm/Makefile b/x11-fm/pcmanfm/Makefile
index 78dc61e4b85e..706f13022991 100644
--- a/x11-fm/pcmanfm/Makefile
+++ b/x11-fm/pcmanfm/Makefile
@@ -7,17 +7,16 @@
#
PORTNAME= pcmanfm
-PORTVERSION= 0.5.2
-PORTREVISION= 3
+PORTVERSION= 0.9.7
CATEGORIES= x11-fm
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/PCManFM%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/PCManFM2%20%2B%20Libfm%20%28experimental%29/PCManFM/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kmoore@FreeBSD.org
COMMENT= PCMan File Manager
-LIB_DEPENDS= startup-notification-1:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS= startup-notification-1:${PORTSDIR}/x11/startup-notification \
+ fm-gtk.0:${PORTSDIR}/x11/libfm
-USE_BZIP2= yes
USE_GNOME= gtk20
USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
@@ -25,25 +24,11 @@ USE_FAM= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+=--disable-desktop-integration \
- --disable-hal
OPTIONS= NLS "Native Language Support (devel/gettext)" on
-# HAL "Enable auto-mounthing with HAL (sysutils/hal and devel/dbus)" on
-# Disable HAL for now, it doesn't seem to work very well in this version
.include <bsd.port.pre.mk>
-#.if !defined(WITHOUT_HAL)
-#LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal \
-# dbus-1.3:${PORTSDIR}/devel/dbus
-#CONFIGURE_ARGS+=--enable-hal
-#PLIST_SUB+= HAL=""
-#.else
-#CONFIGURE_ARGS+=--disable-hal
-#PLIST_SUB+= HAL="@comment"
-#.endif
-
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""