aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/pcmanfm/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-04 13:46:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-04 13:46:10 +0000
commit7cbc70d1885f4a7fc70c4788f25b1fce5206032d (patch)
treef554206e49912cfd11335f073c8ac57736336a38 /x11-fm/pcmanfm/Makefile
parent44b5076c379fc8cf07681ec8464323a7bd8d81b0 (diff)
downloadports-7cbc70d1885f4a7fc70c4788f25b1fce5206032d.tar.gz
ports-7cbc70d1885f4a7fc70c4788f25b1fce5206032d.zip
Notes
Diffstat (limited to 'x11-fm/pcmanfm/Makefile')
-rw-r--r--x11-fm/pcmanfm/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-fm/pcmanfm/Makefile b/x11-fm/pcmanfm/Makefile
new file mode 100644
index 000000000000..cc5b6ae6d1b1
--- /dev/null
+++ b/x11-fm/pcmanfm/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: x11-fm/pcmanfm
+# Date created: 27 March 2008
+# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
+#
+# $Carpetsmoker: ports/x11-fm/pcmanfm/Makefile,v 1.1 2008/03/27 22:02:27 carpetsmoker Exp $
+# $FreeBSD$
+#
+
+PORTNAME= pcmanfm
+PORTVERSION= 0.3.6.2
+CATEGORIES= x11-fm
+MASTER_SITES= SF
+
+MAINTAINER= carpetsmoker@xs4all.nl
+COMMENT= PCMan File Manager
+
+LIB_DEPENDS= startup-notification-1:${PORTSDIR}/x11/startup-notification
+
+USE_GNOME= gtk20
+USE_AUTOTOOLS= libtool:15
+USE_GMAKE= yes
+USE_FAM= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+=--disable-desktop-integration \
+ --disable-hal
+
+OPTIONS= NLS "Native Language Support (devel/gettext)" on
+# HAL "Enable auto-mounthing with HAL (sysutils/hal and devel/dbus)" on
+# Disable HAL for now, it doesn't seem to work very well in this version
+
+.include <bsd.port.pre.mk>
+
+#.if !defined(WITHOUT_HAL)
+#LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal \
+# dbus-1.3:${PORTSDIR}/devel/dbus
+#CONFIGURE_ARGS+=--enable-hal
+#PLIST_SUB+= HAL=""
+#.else
+#CONFIGURE_ARGS+=--disable-hal
+#PLIST_SUB+= HAL="@comment"
+#.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>