aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/py-nautilus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:36:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:36:39 +0000
commit0d91e908a860e58281ee805e9fbaf42057f42633 (patch)
treebab1455f1781e22fb6885f9881cebb71ec6c331e /x11-fm/py-nautilus
parent80b8f841389c94bdb13a30c08752f3e0a38b7b25 (diff)
downloadports-0d91e908a860e58281ee805e9fbaf42057f42633.tar.gz
ports-0d91e908a860e58281ee805e9fbaf42057f42633.zip
Notes
Diffstat (limited to 'x11-fm/py-nautilus')
-rw-r--r--x11-fm/py-nautilus/Makefile38
-rw-r--r--x11-fm/py-nautilus/distinfo2
-rw-r--r--x11-fm/py-nautilus/pkg-descr1
-rw-r--r--x11-fm/py-nautilus/pkg-plist12
4 files changed, 53 insertions, 0 deletions
diff --git a/x11-fm/py-nautilus/Makefile b/x11-fm/py-nautilus/Makefile
new file mode 100644
index 000000000000..2e734fa8c2ac
--- /dev/null
+++ b/x11-fm/py-nautilus/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: py-nautilus
+# Date created: 31 May, 2005
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11-fm/py-nautilus/Makefile,v 1.4 2005/10/02 23:53:38 marcus Exp $
+#
+
+PORTNAME= nautilus
+PORTVERSION= 0.4.1
+CATEGORIES= x11-fm gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/nautilus-python/${PORTVERSION:R}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= nautilus-python-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python nautilus bindings
+
+LIB_DEPENDS= nautilus-extension:${PORTSDIR}/x11-fm/nautilus2
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= libtool:15
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack pygnome2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+DOCSDIR= ${PREFIX}/share/doc/nautilus-python
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/doc/|(prefix)/share/doc/|g' \
+ ${WRKSRC}/examples/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-fm/py-nautilus/distinfo b/x11-fm/py-nautilus/distinfo
new file mode 100644
index 000000000000..326eeded0755
--- /dev/null
+++ b/x11-fm/py-nautilus/distinfo
@@ -0,0 +1,2 @@
+MD5 (nautilus-python-0.4.1.tar.bz2) = 9f8e8eae9d954b4e4a73c242684f18ed
+SIZE (nautilus-python-0.4.1.tar.bz2) = 209703
diff --git a/x11-fm/py-nautilus/pkg-descr b/x11-fm/py-nautilus/pkg-descr
new file mode 100644
index 000000000000..1d3571cec08c
--- /dev/null
+++ b/x11-fm/py-nautilus/pkg-descr
@@ -0,0 +1 @@
+Python nautilus bindings.
diff --git a/x11-fm/py-nautilus/pkg-plist b/x11-fm/py-nautilus/pkg-plist
new file mode 100644
index 000000000000..ea97dc442777
--- /dev/null
+++ b/x11-fm/py-nautilus/pkg-plist
@@ -0,0 +1,12 @@
+lib/nautilus-python/nautilus.so
+lib/nautilus/extensions-1.0/libnautilus-python.so
+libdata/pkgconfig/nautilus-python.pc
+%%DOCSDIR%%/README
+%%DOCSDIR%%/documentation.py
+%%DOCSDIR%%/examples/background-image.py
+%%DOCSDIR%%/examples/block-size-column.py
+%%DOCSDIR%%/examples/md5sum-property-page.py
+%%DOCSDIR%%/examples/open-terminal.py
+@dirrm %%DOCSDIR%%/examples
+@dirrm %%DOCSDIR%%
+@dirrm lib/nautilus-python