aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/rodent/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 13:08:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 13:08:17 +0000
commit4490b16e4f9505e91dbcc35fb8a643435097b56f (patch)
tree9150428f098a620afa2fe2569336581e198f6c91 /x11-fm/rodent/Makefile
parenta12e34d03e75027ba1ec98b31b2dc24d36ca1e26 (diff)
downloadports-4490b16e4f9505e91dbcc35fb8a643435097b56f.tar.gz
ports-4490b16e4f9505e91dbcc35fb8a643435097b56f.zip
Notes
Diffstat (limited to 'x11-fm/rodent/Makefile')
-rw-r--r--x11-fm/rodent/Makefile38
1 files changed, 13 insertions, 25 deletions
diff --git a/x11-fm/rodent/Makefile b/x11-fm/rodent/Makefile
index a2ec2fc1105c..9e8334bfe777 100644
--- a/x11-fm/rodent/Makefile
+++ b/x11-fm/rodent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rodent
PORTVERSION= 4.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm
MASTER_SITES= SF/xffm/${PORTVERSION}/
@@ -15,43 +15,31 @@ LICENSE= GPLv3
BUILD_DEPENDS= gawk:${PORTSDIR}/japanese/gawk \
bash:${PORTSDIR}/shells/bash \
intltoolize:${PORTSDIR}/textproc/intltool
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- glib-2:${PORTSDIR}/devel/glib20 \
- cairo:${PORTSDIR}/graphics/cairo \
- rsvg-2:${PORTSDIR}/graphics/librsvg2 \
- gtk-x11-2:${PORTSDIR}/x11-toolkits/gtk20 \
- magic:${PORTSDIR}/sysutils/file
-
-USES= gmake pkgconfig
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libmagic.so:${PORTSDIR}/sysutils/file
+
+USES= gmake libtool pkgconfig desktop-file-utils
+USE_GNOME= glib20 gtk20 librsvg2 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--docdir=${DOCSDIR}
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
PORTDOCS= *
-MAN1= fgr.1
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
post-patch:
${REINPLACE_CMD} -e 's,^\(docdir = \).*,\1${DOCSDIR},' \
${WRKSRC}/Build/share/Makefile.in
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
+.for a in ia64 powerpc sparc63
+BROKEN_${a}= Does not compile on ia64, powerpc, or sparc64
+.endfor
.include <bsd.port.mk>