aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/rox-filer
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-08-17 18:06:43 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-08-17 18:06:43 +0000
commit2121e5e429368a2b08a20412bd8bb85c6b10082d (patch)
treeb0c823cf3423ec6197a6a6f674c18cf7f2e28744 /x11-fm/rox-filer
parenta596a0a5c261691265c0961e0c3c349d6fcead15 (diff)
downloadports-2121e5e429368a2b08a20412bd8bb85c6b10082d.tar.gz
ports-2121e5e429368a2b08a20412bd8bb85c6b10082d.zip
Notes
Diffstat (limited to 'x11-fm/rox-filer')
-rw-r--r--x11-fm/rox-filer/Makefile45
-rw-r--r--x11-fm/rox-filer/files/patch-ROX-Filer_src_Makefile.in8
-rw-r--r--x11-fm/rox-filer/files/patch-ROX-Filer_src_configure4
-rw-r--r--x11-fm/rox-filer/pkg-plist2
4 files changed, 34 insertions, 25 deletions
diff --git a/x11-fm/rox-filer/Makefile b/x11-fm/rox-filer/Makefile
index 064e623151d7..eb7b0c1a43a8 100644
--- a/x11-fm/rox-filer/Makefile
+++ b/x11-fm/rox-filer/Makefile
@@ -2,21 +2,24 @@
PORTNAME= rox-filer
PORTVERSION= 2.11
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-fm gnome
MASTER_SITES= SF/rox/rox/${PORTVERSION}
-DISTNAME= rox-filer-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Simple and easy to use graphical file manager
-LIB_DEPENDS= libinotify.so:devel/libinotify
+LICENSE= GPLv2+
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libinotify.so:devel/libinotify
PLIST_SUB+= LOCALBASE=${LOCALBASE}
-USE_XORG= x11 sm xaw xorgproto
-USE_GNOME= atk glib20 gtk20 libxml2 pango
-USES= gmake pkgconfig shared-mime-info tar:bzip2
+USES= gettext-runtime:build gmake pkgconfig shared-mime-info tar:bzip2
+USE_XORG= ice sm x11 xaw xorgproto
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 libxml2 pango
GNU_CONFIGURE= yes
CONFIGURE_ENV= APP_DIR=${WRKSRC}/ROX-Filer
@@ -26,24 +29,30 @@ BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
ALL_TARGET=
LIBS+= -lm
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT= NLS
+
+NLS_USES= gettext-runtime:run
+
post-configure:
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
- ${CONFIGURE_WRKSRC}/configure \
- ${CONFIGURE_WRKSRC}/choices.c \
- ${CONFIGURE_WRKSRC}/support.c \
- ${CONFIGURE_WRKSRC}/type.c \
- ${CONFIGURE_WRKSRC}/usericons.c \
- ${CONFIGURE_WRKSRC}/xdgmime.c
- @${TOUCH} ${CONFIGURE_WRKSRC}/config.status
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${CONFIGURE_WRKSRC}/configure \
+ ${CONFIGURE_WRKSRC}/choices.c \
+ ${CONFIGURE_WRKSRC}/support.c \
+ ${CONFIGURE_WRKSRC}/type.c \
+ ${CONFIGURE_WRKSRC}/usericons.c \
+ ${CONFIGURE_WRKSRC}/xdgmime.c
+ ${TOUCH} ${CONFIGURE_WRKSRC}/config.status
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/apps/ROX-Filer
- cd ${WRKSRC}/ROX-Filer && ${CP} -r .DirIcon AppInfo.xml AppRun Help Messages Options.xml ROX ROX-Filer Templates.ui images style.css subclasses ${STAGEDIR}${PREFIX}/apps/ROX-Filer
+ ${MKDIR} ${STAGEDIR}${PREFIX}/apps/ROX-Filer
+ cd ${WRKSRC}/ROX-Filer && ${CP} -r .DirIcon AppInfo.xml AppRun \
+ Help Messages Options.xml ROX ROX-Filer Templates.ui images \
+ style.css subclasses ${STAGEDIR}${PREFIX}/apps/ROX-Filer
cd ${WRKSRC} && ${CP} -r Choices ${STAGEDIR}${PREFIX}/share/
${CAT} ${FILESDIR}/rox | ${SED} -e "s|%%PREFIX%%|${PREFIX}|" > ${STAGEDIR}${PREFIX}/bin/rox
- ${CHMOD} 755 ${STAGEDIR}${PREFIX}/bin/rox
${INSTALL_MAN} ${WRKSRC}/rox.1 ${STAGEDIR}${PREFIX}/man/man1
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
${INSTALL_DATA} ${WRKSRC}/rox.xml ${STAGEDIR}${PREFIX}/share/mime/packages
.include <bsd.port.mk>
diff --git a/x11-fm/rox-filer/files/patch-ROX-Filer_src_Makefile.in b/x11-fm/rox-filer/files/patch-ROX-Filer_src_Makefile.in
index 8347e7a3d53b..0d77f70a3357 100644
--- a/x11-fm/rox-filer/files/patch-ROX-Filer_src_Makefile.in
+++ b/x11-fm/rox-filer/files/patch-ROX-Filer_src_Makefile.in
@@ -1,6 +1,6 @@
---- ROX-Filer/src/Makefile.in.orig 2011-10-09 16:31:59.000000000 +0200
-+++ ROX-Filer/src/Makefile.in 2018-07-31 22:30:30.674172000 +0200
-@@ -7,7 +7,7 @@
+--- ROX-Filer/src/Makefile.in.orig 2011-10-09 14:31:59 UTC
++++ ROX-Filer/src/Makefile.in
+@@ -7,7 +7,7 @@ CC = @CC@
.SUFFIXES: .c .o
PKG_CONFIG = @PKG_CONFIG@
@@ -9,7 +9,7 @@
#PROF = -fprofile-arcs -pg
PKG_CONFIG_FLAGS=
-@@ -47,10 +47,7 @@
+@@ -47,10 +47,7 @@ OBJECTS = abox.o action.o appinfo.o appm
${PROG}: ${OBJECTS}
${CC} -o "${PROG}" ${OBJECTS} ${LDFLAGS}
mv "${PROG}" "${PLATFORM_DIR}"
diff --git a/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure b/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure
index 4a582d2ec1a2..435640abad48 100644
--- a/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure
+++ b/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure
@@ -1,6 +1,6 @@
---- ROX-Filer/src/configure.orig
+--- ROX-Filer/src/configure.orig 2011-10-09 14:32:14 UTC
+++ ROX-Filer/src/configure
-@@ -2134,10 +2134,6 @@
+@@ -2134,10 +2134,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
ac_config_headers="$ac_config_headers config.h"
diff --git a/x11-fm/rox-filer/pkg-plist b/x11-fm/rox-filer/pkg-plist
index 439260b99350..46f91e702f86 100644
--- a/x11-fm/rox-filer/pkg-plist
+++ b/x11-fm/rox-filer/pkg-plist
@@ -143,7 +143,7 @@ apps/ROX-Filer/images/rox-xattr.png
apps/ROX-Filer/images/symlink.png
apps/ROX-Filer/style.css
apps/ROX-Filer/subclasses
-bin/rox
+@(,,755) bin/rox
man/man1/rox.1.gz
share/Choices/MIME-types/application_postscript
share/Choices/MIME-types/text