aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2009-03-02 16:51:57 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2009-03-02 16:51:57 +0000
commit395f5a4663fa4199738c47657facbf79c5835dbd (patch)
treeb041405e6daaf431accdd59687256a169537b115 /x11-fm/thunar/Makefile
parent38dccd590b9f56ec8c234bf9b013edd5ffb86d7c (diff)
downloadports-395f5a4663fa4199738c47657facbf79c5835dbd.tar.gz
ports-395f5a4663fa4199738c47657facbf79c5835dbd.zip
Notes
Diffstat (limited to 'x11-fm/thunar/Makefile')
-rw-r--r--x11-fm/thunar/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 529b6712a7cc..4c12f6dd230d 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Thunar
-PORTVERSION= 0.9.3
-PORTREVISION= 0
+PORTVERSION= 1.0.0
CATEGORIES= x11-fm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
@@ -17,9 +16,6 @@ COMMENT= XFce 4 file manager
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-PATCHFILES= Thunar-0.9.0-missing-audio-cds-for-volman.patch
-PATCH_SITES= http://thunar.xfce.org/download/sources/Thunar/0.9.0/
-
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
@@ -31,16 +27,17 @@ USE_XFCE= configenv libexo libutil
OPTIONS= DBUS "Enable D-BUS support" on \
JPEG "Enable JPEG support" on \
- FAM "Enable FAM support" off \
- HAL "Enable HAL support" on \
+ FAM "Enable FAM support" on \
+ HAL "Enable HAL support" on \
GCONF "Enable GCONF support" off \
STARTUP "Enable startup notification support" on \
- PLUG_APR "Thunar Advanced Properties plugin" on \
+ PLUG_APR "Thunar Advanced Properties plugin" on \
PLUG_APR_EXIF "Exif support for the APR plugin" off \
- PLUG_SBR "Thunar Simple Builtin Renamers plugin" on \
+ PLUG_SBR "Thunar Simple Builtin Renamers plugin" on \
PLUG_SBR_PCRE "Regular expression support for the SBR plugin" off \
- PLUG_TPA "Thunar Trash Panel Applet plugin" on \
- PLUG_UCA "Thunar User Customizable Actions plugin" on
+ PLUG_TPA "Thunar Trash Panel Applet plugin" on \
+ PLUG_UCA "Thunar User Customizable Actions plugin" on \
+ PLUG_WALL "Thunar Wallpaper plugin" on
MAN1= Thunar.1
@@ -124,6 +121,14 @@ CONFIGURE_ARGS+=--disable-uca-plugin
PLIST_SUB+= PLUGIN_UCA="@comment "
.endif
+.if !defined(WITHOUT_PLUG_WALL)
+CONFIGURE_ARGS+=--enable-wallpaper-plugin
+PLIST_SUB+= PLUGIN_WALL=""
+.else
+CONFIGURE_ARGS+=--disable-wallpaper-plugin
+PLIST_SUB+= PLUGIN_WALL="@comment "
+.endif
+
.if !defined(WITHOUT_STARTUP)
LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification