aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-05-13 17:18:06 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-05-13 17:18:06 +0000
commit00f8846df929110c5e843675eff227eb98eb93b0 (patch)
tree73b80904bca035a406e797151214dce6b5814052 /x11-fm/thunar
parent172e01515f0ff6fd5358027fdb5d5eef782f3763 (diff)
downloadports-00f8846df929110c5e843675eff227eb98eb93b0.tar.gz
ports-00f8846df929110c5e843675eff227eb98eb93b0.zip
Notes
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile1
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-file.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 06741c700ef9..33eb4e73feaa 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Thunar
PORTVERSION= 1.6.8
+PORTREVISION= 1
CATEGORIES= x11-fm xfce
MASTER_SITES= XFCE/src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-file.c b/x11-fm/thunar/files/patch-thunar_thunar-file.c
new file mode 100644
index 000000000000..3d1dc7088050
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-file.c
@@ -0,0 +1,12 @@
+Fix Trash panel plugin (PLUG_TPA), now receives right signal (bug #11896)
+
+--- thunar/thunar-file.c.orig 2015-05-05 17:25:29 UTC
++++ thunar/thunar-file.c
+@@ -661,6 +661,7 @@ thunar_file_monitor_update (GFile
+ switch (event_type)
+ {
+ case G_FILE_MONITOR_EVENT_CREATED:
++ case G_FILE_MONITOR_EVENT_ATTRIBUTE_CHANGED:
+ case G_FILE_MONITOR_EVENT_CHANGES_DONE_HINT:
+ case G_FILE_MONITOR_EVENT_PRE_UNMOUNT:
+ case G_FILE_MONITOR_EVENT_DELETED: