aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/vide
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-06-28 16:36:54 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-06-28 16:36:54 +0000
commit7aa69efc18981fd7b7d268a21171db69585e86cb (patch)
treec4a5e3ec20265782e4cdfcde20a1f8581a32bc44 /x11-fm/vide
parentdc61a2f5b317c2af880e77871479076d05aec2ad (diff)
downloadports-7aa69efc18981fd7b7d268a21171db69585e86cb.tar.gz
ports-7aa69efc18981fd7b7d268a21171db69585e86cb.zip
Notes
Diffstat (limited to 'x11-fm/vide')
-rw-r--r--x11-fm/vide/Makefile16
-rw-r--r--x11-fm/vide/files/patch-ac61
-rw-r--r--x11-fm/vide/files/patch-ad29
-rw-r--r--x11-fm/vide/files/patch-ae11
-rw-r--r--x11-fm/vide/files/patch-af11
-rw-r--r--x11-fm/vide/pkg-plist3
6 files changed, 123 insertions, 8 deletions
diff --git a/x11-fm/vide/Makefile b/x11-fm/vide/Makefile
index e5a9677b993a..41967b21694e 100644
--- a/x11-fm/vide/Makefile
+++ b/x11-fm/vide/Makefile
@@ -14,10 +14,18 @@ MAINTAINER= careilly@thecia.ie
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-CFLAGS+= -DHAVE_SYS_PARAM_H
-MANCOMPRESSED= yes
-USE_XLIB= yes
-GNU_CONFIGURE= yes
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-DHAVE_SYS_PARAM_H" \
+ GTK_CONFIG="${GTK_CONFIG}"
+CONFIGURE_ARGS= --disable-gtktest
+
+PLIST_SUB= VERSION=${PORTVERSION}
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/*.c
.include <bsd.port.mk>
diff --git a/x11-fm/vide/files/patch-ac b/x11-fm/vide/files/patch-ac
index 671424e3b8a9..951885707603 100644
--- a/x11-fm/vide/files/patch-ac
+++ b/x11-fm/vide/files/patch-ac
@@ -1,15 +1,16 @@
---- src/vide.c.orig Sun Jun 11 19:04:56 2000
-+++ src/vide.c Sun Jun 11 19:06:53 2000
-@@ -224,6 +224,8 @@
+--- src/vide.c.orig Thu May 11 03:04:39 2000
++++ src/vide.c Sat Jun 17 15:19:25 2000
+@@ -224,6 +224,9 @@
getcwd(current_dir, sizeof(current_dir));
+ /* i18n support */
+ gtk_set_locale();
++
/* Set up handler for sigchild so that we don't get zombies */
new_action.sa_handler = received_sigchild;
sigemptyset (&new_action.sa_mask);
-@@ -243,7 +245,7 @@
+@@ -243,7 +246,7 @@
gdk_color_parse ("yellow", &TAG_COLOR);
gdk_color_parse ("wheat", &DRAG_HILIGHT);
COMMAND_TEXT_FONT =
@@ -18,3 +19,55 @@
cfg.filetypes = NULL;
cfg.bookmarks = NULL;
+@@ -259,7 +262,7 @@
+ cfg.confirm_delete = TRUE; // not used
+ cfg.confirm_overwrite = TRUE; // not used
+ cfg.start_with_cwd = FALSE;
+- strncpy (cfg.viewer_command, "rxvt -e vim",
++ strncpy (cfg.viewer_command, "xterm -e vi",
+ sizeof (cfg.viewer_command));
+ cfg.window_width = 640;
+ cfg.window_height = 480;
+@@ -268,7 +271,7 @@
+ cfg.divide_popup_menu = FALSE; // not used
+ cfg.dir_history_max_length = 15;
+ cfg.command_history_max_length = 10;
+- strncpy (cfg.xterm_command, "rxvt", sizeof (cfg.xterm_command));
++ strncpy (cfg.xterm_command, "xterm", sizeof (cfg.xterm_command));
+ chdir (getenv ("HOME"));
+ getcwd (app.left_view.dir, PATH_MAX);
+ strncpy (app.right_view.dir, app.left_view.dir, PATH_MAX);
+@@ -280,9 +283,9 @@
+ {
+ /* Setup some default filetypes */
+ add_filetype ("jpeg,jpg,png,xpm,gif", "xv,gimp", "Image Files");
+- add_filetype ("c,cpp,h,pl,java, py", "x vim", "Source Code Files");
++ add_filetype ("c,cpp,h,pl,java, py", "x vi", "Source Code Files");
+ add_filetype ("o,so,a", "x nm %f | less", "Object Files");
+- add_filetype ("htm,html,php", "netscape,x vim", "HTML Documents");
++ add_filetype ("htm,html,php", "netscape,x vi", "HTML Documents");
+ add_filetype ("tar.gz,tgz", "x tar xzvf %f ,x tar tzvf %f | less",
+ "Gzipped Tarballs");
+ add_filetype("zip, Z", "x unzip %f", "Zip");
+@@ -310,7 +313,7 @@
+ gchar trash_com[128];
+ gchar memo_com[128];
+ g_snprintf (trash_com, 128, "mv %%f %s", cfg.trash);
+- g_snprintf (memo_com, 128, "rxvt -e vim %s/memo", cfg.config_dir);
++ g_snprintf (memo_com, 128, "xterm -e vi %s/memo", cfg.config_dir);
+
+ add_user_command (" ", "NULL");
+ add_user_command ("Memo", memo_com);
+@@ -332,9 +335,9 @@
+ }
+ if(!read_command_mode_file())
+ {
+- add_command("mutt", "exe rxvt -e mutt");
+- add_command("ps", "exe rxvt -e top");
+- add_command("vi", "exe rxvt -e vim");
++ add_command("mutt", "exe xterm -e mutt");
++ add_command("ps", "exe xterm -e top");
++ add_command("vi", "exe xterm -e vi");
+ add_command("Backup", "/~$");
+ add_command("touch", "exe touch %{Name of new file.}");
+ }
diff --git a/x11-fm/vide/files/patch-ad b/x11-fm/vide/files/patch-ad
new file mode 100644
index 000000000000..1d6c7f28b4eb
--- /dev/null
+++ b/x11-fm/vide/files/patch-ad
@@ -0,0 +1,29 @@
+--- src/command_mode.c.orig Sat Jun 17 15:24:19 2000
++++ src/command_mode.c Sat Jun 17 15:57:34 2000
+@@ -201,7 +201,7 @@
+ buf[4] = '\0';
+ if(!strcmp(buf, "grep"))
+ {
+- g_snprintf(buf, sizeof(buf), "vim \"+ grep %s\"", command);
++ g_snprintf(buf, sizeof(buf), "vi \"+ grep %s\"", command);
+ exec_in_xterm(buf);
+ }
+
+@@ -280,7 +280,7 @@
+
+ if(!strcmp(command, "h"))
+ {
+- g_snprintf(buf, sizeof(buf), "%s -e vim %s/vide%s.txt",
++ g_snprintf(buf, sizeof(buf), "%s -e vi %s/vide%s.txt",
+ cfg.xterm_command, cfg.config_dir, VERSION);
+ file_exec(buf);
+ }
+@@ -363,7 +363,7 @@
+ /* load file into vi */
+ if(!strcmp(command, "e"))
+ {
+- g_snprintf(buf, sizeof(buf), "%s -e vim \"%s\"", cfg.xterm_command, file);
++ g_snprintf(buf, sizeof(buf), "%s -e vi \"%s\"", cfg.xterm_command, file);
+ file_exec(buf);
+
+ /* g_snprintf(buf, sizeof(buf), ":e %s/%s\r", curr_view->dir, file);
diff --git a/x11-fm/vide/files/patch-ae b/x11-fm/vide/files/patch-ae
new file mode 100644
index 000000000000..d91bc1a345a2
--- /dev/null
+++ b/x11-fm/vide/files/patch-ae
@@ -0,0 +1,11 @@
+--- src/config_files.c.orig Thu Apr 27 04:12:22 2000
++++ src/config_files.c Sat Jun 17 14:26:55 2000
+@@ -60,7 +60,7 @@
+ {
+ gchar command[PATH_MAX];
+
+- g_snprintf(command, sizeof(command), "cp /usr/local/share/vide/vide%s.txt %s",
++ g_snprintf(command, sizeof(command), "cp %%PREFIX%%/share/vide/vide%s.txt %s",
+ VERSION, help_file);
+ file_exec(command);
+
diff --git a/x11-fm/vide/files/patch-af b/x11-fm/vide/files/patch-af
new file mode 100644
index 000000000000..b8de139a6b0d
--- /dev/null
+++ b/x11-fm/vide/files/patch-af
@@ -0,0 +1,11 @@
+--- src/main_menu.c.orig Sat Jun 17 15:24:20 2000
++++ src/main_menu.c Sat Jun 17 15:56:55 2000
+@@ -27,7 +27,7 @@
+ help_cb(GtkWidget *widget, gpointer data)
+ {
+ gchar help_command[NAME_MAX];
+- g_snprintf(help_command, sizeof(help_command), "%s -e vim %s/vide%s.txt",
++ g_snprintf(help_command, sizeof(help_command), "%s -e vi %s/vide%s.txt",
+ cfg.xterm_command, cfg.config_dir, VERSION);
+ file_exec(help_command);
+
diff --git a/x11-fm/vide/pkg-plist b/x11-fm/vide/pkg-plist
index 7e2e219bb21e..1db7386e3758 100644
--- a/x11-fm/vide/pkg-plist
+++ b/x11-fm/vide/pkg-plist
@@ -1 +1,4 @@
+bin/pauseme
bin/vide
+share/vide/vide%%VERSION%%.txt
+@dirrm share/vide