aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/worker/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-20 17:10:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-20 17:10:03 +0000
commit760c49f41ef61089074d506f9688f024bb26d7d1 (patch)
tree9b36f774d55cdc81ff1a8f761b8d65dbf006e957 /x11-fm/worker/Makefile
parent23683f5155eb5b54c5223ff18c4d306772d70dce (diff)
downloadports-760c49f41ef61089074d506f9688f024bb26d7d1.tar.gz
ports-760c49f41ef61089074d506f9688f024bb26d7d1.zip
Notes
Diffstat (limited to 'x11-fm/worker/Makefile')
-rw-r--r--x11-fm/worker/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index c195a4548f1c..57087fb269f6 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= worker
-PORTVERSION= 3.6.2
-PORTREVISION= 1
+PORTVERSION= 3.7.0
CATEGORIES= x11-fm
MASTER_SITES= http://www.boomerangsworld.de/cms/worker/downloads/
@@ -17,6 +16,12 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USES= compiler:c++11-lib pkgconfig shebangfix tar:bzip2
GNU_CONFIGURE= yes
USE_XORG= x11 xinerama
+# From version 3.7.0 worker automatically detects proper pthread flags
+# which should be passed to compiler, for FreeBSD it properly sets
+# PTHREAD_CFLAGS to '-pthread', but leaves PTHREAD_LIBS variable empty,
+# making linker scream and fail about unresolved pthread_* functions.
+# This hack helps to pass proper flags to the linker.
+CONFIGURE_ENV= PTHREAD_LIBS="-pthread"
SHEBANG_FILES= ${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/xeditor