aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/worker/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-12-02 11:59:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-12-02 11:59:14 +0000
commitd22a6f3989a6cae319ad23ed418f8f5f397adb62 (patch)
tree356b2a64274d95710708af6183d30c6720b4b650 /x11-fm/worker/Makefile
parent7d69ee7b7479c229568e07951e54dc77f42015cb (diff)
downloadports-d22a6f3989a6cae319ad23ed418f8f5f397adb62.tar.gz
ports-d22a6f3989a6cae319ad23ed418f8f5f397adb62.zip
Notes
Diffstat (limited to 'x11-fm/worker/Makefile')
-rw-r--r--x11-fm/worker/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index cdcd45c2fb19..29f4563cc220 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= worker
-PORTVERSION= 4.5.1
+PORTVERSION= 4.6.0
CATEGORIES= x11-fm
MASTER_SITES= http://www.boomerangsworld.de/cms/worker/downloads/
@@ -14,9 +14,11 @@ LICENSE= GPLv2+
RUN_DEPENDS= bash:shells/bash
USES= compiler:c++14-lang localbase pkgconfig python:run \
- shebangfix tar:bzip2 xorg
+ shebangfix ssl tar:bzip2 xorg
GNU_CONFIGURE= yes
-USE_XORG= x11 xinerama
+CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
+USE_XORG= ice sm x11 xinerama
SHEBANG_FILES= ${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/xeditor \