aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/xfe/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-08-08 13:17:47 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-08-08 13:17:47 +0000
commit40f439aa7fe45b0cd9c2e42c4310ca277178f30c (patch)
tree0ca11108f28c8f1da438988eaa3ef07f4441b6ed /x11-fm/xfe/Makefile
parent2601b88e07012e0409dd88effa64b92be024b38c (diff)
Notes
Diffstat (limited to 'x11-fm/xfe/Makefile')
-rw-r--r--x11-fm/xfe/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
new file mode 100644
index 000000000000..7da15198149e
--- /dev/null
+++ b/x11-fm/xfe/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xfe
+# Date created: Sun, Jul 13 2003
+# Whom: ptiJo
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfe
+PORTVERSION= 0.54.2
+PORTREVISION= 0
+CATEGORIES= x11-fm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ptiJo@noos.fr
+COMMENT= Fast MS-Explorer like filemanager for X
+
+LIB_DEPENDS= FOX:${PORTSDIR}/x11-toolkits/fox \
+ png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--x-includes=${X11BASE}/include \
+ --x-libraries=${X11BASE}/lib \
+ --with-x
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-I/usr/include/fox|-I${LOCALBASE}/include/|g' \
+ ${WRKSRC}/src/Makefile.in ${WRKSRC}/xfq/Makefile.in \
+ ${WRKSRC}/xfv/Makefile.in
+
+MAN1= xfe.1 xfq.1 xfv.1
+
+.include <bsd.port.mk>