aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/xnc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /x11-fm/xnc
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'x11-fm/xnc')
-rw-r--r--x11-fm/xnc/Makefile6
-rw-r--r--x11-fm/xnc/files/patch-IMG_png.c35
2 files changed, 38 insertions, 3 deletions
diff --git a/x11-fm/xnc/Makefile b/x11-fm/xnc/Makefile
index 6e768b7f0614..a1a44a62eaa2 100644
--- a/x11-fm/xnc/Makefile
+++ b/x11-fm/xnc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xnc
PORTVERSION= 5.0.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-fm
MASTER_SITES= http://www.xnc.dubna.su/src-5/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -23,7 +23,7 @@ COMMENT= File manager for X Window
# unarj:${PORTSDIR}/archivers/unarj \
# lha:${PORTSDIR}/archivers/lha
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -32,7 +32,7 @@ GNU_CONFIGURE= yes
USE_XORG= x11 xext xt
CONFIGURE_ARGS+=--with-pty=BSD --with-libintl-prefix=${LOCALBASE}
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
MAN1= ives.1 xjpegroot.1 xnc.1 xnlaunch.1 iedit.1 iview.1
diff --git a/x11-fm/xnc/files/patch-IMG_png.c b/x11-fm/xnc/files/patch-IMG_png.c
new file mode 100644
index 000000000000..3c90061eb505
--- /dev/null
+++ b/x11-fm/xnc/files/patch-IMG_png.c
@@ -0,0 +1,35 @@
+--- src/lib/image2/sdl_image/IMG_png.c.orig 2002-08-05 12:43:09.000000000 +0200
++++ src/lib/image2/sdl_image/IMG_png.c 2012-05-06 16:16:38.000000000 +0200
+@@ -70,6 +70,7 @@
+ #define MACOS
+ #endif
+ #include <png.h>
++#include <pngpriv.h>
+
+ #define PNG_BYTES_TO_CHECK 4
+
+@@ -87,7 +88,7 @@
+ }
+
+ /* Load a PNG type image from an SDL datasource */
+-static void png_read_data(png_structp ctx, png_bytep area, png_size_t size)
++static void local_png_read_data(png_structp ctx, png_bytep area, png_size_t size)
+ {
+ SDL_RWops *src;
+
+@@ -138,13 +139,13 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in png_create_read_struct() earlier.
+ */
+- if ( setjmp(png_ptr->jmpbuf) ) {
++ if ( setjmp(png_jmpbuf(png_ptr)) ) {
+ IMG_SetError("Error reading the PNG file.");
+ goto done;
+ }
+
+ /* Set up the input control */
+- png_set_read_fn(png_ptr, src, png_read_data);
++ png_set_read_fn(png_ptr, src, local_png_read_data);
+
+ /* Read PNG header info */
+ png_read_info(png_ptr, info_ptr);