aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/xnc
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 19:07:04 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 19:07:04 +0000
commit2949cb5d8b67bfc8581e73732033579d0c913a7f (patch)
tree1b68f7028e40ae9a269fb0854329c63211aec18a /x11-fm/xnc
parent99939c64cd44536cda1e117de00eaef5fa1276c2 (diff)
downloadports-2949cb5d8b67bfc8581e73732033579d0c913a7f.tar.gz
ports-2949cb5d8b67bfc8581e73732033579d0c913a7f.zip
Notes
Diffstat (limited to 'x11-fm/xnc')
-rw-r--r--x11-fm/xnc/Makefile8
-rw-r--r--x11-fm/xnc/files/patch-ae56
2 files changed, 62 insertions, 2 deletions
diff --git a/x11-fm/xnc/Makefile b/x11-fm/xnc/Makefile
index 070f2a600480..914c4d4ce9d5 100644
--- a/x11-fm/xnc/Makefile
+++ b/x11-fm/xnc/Makefile
@@ -23,10 +23,14 @@ MAINTAINER= dima@Chg.RU
# unarj:${PORTSDIR}/archivers/unarj \
# lha:${PORTSDIR}/archivers/lha \
# bzip2:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.3:${PORTSDIR}/graphics/png
-USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PKGNAME}
+USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
MAN1= es.1 ives.1 vs.1 xjpegroot.1 xnc.1 xnlaunch.1
@@ -35,6 +39,6 @@ post-install:
${MKDIR} ${PREFIX}/share/doc/xnc
${INSTALL_DATA} ${WRKSRC}/Docs/* ${PREFIX}/share/doc/xnc
.endif
- @${CAT} ${PKGDIR}/MESSAGE
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/x11-fm/xnc/files/patch-ae b/x11-fm/xnc/files/patch-ae
new file mode 100644
index 000000000000..d4912b6727dc
--- /dev/null
+++ b/x11-fm/xnc/files/patch-ae
@@ -0,0 +1,56 @@
+--- image/makefile.in.orig Tue Jan 18 17:35:15 2000
++++ image/makefile.in Sat Jun 24 15:56:50 2000
+@@ -31,31 +31,31 @@
+ all:: libie.a $(PNGDEP) $(ZDEP)
+
+ 24to8.o: 24to8.c
+- $(CC) -c 24to8.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c 24to8.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ jpeg.o: jpeg.c
+- $(CC) -c jpeg.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c jpeg.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ pcdr.o: pcdr.c
+- $(CC) -c pcdr.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c pcdr.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ inter.o: inter.c
+- $(CC) -c inter.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c inter.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ huff.o: huff.c
+- $(CC) -c huff.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c huff.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ file.o: file.c
+- $(CC) -c file.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c file.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ yuv2rgb.o: yuv2rgb.c
+- $(CC) -c yuv2rgb.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c yuv2rgb.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ tiffr.o: tiffr.c
+- $(CC) -c tiffr.c $(CXXOPT) $(INCLUDES) -I/usr/local/include -I/usr/include/gr
++ $(CC) -c tiffr.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ png.o: png.c
+- $(CC) -c png.c $(CXXOPT) $(INCLUDES) $(ZINC) $(PNGINC)
++ $(CC) -c png.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS) $(ZINC) $(PNGINC)
+
+ ../zlib/libz.a:
+ cd ../zlib && make
+@@ -64,10 +64,10 @@
+ cd ../libpng && make
+
+ pcxr.o: pcxr.c
+- $(CC) -c pcxr.c $(CXXOPT) $(INCLUDES)
++ $(CC) -c pcxr.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
+
+ accel.o: accel.c
+- $(CC) -c accel.c $(CFLAGS)
++ $(CC) -c accel.c $(CFLAGS) $(CPPFLAGS)
+
+ libie.a: $(IOBJS)
+ $(RM) -f libie.a