aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-05-05 19:44:44 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-05-05 19:44:44 +0000
commit025a69d21bf0f82a329e30f7192faf2227d36e0d (patch)
tree2fde79446a71872543ed0a6833aeb9b02a55c7ac /x11-fm
parent33aa3c1f075cfdd1d8ad4fbf028858d631870447 (diff)
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/thunar/Makefile11
-rw-r--r--x11-fm/thunar/distinfo4
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-folder.c17
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-window.c13
4 files changed, 6 insertions, 39 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 9c86b8b2f8cd..06741c700ef9 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Thunar
-PORTVERSION= 1.6.7
-PORTREVISION= 1
+PORTVERSION= 1.6.8
CATEGORIES= x11-fm xfce
MASTER_SITES= XFCE/src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -27,15 +26,15 @@ USE_XFCE= libexo
USE_XORG= sm x11
USES= desktop-file-utils gmake pathfix perl5 libtool pkgconfig \
gettext-tools xfce tar:bzip2
+INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= NLS NOTIFY STARTUP
+OPTIONS_DEFINE= NLS NOTIFY
OPTIONS_GROUP= PLUGINS
OPTIONS_GROUP_PLUGINS= PLUG_APR PLUG_SBR PLUG_TPA PLUG_UCA PLUG_WALL
-OPTIONS_DEFAULT= NOTIFY PLUG_APR PLUG_SBR PLUG_UCA PLUG_TPA PLUG_WALL STARTUP
+OPTIONS_DEFAULT= NOTIFY PLUG_APR PLUG_SBR PLUG_UCA PLUG_TPA PLUG_WALL
# Override NOTIFY_DESC
NOTIFY_DESC= Display notifications
-STARTUP_DESC= Startup notification
PLUG_APR_DESC= Advanced Properties plugin
PLUG_SBR_DESC= Simple Builtin Renamers plugin
PLUG_TPA_DESC= Trash Panel Applet plugin
@@ -46,8 +45,6 @@ NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
NOTIFY_CONFIGURE_ENABLE= notifications
-STARTUP_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
-STARTUP_CONFIGURE_ENABLE= startup-notification
PLUG_APR_LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif
PLUG_APR_CONFIGURE_ENABLE= apr-plugin exif
PLUG_SBR_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
diff --git a/x11-fm/thunar/distinfo b/x11-fm/thunar/distinfo
index 4da5fd4872a8..b98d699fe668 100644
--- a/x11-fm/thunar/distinfo
+++ b/x11-fm/thunar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/Thunar-1.6.7.tar.bz2) = e35f05d5413ffd26bfe866f47b1d199045e3b42912da47c831d3689e12336ee5
-SIZE (xfce4/Thunar-1.6.7.tar.bz2) = 2108500
+SHA256 (xfce4/Thunar-1.6.8.tar.bz2) = 4079ccffe990cdccee48a0ae200d8a5bc9335c34721d7923b375795940cf79bb
+SIZE (xfce4/Thunar-1.6.8.tar.bz2) = 2169171
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-folder.c b/x11-fm/thunar/files/patch-thunar_thunar-folder.c
deleted file mode 100644
index 76066f70652a..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-folder.c
+++ /dev/null
@@ -1,17 +0,0 @@
-Avoid an infinite loop, during manual reload (bug #11849)
-
---- thunar/thunar-folder.c.orig 2015-04-18 14:25:18 UTC
-+++ thunar/thunar-folder.c
-@@ -551,10 +551,10 @@ thunar_folder_finished (ExoJob *jo
- if (folder->reload_info)
- {
- for (lp = folder->files; lp != NULL; lp = lp->next)
-- thunar_file_reload_idle (lp->data);
-+ thunar_file_reload (lp->data);
-
- /* reload folder information too */
-- thunar_file_reload_idle (folder->corresponding_file);
-+ thunar_file_reload (folder->corresponding_file);
-
- folder->reload_info = FALSE;
- }
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-window.c b/x11-fm/thunar/files/patch-thunar_thunar-window.c
deleted file mode 100644
index ee8b16e3babc..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-window.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix bind key for new ThunarWindow reload signal
-
---- thunar/thunar-window.c.orig 2015-04-18 14:25:18 UTC
-+++ thunar/thunar-window.c
-@@ -623,7 +623,7 @@ thunar_window_class_init (ThunarWindowCl
- /* setup the key bindings for the windows */
- binding_set = gtk_binding_set_by_class (klass);
- gtk_binding_entry_add_signal (binding_set, GDK_BackSpace, 0, "back", 0);
-- gtk_binding_entry_add_signal (binding_set, GDK_F5, 0, "reload", 0);
-+ gtk_binding_entry_add_signal (binding_set, GDK_F5, 0, "reload", 1, G_TYPE_BOOLEAN, TRUE);
- gtk_binding_entry_add_signal (binding_set, GDK_F9, 0, "toggle-sidepane", 0);
- gtk_binding_entry_add_signal (binding_set, GDK_F10, 0, "toggle-menubar", 0);
- gtk_binding_entry_add_signal (binding_set, GDK_KP_Add, GDK_CONTROL_MASK, "zoom-in", 0);