aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-12 15:17:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-12 15:17:08 +0000
commit37356c960ca7ab9ba12537980f1d440797c3b5d0 (patch)
tree000cb185f6549a733b8786ed1d9864cf3db9321c /x11-fm
parent54c8494312ed9edac8e7c3e674935dea3176693e (diff)
Remove this ports as part of phase II of the GNOME 1.4 desktop removal.
Notes
Notes: svn path=/head/; revision=86822
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/file_menu_applet/Makefile24
-rw-r--r--x11-fm/file_menu_applet/distinfo1
-rw-r--r--x11-fm/file_menu_applet/files/patch-src::flist-mime-icon.c41
-rw-r--r--x11-fm/file_menu_applet/files/patch-src::main.c29
-rw-r--r--x11-fm/file_menu_applet/pkg-descr14
-rw-r--r--x11-fm/file_menu_applet/pkg-install20
-rw-r--r--x11-fm/file_menu_applet/pkg-plist6
8 files changed, 0 insertions, 136 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index b220c555a8a5..41517ae7aebd 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -8,7 +8,6 @@
SUBDIR += dfm
SUBDIR += endeavour
SUBDIR += ezfm
- SUBDIR += file_menu_applet
SUBDIR += filerunner
SUBDIR += fsv
SUBDIR += gentoo
diff --git a/x11-fm/file_menu_applet/Makefile b/x11-fm/file_menu_applet/Makefile
deleted file mode 100644
index 7a79f86f9ccb..000000000000
--- a/x11-fm/file_menu_applet/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# New ports collection makefile for: file_menu_applet
-# Date created: 4 May 2002
-# Whom: Franz Klammer <klammer@webonaut.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= file_menu_applet
-PORTVERSION= 0.5
-CATEGORIES= x11-fm gnome
-MASTER_SITES= http://www.zoned.net:8000/~xkahn/file_menu_applet/
-
-MAINTAINER= klammer@webonaut.com
-COMMENT= A small GNOME panel application which creates a file manager
-
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack libpanel gnomevfs libglade
-GNU_CONFIGURE= yes
-
-pre-everything::
- @${SH} ${PKGINSTALL} ${PKGNAME} ${PREFIX}
-
-.include <bsd.port.mk>
diff --git a/x11-fm/file_menu_applet/distinfo b/x11-fm/file_menu_applet/distinfo
deleted file mode 100644
index 19bbe6f2e733..000000000000
--- a/x11-fm/file_menu_applet/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (file_menu_applet-0.5.tar.gz) = 2038c3bf76485c17f6e8c8096d69cfd5
diff --git a/x11-fm/file_menu_applet/files/patch-src::flist-mime-icon.c b/x11-fm/file_menu_applet/files/patch-src::flist-mime-icon.c
deleted file mode 100644
index b5c7a9a837c7..000000000000
--- a/x11-fm/file_menu_applet/files/patch-src::flist-mime-icon.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- src/flist-mime-icon.c.orig Wed May 29 03:31:00 2002
-+++ src/flist-mime-icon.c Fri Jun 14 21:24:00 2002
-@@ -132,7 +132,7 @@
- const char *
- flist_mime_get_icon (const char *mime_type)
- {
-- gchar *mime_part, *index, *icon_name, *icon_name2;
-+ gchar *mime_part, *index, *icon_name, *icon_name2, *icon_name3;
-
- if (!mime_type)
- goto skip_theme_stuff;
-@@ -170,6 +170,19 @@
-
- skip_theme_stuff:
-
-+ mime_part = g_strdup (mime_type);
-+ index = strchr (mime_part, '/');
-+ *index = '-';
-+
-+ icon_name3 = g_strconcat (MIMEICONDIR, "document-icons/gnome-", mime_part, ".png", NULL);
-+
-+ g_free(mime_part);
-+
-+ if (g_file_exists (icon_name3))
-+ return icon_name3;
-+
-+ g_free (icon_name3);
-+
- return gnome_vfs_mime_get_icon (mime_type);
- }
-
-@@ -218,6 +231,9 @@
- if (!file) {
- if (!icon) return NULL;
- flist_nautilus_theme_load ();
-+
-+ if (!strstr(icon, ".png"))
-+ icon = g_strconcat(icon, ".png", NULL);
-
- if (!g_file_exists (icon)) {
- if (nautilus_theme_dir) file = g_concat_dir_and_file (nautilus_theme_dir, icon);
diff --git a/x11-fm/file_menu_applet/files/patch-src::main.c b/x11-fm/file_menu_applet/files/patch-src::main.c
deleted file mode 100644
index d1309e3979b6..000000000000
--- a/x11-fm/file_menu_applet/files/patch-src::main.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/main.c.orig Thu May 30 22:31:15 2002
-+++ src/main.c Fri Jun 14 23:13:34 2002
-@@ -318,13 +318,12 @@
- g_timer_start (dm->timer);
- g_timer_elapsed (dm->timer, &dm->last_time);
-
-- if (fma->icon_menus) {
-+ if (!fma->icon_menus) {
- options = GNOME_VFS_FILE_INFO_FOLLOW_LINKS
-- | GNOME_VFS_FILE_INFO_FORCE_FAST_MIME_TYPE
- | GNOME_VFS_FILE_INFO_GET_MIME_TYPE;
- } else {
- options = GNOME_VFS_FILE_INFO_FOLLOW_LINKS
-- | GNOME_VFS_FILE_INFO_GET_MIME_TYPE;
-+ | GNOME_VFS_FILE_INFO_FORCE_FAST_MIME_TYPE;
- }
-
- result = gnome_vfs_directory_visit
-@@ -559,6 +558,10 @@
-
- if (!fma->menu_label)
- fma->menu_label = strdup ("Home Directory");
-+ if (!fma->dir_watch)
-+ fma->dir_watch = strdup ("~/");
-+ if (fma->icon_menus == "(null)")
-+ fma->icon_menus = strdup ("true");
-
- /* Create */
- fma->menu_bar = gtk_menu_bar_new ();
diff --git a/x11-fm/file_menu_applet/pkg-descr b/x11-fm/file_menu_applet/pkg-descr
deleted file mode 100644
index baf384f5ec9d..000000000000
--- a/x11-fm/file_menu_applet/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-[ excerpt from developer's site ]
-File Menu Applet is a small GNOME panel application which
-creates a file manager.
-
-File Menu Applet is not designed to replace your existing
-file manager, but instead work with it. It supports standard
-drag and drop, GNOME file types, and Nautilus icons.
-I use it for small tasks such a easily attaching files to
-emails in Evolution by dragging them out of File Menu Applet
-into the Evolution composer window.
-It's also excellent for selecting songs to play from your
-MP3 or OGG collection.
-
-WWW: http://www.zoned.net:8000/~xkahn/file_menu_applet/
diff --git a/x11-fm/file_menu_applet/pkg-install b/x11-fm/file_menu_applet/pkg-install
deleted file mode 100644
index 3f4444205888..000000000000
--- a/x11-fm/file_menu_applet/pkg-install
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-if [ -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin:${PATH}
-export PATH
-
-if [ ! -f ${2}/libdata/pkgconfig/libpanelapplet-2.0.pc ]; then
- exit 0
-fi
-
-echo "================================================================"
-echo ""
-echo "The GNOME 2.0 package libpanelapplet was detected on the system."
-echo "file_menu_applet works only with the GNOME 1.0 panel."
-echo ""
-echo "================================================================"
-false
diff --git a/x11-fm/file_menu_applet/pkg-plist b/x11-fm/file_menu_applet/pkg-plist
deleted file mode 100644
index e414b0cd2e49..000000000000
--- a/x11-fm/file_menu_applet/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/file_menu_applet
-etc/CORBA/servers/file_menu_applet.gnorba
-share/gnome/applets/Utility/file_menu_applet.desktop
-share/gnome/file_menu_applet/fma_prefs.glade
-share/gnome/pixmaps/file_menu_applet.png
-@dirrm share/gnome/file_menu_applet