aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 09:27:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 09:27:39 +0000
commit8572b975bc17a32fce243cb60363ba44041a10e1 (patch)
tree2b4f5e9c621b7e38288f287c279f569a645e7f3c /x11-fm
parent63a241ec543e9ab4b7385b14407c354b6e8bba07 (diff)
downloadports-8572b975bc17a32fce243cb60363ba44041a10e1.tar.gz
ports-8572b975bc17a32fce243cb60363ba44041a10e1.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/jaffm/Makefile45
-rw-r--r--x11-fm/jaffm/distinfo3
-rw-r--r--x11-fm/jaffm/pkg-descr7
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index 7da06ebc14df..35c0ad4f52c2 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -18,6 +18,7 @@
SUBDIR += gnome-commander
SUBDIR += gnome-commander2
SUBDIR += gprename
+ SUBDIR += jaffm
SUBDIR += krusader
SUBDIR += mtoolsfm
SUBDIR += nautilus2
diff --git a/x11-fm/jaffm/Makefile b/x11-fm/jaffm/Makefile
new file mode 100644
index 000000000000..924f90ae7360
--- /dev/null
+++ b/x11-fm/jaffm/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: jaffm
+# Date Created: 2006-04-27
+# Whom: Shaun Amott <shaun@inerd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jaffm
+PORTVERSION= 1.3
+CATEGORIES= x11-fm
+MASTER_SITES= http://binary.is/download/
+
+MAINTAINER= shaun@inerd.com
+COMMENT= A lightweight file manager inspired by MacOS Finder
+
+WXGTK_VER?= 2.6
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${WXGTK_VER} == "2.4" || \
+ (exists(${X11BASE}/bin/wxgtk2-2.4-config) && \
+ !exists(${X11BASE}/bin/wxgtk2-2.6-config))
+LIB_DEPENDS+= wx_gtk2_core-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
+WXGTK_VER= 2.4
+.else
+LIB_DEPENDS+= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
+WXGTK_VER= 2.6
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#^PREFIX=.*#PREFIX=${PREFIX}#' \
+ -e 's#$$(shell wx-config \(.*\))#`${X11BASE}/bin/wxgtk2-${WXGTK_VER}-config \1`#' \
+ -e 's#^FLAGS=-ggdb#FLAGS=${CFLAGS}#' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/x11-fm/jaffm/distinfo b/x11-fm/jaffm/distinfo
new file mode 100644
index 000000000000..0933700098ac
--- /dev/null
+++ b/x11-fm/jaffm/distinfo
@@ -0,0 +1,3 @@
+MD5 (jaffm-1.3.tar.bz2) = 7e6572dbb64258203e8f1910ab00238f
+SHA256 (jaffm-1.3.tar.bz2) = d73426330eb408767ad9075fd466b8024413e48829e899b21714eadfbda3399d
+SIZE (jaffm-1.3.tar.bz2) = 24346
diff --git a/x11-fm/jaffm/pkg-descr b/x11-fm/jaffm/pkg-descr
new file mode 100644
index 000000000000..63d42e9b0b7f
--- /dev/null
+++ b/x11-fm/jaffm/pkg-descr
@@ -0,0 +1,7 @@
+Jaffm is a lightweight wxWindows (GTK+ interface) file manager for
+Unix, written in C++. It is aimed at nonsense-free file management. It
+is mostly inspired by the List View in Mac OS Finder, but also has
+Unix-handy features such as an interactive location bar with Bash-style
+tab completion, and a simple but elegant user interface.
+
+WWW: http://jaffm.binary.is/