aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-01 18:31:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-01 18:31:17 +0000
commit4b256bf21c65422aa455f64d9076d08c86575f0f (patch)
treeb7fff8b76d7e671be4d95d0256b6b1dd522d4665 /x11-fm
parentf2467d3609c4a9e109e08af10d4492ef2b497704 (diff)
downloadports-4b256bf21c65422aa455f64d9076d08c86575f0f.tar.gz
ports-4b256bf21c65422aa455f64d9076d08c86575f0f.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/velocity/Makefile2
-rw-r--r--x11-fm/velocity/files/patch-src-velocity-vfs.c30
2 files changed, 31 insertions, 1 deletions
diff --git a/x11-fm/velocity/Makefile b/x11-fm/velocity/Makefile
index fef89c6e6f5d..41468c166e64 100644
--- a/x11-fm/velocity/Makefile
+++ b/x11-fm/velocity/Makefile
@@ -7,7 +7,7 @@
PORTNAME= velocity
PORTVERSION= 0.1.0b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm
MASTER_SITES= http://homepages.ius.edu/kydavis/velocity/
DISTNAME= velocity-0.1.0beta
diff --git a/x11-fm/velocity/files/patch-src-velocity-vfs.c b/x11-fm/velocity/files/patch-src-velocity-vfs.c
new file mode 100644
index 000000000000..7e315d5aff9f
--- /dev/null
+++ b/x11-fm/velocity/files/patch-src-velocity-vfs.c
@@ -0,0 +1,30 @@
+--- src/velocity-vfs.c.orig Tue Aug 26 04:23:50 2003
++++ src/velocity-vfs.c Mon Mar 1 19:23:34 2004
+@@ -31,6 +31,7 @@
+ #include <config.h>
+ #include <unistd.h>
+ #include <sys/types.h>
++#include <sys/param.h> /* for NGROUPS */
+ #include <glib.h>
+ #include <libgnome/gnome-desktop-item.h>
+ #include "velocity-vfs.h"
+@@ -240,7 +241,18 @@
+ return((vfsobj->info->uid==getuid()));
+ }
+ gboolean velocity_vfs_is_in_group(velocity_vfs_obj*vfsobj){
+- return((vfsobj->info->gid==getgid()));
++ /* 24 feb 2004 : Henri Michelon hmichelon at e-cml dot org
++ A patch to use the full list of groups on *BSD */
++ int cnt, ngroups;
++ gid_t groups[NGROUPS];
++ if ((ngroups = getgroups(NGROUPS, groups))) {
++ for (cnt = 0; cnt < ngroups; cnt++) {
++ if (vfsobj->info->gid==groups[cnt]) {
++ return(TRUE);
++ }
++ }
++ }
++ return(FALSE);
+ }
+ gboolean velocity_vfs_is_local(velocity_vfs_obj*vfsobj){
+ return(GNOME_VFS_FILE_INFO_LOCAL(vfsobj->info));