aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-04-29 07:26:45 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-04-29 07:26:45 +0000
commit08fca51da9607fe14fda9aa50dab4ee7dd6b6070 (patch)
tree637e2e520b390cb14652c8ae895f25935158f799 /x11-fm
parenta6703cfc3ed62f761e80e1aee96e151c9a670668 (diff)
downloadports-08fca51da9607fe14fda9aa50dab4ee7dd6b6070.tar.gz
ports-08fca51da9607fe14fda9aa50dab4ee7dd6b6070.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/emelfm2/Makefile13
-rw-r--r--x11-fm/emelfm2/distinfo4
-rw-r--r--x11-fm/emelfm2/files/patch-Makefile16
3 files changed, 11 insertions, 22 deletions
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
index f2a0d0627bac..e8b51417e7c1 100644
--- a/x11-fm/emelfm2/Makefile
+++ b/x11-fm/emelfm2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= emelfm2
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.1
CATEGORIES= x11-fm
MASTER_SITES= http://emelfm2.net/rel/
@@ -26,7 +26,6 @@ MAN1= emelfm2.1
OPTIONS= DEBUG "Enable debugging messages" off \
GAMIN "Enable Gamin for file monitoring" off \
- FAM "Enable FAM for file monitoring" off \
THUMB "Enable the thumbnail plugin" off \
TRACKER "Enable the tracker plugin" off \
HAL "Enable HAL support" off \
@@ -41,22 +40,12 @@ DOCFILES= ACTIONS CONFIGURATION CREDITS GPL HACKING INSTALL LGPL NEWS \
MAK_ENV+= DEBUG=1
.endif
-.if defined(WITH_GAMIN) && defined(WITH_FAM)
-BROKEN= WITH_GAMIN and WITH_FAM cannot be enabled at the same time for this port
-.endif
-
.if defined(WITH_GAMIN)
USE_FAM= yes
WANT_FAM_SYSTEM=gamin
MAKE_ENV+= USE_GAMIN=1
.endif
-.if defined(WITH_FAM)
-USE_FAM= yes
-WANT_FAM_SYSTEM=fam
-MAKE_ENV+= USE_FAM=1
-.endif
-
.if defined(WITH_THUMB)
LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp
MAKE_ENV+= WITH_THUMB=1
diff --git a/x11-fm/emelfm2/distinfo b/x11-fm/emelfm2/distinfo
index 270fe5688aad..12c51a1f898a 100644
--- a/x11-fm/emelfm2/distinfo
+++ b/x11-fm/emelfm2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (emelfm2-0.8.0.tar.bz2) = 85baadcf3d52d77eb8a44a325a444d52cf25164b1151c641dc2b36eb68e333e3
-SIZE (emelfm2-0.8.0.tar.bz2) = 1085861
+SHA256 (emelfm2-0.8.1.tar.bz2) = d38355628360e6bcdb69ef4affff03dd9f7cc9bd25c999b18b648a23c6f8bba7
+SIZE (emelfm2-0.8.1.tar.bz2) = 1098199
diff --git a/x11-fm/emelfm2/files/patch-Makefile b/x11-fm/emelfm2/files/patch-Makefile
index fc08e9cb4a27..2a39e01919b1 100644
--- a/x11-fm/emelfm2/files/patch-Makefile
+++ b/x11-fm/emelfm2/files/patch-Makefile
@@ -1,15 +1,15 @@
---- Makefile.orig 2011-02-03 23:47:50.000000000 +0100
-+++ Makefile 2011-02-20 08:50:16.000000000 +0100
-@@ -236,8 +236,6 @@
- else
- lLIBS += $(shell pkg-config --libs gthread-2.0 gmodule-2.0)
+--- Makefile.orig 2012-03-16 09:11:47.000000000 +0100
++++ Makefile 2012-04-23 08:12:55.000000000 +0200
+@@ -274,7 +274,7 @@
+ lLIBS += $(shell pkg-config --libs gmodule-2.0)
endif
--# -lrt needed for clock_gettime()
--lLIBS += -lrt
+ # -lrt needed for clock_gettime(), explicit -lm, -ldl needed for some arch-linux distros
+-lLIBS += -lrt -lm -ldl
++lLIBS += -lrt -lm
ifeq ($(USE_GAMIN), 1)
#gamin code is a superset of FAM code, so gamin needs fam as well
lLIBS += -lfam
-@@ -277,10 +275,6 @@
+@@ -319,10 +319,6 @@
@for file in `ls $(ICONS)/ |grep -v svn`; do \
install -m 644 $(ICONS)/$$file $(ICON_DIR); \
done