aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-04 20:42:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-04 20:42:06 +0000
commit500ba763056e9559809554fe0c1109231b680e32 (patch)
treefb16846412855810521b94b7c009f5ba4ca8de19 /x11-fm
parent2de8efadcdb4e0db54773e4f09201bb425199dc3 (diff)
downloadports-500ba763056e9559809554fe0c1109231b680e32.tar.gz
ports-500ba763056e9559809554fe0c1109231b680e32.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/emelfm2/Makefile9
-rw-r--r--x11-fm/emelfm2/distinfo6
-rw-r--r--x11-fm/emelfm2/files/patch-Makefile28
-rw-r--r--x11-fm/emelfm2/files/patch-e2_complete__path.c11
-rw-r--r--x11-fm/emelfm2/files/patch-e2_fileview.h11
-rw-r--r--x11-fm/emelfm2/files/patch-plugins_e2p_crypt.c20
-rw-r--r--x11-fm/emelfm2/pkg-plist4
7 files changed, 58 insertions, 31 deletions
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
index 4aac783540c3..e713c04784e6 100644
--- a/x11-fm/emelfm2/Makefile
+++ b/x11-fm/emelfm2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= emelfm2
-PORTVERSION= 0.3.5
-PORTREVISION= 1
+PORTVERSION= 0.4
CATEGORIES= x11-fm
MASTER_SITES= http://emelfm2.net/rel/
@@ -29,6 +28,7 @@ OPTIONS= DEBUG "Enable debugging messages" off \
FAM "Enable FAM for file monitoring" off \
THUMB "Enable the thumbnail plugin" off \
TRACKER "Enable the tracker plugin" off \
+ HAL "Enable HAL support" off \
NLS "Enable gettext support" on
.include <bsd.port.pre.mk>
@@ -76,6 +76,11 @@ PLIST_SUB+= NLS=""
PLIST_SUB+= NLS="@comment "
.endif
+.if defined (WITH_HAL)
+MAKE_ENV+= WITH_HAL=1
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.endif
+
.if ${OSVERSION} < 600000
post-patch:
@${REINPLACE_CMD} -e 's|blksize_t buf_size =|__int32_t buf_size =|g' \
diff --git a/x11-fm/emelfm2/distinfo b/x11-fm/emelfm2/distinfo
index 2b5c8dbd9406..7e789e86c15f 100644
--- a/x11-fm/emelfm2/distinfo
+++ b/x11-fm/emelfm2/distinfo
@@ -1,3 +1,3 @@
-MD5 (emelfm2-0.3.5.tar.gz) = 4f5a065a7d35371a920533153f24e362
-SHA256 (emelfm2-0.3.5.tar.gz) = 8eeacc5dad3fcb562bde6b8817c4beee3ec2354d1f5f38ec4bd656f0bf9d0b0a
-SIZE (emelfm2-0.3.5.tar.gz) = 1081106
+MD5 (emelfm2-0.4.tar.gz) = 0242f340b642d7de2c09ccc8963e3135
+SHA256 (emelfm2-0.4.tar.gz) = 074be06f816460b2467cbad6e54beec39e110940942fc98df6225b7b05c4467c
+SIZE (emelfm2-0.4.tar.gz) = 1143199
diff --git a/x11-fm/emelfm2/files/patch-Makefile b/x11-fm/emelfm2/files/patch-Makefile
index d5db8958e0d6..f1115b44bd48 100644
--- a/x11-fm/emelfm2/files/patch-Makefile
+++ b/x11-fm/emelfm2/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Jul 28 10:40:12 2007
-+++ Makefile Sat Jul 28 10:42:14 2007
+--- Makefile.orig 2008-02-09 23:22:11.000000000 +0100
++++ Makefile 2008-04-04 21:47:47.000000000 +0200
@@ -56,7 +56,7 @@
#these are only used here for installation purposes
@@ -9,7 +9,7 @@
#as well as usage here, all in-code uses of these is assumed localised
ifeq ($(DOCS_VERSION), 1)
DOC_DIR = $(PREFIX)/share/doc/$(TARGET)-$(VERSION)
-@@ -203,7 +203,7 @@
+@@ -217,7 +217,7 @@
lLDFLAGS = $(LDFLAGS)
# -lrt needed for clock_gettime()
@@ -18,7 +18,15 @@
ifeq ($(USE_FAM),1)
lLIBS += -lfam
endif
-@@ -221,10 +221,10 @@
+@@ -234,6 +234,7 @@
+ lLIBS += -lacl
+ endif
+ ifeq ($(WITH_HAL),1)
++lCFLAGS += $(shell pkg-config --cflags dbus-1 dbus-glib-1 hal hal-storage)
+ lLIBS += $(shell pkg-config --libs dbus-1 dbus-glib-1 hal hal-storage)
+ endif
+ # for vfs & gvfs development
+@@ -246,10 +247,10 @@
endif
# should not need translation
OPSYS := $(shell uname)
@@ -31,13 +39,5 @@
+#lLIBS += $(shell if test $(OSREL) -lt 500041 ; then echo "-lgnugetopt"; fi)
+#endif
- #for gvfs development
- ifeq ($(WITH_GVFS),1)
-@@ -254,7 +254,6 @@
- done
- @install -d $(MAN_DIR)
- @install -m 644 docs/$(TARGET).1 $(MAN_DIR);
-- @bzip2 -f $(MAN_DIR)/$(TARGET).1;
-
- ifeq ($(XDG_INTEGRATION), 1)
- @install -d $(XDG_DESKTOP_DIR)
+ .PHONY: all plugins install install_plugins uninstall uninstall_plugins doc \
+ clean deps marshals gettext i18n install_i18n uninstall_i18n \
diff --git a/x11-fm/emelfm2/files/patch-e2_complete__path.c b/x11-fm/emelfm2/files/patch-e2_complete__path.c
new file mode 100644
index 000000000000..8a9ead530892
--- /dev/null
+++ b/x11-fm/emelfm2/files/patch-e2_complete__path.c
@@ -0,0 +1,11 @@
+--- src/command/complete/e2_complete__path.c 2008-03-22 03:58:43.000000000 +0100
++++ src/command/complete/e2_complete__path.c 2008-04-03 15:15:09.000000000 +0200
+@@ -147,7 +147,7 @@
+ {
+ gchar *p1, *p2, *localpath;
+ p1 = g_utf8_next_char (strrchr (word, G_DIR_SEPARATOR)); //the 'real' word to complete
+- p2 = strndup (word, p1 - word); //prefix for matches
++ p2 = g_strndup (word, p1 - word); //prefix for matches
+ if (word[0] == G_DIR_SEPARATOR)
+ { //word is an absolute path string
+ localpath = F_FILENAME_TO_LOCALE (p2);
diff --git a/x11-fm/emelfm2/files/patch-e2_fileview.h b/x11-fm/emelfm2/files/patch-e2_fileview.h
deleted file mode 100644
index 5dacdccf5d93..000000000000
--- a/x11-fm/emelfm2/files/patch-e2_fileview.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/e2_fileview.h.orig Sat Nov 4 14:39:08 2006
-+++ src/e2_fileview.h Sat Nov 4 14:39:26 2006
-@@ -21,6 +21,7 @@
- #ifndef E2_FILEVIEW_H
- #define E2_FILEVIEW_H
-
-+#include <pthread.h>
- #include "emelfm2.h"
-
- #ifdef E2_VFS
-
diff --git a/x11-fm/emelfm2/files/patch-plugins_e2p_crypt.c b/x11-fm/emelfm2/files/patch-plugins_e2p_crypt.c
new file mode 100644
index 000000000000..09917a77958a
--- /dev/null
+++ b/x11-fm/emelfm2/files/patch-plugins_e2p_crypt.c
@@ -0,0 +1,20 @@
+--- plugins/e2p_crypt.c.orig 2007-11-22 22:23:11.000000000 +0100
++++ plugins/e2p_crypt.c 2008-04-03 15:45:48.000000000 +0200
+@@ -1545,7 +1545,7 @@
+ {
+ sep = strchr (execpath, ':'); //ascii scan ok
+ if (sep != NULL)
+- execpath = strndup (execpath, sep-execpath);
++ execpath = g_strndup (execpath, sep-execpath);
+ //FIXME preserve execpath so that later members can be used
+ }
+ #ifdef E2_VFS
+@@ -1849,7 +1849,7 @@
+ }
+ }
+
+- fdatasync (fdesc);
++ fsync (fdesc);
+
+ retval = TRUE;
+ cleanup:
diff --git a/x11-fm/emelfm2/pkg-plist b/x11-fm/emelfm2/pkg-plist
index d4481ffed7ee..ba7d895b9537 100644
--- a/x11-fm/emelfm2/pkg-plist
+++ b/x11-fm/emelfm2/pkg-plist
@@ -2,6 +2,7 @@ bin/emelfm2
lib/emelfm2/plugins/e2p_clone.so
lib/emelfm2/plugins/e2p_config.so
lib/emelfm2/plugins/e2p_cpbar.so
+lib/emelfm2/plugins/e2p_crypt.so
lib/emelfm2/plugins/e2p_dircmp.so
lib/emelfm2/plugins/e2p_du.so
lib/emelfm2/plugins/e2p_find.so
@@ -10,7 +11,7 @@ lib/emelfm2/plugins/e2p_glob.so
lib/emelfm2/plugins/e2p_mvbar.so
lib/emelfm2/plugins/e2p_names_clip.so
lib/emelfm2/plugins/e2p_pack.so
-lib/emelfm2/plugins/e2p_rename_ext.so
+lib/emelfm2/plugins/e2p_rename.so
lib/emelfm2/plugins/e2p_sort_by_ext.so
lib/emelfm2/plugins/e2p_times.so
%%TRACKER%%lib/emelfm2/plugins/e2p_track.so
@@ -67,6 +68,7 @@ share/pixmaps/emelfm2/plugin_clip_48.png
share/pixmaps/emelfm2/plugin_clone_48.png
share/pixmaps/emelfm2/plugin_config_48.png
share/pixmaps/emelfm2/plugin_copy_48.png
+share/pixmaps/emelfm2/plugin_crypt_48.png
share/pixmaps/emelfm2/plugin_dircmp_48.png
share/pixmaps/emelfm2/plugin_du_48.png
share/pixmaps/emelfm2/plugin_extsort_48.png