aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-11-26 15:40:34 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-11-26 15:40:34 +0000
commit95f8285ce8e8a17eff121d1d3a3032c0ed877b01 (patch)
treef4924bc632747dbbddc2afc5a8f1ca5ab8b8e880 /x11-fm
parent38592c3bf229ae5d7d534d1fa1c2251e7f164e13 (diff)
downloadports-95f8285ce8e8a17eff121d1d3a3032c0ed877b01.tar.gz
ports-95f8285ce8e8a17eff121d1d3a3032c0ed877b01.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/xfe/Makefile29
-rw-r--r--x11-fm/xfe/distinfo4
-rw-r--r--x11-fm/xfe/files/patch-src_FilePanel262
-rw-r--r--x11-fm/xfe/files/patch-xvt_ttyinit.c29
-rw-r--r--x11-fm/xfe/pkg-plist59
5 files changed, 53 insertions, 330 deletions
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
index d919b23c08de..c05a50de06ac 100644
--- a/x11-fm/xfe/Makefile
+++ b/x11-fm/xfe/Makefile
@@ -2,30 +2,39 @@
# $FreeBSD$
PORTNAME= xfe
-PORTVERSION= 1.35
-PORTREVISION= 1
+PORTVERSION= 1.37
CATEGORIES= x11-fm
MASTER_SITES= SF
MAINTAINER= gahr@FreeBSD.org
-COMMENT= Fast MS-Explorer like filemanager for X
+COMMENT= Fast MS-Explorer like file manager for X
-LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
+LICENSE= GPLv2
+
+LIB_DEPENDS= libFOX-1.6.so:${PORTSDIR}/x11-toolkits/fox16
+
+OPTIONS_DEFINE= NLS
USE_XORG= xft
-USE_GNOME= gnomehack intltool
-USES= gettext gmake
+USE_GNOME= intltool
+USES= gettext gmake pathfix
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include -g -O0
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-MAN1= xfe.1 xfi.1 xfp.1 xfv.1 xfw.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} 's|/usr/local/share/xfe|${DATADIR}|g' \
${WRKSRC}/src/XFileExplorer.cpp \
${WRKSRC}/src/help.h \
${WRKSRC}/src/xfedefs.h
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=--disable-nls
+.endif
+
.include <bsd.port.mk>
diff --git a/x11-fm/xfe/distinfo b/x11-fm/xfe/distinfo
index 498a42ba7296..e58d4f7a3277 100644
--- a/x11-fm/xfe/distinfo
+++ b/x11-fm/xfe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfe-1.35.tar.gz) = 9f001cc9c07a9703b2874cd41635b1b2402cd1d7d270ab436d3daf0015369850
-SIZE (xfe-1.35.tar.gz) = 2447267
+SHA256 (xfe-1.37.tar.gz) = 4dbb2e24b18a63d78afd0219232f05cd7401370750e2db5f8fa70a6fef022abd
+SIZE (xfe-1.37.tar.gz) = 2480940
diff --git a/x11-fm/xfe/files/patch-src_FilePanel b/x11-fm/xfe/files/patch-src_FilePanel
deleted file mode 100644
index 04da45a21081..000000000000
--- a/x11-fm/xfe/files/patch-src_FilePanel
+++ /dev/null
@@ -1,262 +0,0 @@
---- src/FilePanel.cpp.orig 2013-08-21 13:32:33.000000000 +0200
-+++ src/FilePanel.cpp 2013-08-26 18:08:30.000000000 +0200
-@@ -119,9 +119,13 @@
- FXMAPFUNC(SEL_COMMAND,FilePanel::ID_EXTRACT,FilePanel::onCmdExtract),
- FXMAPFUNC(SEL_COMMAND,FilePanel::ID_EXTRACT_TO_FOLDER,FilePanel::onCmdExtractToFolder),
- FXMAPFUNC(SEL_COMMAND,FilePanel::ID_EXTRACT_HERE,FilePanel::onCmdExtractHere),
-+#if defined(linux) || defined(__FreeBSD__)
- FXMAPFUNC(SEL_COMMAND,FilePanel::ID_RUN_SCRIPT,FilePanel::onCmdRunScript),
-+#endif
- FXMAPFUNC(SEL_UPDATE,FilePanel::ID_RUN_SCRIPT,FilePanel::onUpdRunScript),
-+#if defined(linux) || defined(__FreeBSD__)
- FXMAPFUNC(SEL_COMMAND,FilePanel::ID_GO_SCRIPTDIR,FilePanel::onCmdGoScriptDir),
-+#endif
- FXMAPFUNC(SEL_RIGHTBUTTONRELEASE,FilePanel::ID_FILELIST,FilePanel::onCmdPopupMenu),
- FXMAPFUNC(SEL_COMMAND,FilePanel::ID_POPUP_MENU,FilePanel::onCmdPopupMenu),
- FXMAPFUNC(SEL_DOUBLECLICKED,FilePanel::ID_FILELIST,FilePanel::onCmdItemDoubleClicked),
-@@ -4548,108 +4552,6 @@
- }
-
-
--// Run script
--long FilePanel::onCmdRunScript(FXObject* o, FXSelector sel, void*)
--{
-- // Wait cursor
-- getApp()->beginWaitCursor();
--
-- FXString pathname, cmd, itemslist=" ";
-- FXString scriptpath = dynamic_cast<FXMenuCommand *>(o)->getHelpText();
--
-- // Construct selected files list
-- current->list->setFocus();
-- for (int u=0; u<current->list->getNumItems(); u++)
-- {
-- if (current->list->isItemSelected(u))
-- {
-- pathname=current->list->getItemPathname(u);
--
-- // List of selected items
-- itemslist += ::quote(pathname) + " ";
-- }
-- }
--
-- // Construct command line
-- cmd = scriptpath + itemslist + " &";
--
-- // Go to the current directory
-- int ret=chdir(current->list->getDirectory().text());
-- if (ret < 0)
-- {
-- int errcode=errno;
-- if (errcode)
-- MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s: %s"),current->list->getDirectory().text(),strerror(errcode));
-- else
-- MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s"),current->list->getDirectory().text());
-- }
--
-- // Execute command
-- static pid_t child_pid = 0;
-- switch ((child_pid = fork ()))
-- {
-- case -1:
-- fprintf (stderr,_("Error: Fork failed: %s\n"),strerror (errno));
-- break;
--
-- case 0:
-- execl("/bin/sh","sh","-c",cmd.text(),(char *)NULL);
-- exit(1);
-- break;
-- }
--
-- // Return to the starting directory
-- ret=chdir(startlocation.text());
-- if (ret < 0)
-- {
-- int errcode=errno;
-- if (errcode)
-- MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s: %s"),startlocation.text(),strerror(errcode));
-- else
-- MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s"),startlocation.text());
-- }
--
-- getApp()->endWaitCursor();
--
-- return 1;
--}
--
--
--// Go to scripts directory
--long FilePanel::onCmdGoScriptDir(FXObject* o, FXSelector sel, void*)
--{
-- FXString scriptpath = homedir + PATHSEPSTRING CONFIGPATH PATHSEPSTRING XFECONFIGPATH PATHSEPSTRING SCRIPTPATH;
--
-- if (!::exists(scriptpath))
-- {
-- // Create the script directory according to the umask
-- int mask=umask(0);
-- umask(mask);
-- errno=0;
-- int ret=mkpath(scriptpath.text(),511 & ~mask);
-- int errcode=errno;
-- if (ret==-1)
-- {
-- if (errcode)
-- MessageBox::error(this,BOX_OK,_("Error"),_("Can't create script folder %s: %s"),scriptpath.text(),strerror(errcode));
-- else
-- MessageBox::error(this,BOX_OK,_("Error"),_("Can't create script folder %s"),scriptpath.text());
--
-- return 0;
-- }
-- }
--
-- // Go to scripts directory
-- current->list->setDirectory(scriptpath);
-- current->list->setFocus();
-- dirpanel->setDirectory(scriptpath,TRUE);
-- current->updatePath();
-- updateLocation();
--
-- return 1;
--}
--
--
- // Update the Mount button
- long FilePanel::onUpdMount(FXObject* o,FXSelector sel,void*)
- {
-@@ -4815,6 +4717,114 @@
- }
- #endif // End #if defined(linux)
-
-+#if defined(linux) || defined(__FreeBSD__)
-+
-+// Go to scripts directory
-+long FilePanel::onCmdGoScriptDir(FXObject* o, FXSelector sel, void*)
-+{
-+ FXString scriptpath = homedir + PATHSEPSTRING CONFIGPATH PATHSEPSTRING XFECONFIGPATH PATHSEPSTRING SCRIPTPATH;
-+
-+ if (!::exists(scriptpath))
-+ {
-+ // Create the script directory according to the umask
-+ int mask=umask(0);
-+ umask(mask);
-+ errno=0;
-+ int ret=mkpath(scriptpath.text(),511 & ~mask);
-+ int errcode=errno;
-+ if (ret==-1)
-+ {
-+ if (errcode)
-+ MessageBox::error(this,BOX_OK,_("Error"),_("Can't create script folder %s: %s"),scriptpath.text(),strerror(errcode));
-+ else
-+ MessageBox::error(this,BOX_OK,_("Error"),_("Can't create script folder %s"),scriptpath.text());
-+
-+ return 0;
-+ }
-+ }
-+
-+ // Go to scripts directory
-+ current->list->setDirectory(scriptpath);
-+ current->list->setFocus();
-+ dirpanel->setDirectory(scriptpath,TRUE);
-+ current->updatePath();
-+ updateLocation();
-+
-+ return 1;
-+}
-+
-+// Run script
-+long FilePanel::onCmdRunScript(FXObject* o, FXSelector sel, void*)
-+{
-+ // Wait cursor
-+ getApp()->beginWaitCursor();
-+
-+ FXString pathname, cmd, itemslist=" ";
-+ FXString scriptpath = dynamic_cast<FXMenuCommand *>(o)->getHelpText();
-+
-+ // Construct selected files list
-+ current->list->setFocus();
-+ for (int u=0; u<current->list->getNumItems(); u++)
-+ {
-+ if (current->list->isItemSelected(u))
-+ {
-+ pathname=current->list->getItemPathname(u);
-+
-+ // List of selected items
-+ itemslist += ::quote(pathname) + " ";
-+ }
-+ }
-+
-+ // Construct command line
-+ cmd = scriptpath + itemslist + " &";
-+
-+ // Go to the current directory
-+ int ret=chdir(current->list->getDirectory().text());
-+ if (ret < 0)
-+ {
-+ int errcode=errno;
-+ if (errcode)
-+ MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s: %s"),current->list->getDirectory().text(),strerror(errcode));
-+ else
-+ MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s"),current->list->getDirectory().text());
-+ }
-+
-+ // Execute command
-+ static pid_t child_pid = 0;
-+ switch ((child_pid = fork ()))
-+ {
-+ case -1:
-+ fprintf (stderr,_("Error: Fork failed: %s\n"),strerror (errno));
-+ break;
-+
-+ case 0:
-+ execl("/bin/sh","sh","-c",cmd.text(),(char *)NULL);
-+ exit(1);
-+ break;
-+ }
-+
-+ // Return to the starting directory
-+ ret=chdir(startlocation.text());
-+ if (ret < 0)
-+ {
-+ int errcode=errno;
-+ if (errcode)
-+ MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s: %s"),startlocation.text(),strerror(errcode));
-+ else
-+ MessageBox::error(this,BOX_OK,_("Error"),_("Can't enter folder %s"),startlocation.text());
-+ }
-+
-+ getApp()->endWaitCursor();
-+
-+ return 1;
-+}
-+
-+
-+
-+#endif
-+
-+
-+
-
- // Update the status bar and the path linker
- long FilePanel::onUpdStatus(FXObject* sender,FXSelector,void*)
---- src/FilePanel.h.orig 2013-08-20 15:14:01.000000000 +0200
-+++ src/FilePanel.h 2013-08-26 18:06:46.000000000 +0200
-@@ -176,7 +176,9 @@
- long onCmdToggleHidden(FXObject*,FXSelector,void*);
- long onUpdToggleHidden(FXObject*,FXSelector,void*);
- long onCmdToggleThumbnails(FXObject*,FXSelector,void*);
-+#if defined(linux) || defined(__FreeBSD__)
- long onCmdRunScript(FXObject* o,FXSelector sel,void*);
-+#endif
- long onUpdToggleThumbnails(FXObject*,FXSelector,void*);
- long onCmdAddToArch(FXObject*,FXSelector,void*);
- long onUpdMenu(FXObject*,FXSelector,void*);
-@@ -190,7 +192,9 @@
- void updatePath();
- long onCmdStopListRefreshTimer(FXObject*,FXSelector,void*);
- long onUpdRunScript(FXObject*,FXSelector,void*);
-+#if defined(linux) || defined(__FreeBSD__)
- long onCmdGoScriptDir(FXObject*, FXSelector, void*);
-+#endif
-
- #if defined(linux)
- long onCmdMount(FXObject*,FXSelector,void*);
diff --git a/x11-fm/xfe/files/patch-xvt_ttyinit.c b/x11-fm/xfe/files/patch-xvt_ttyinit.c
deleted file mode 100644
index daeaf4b3156c..000000000000
--- a/x11-fm/xfe/files/patch-xvt_ttyinit.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- xvt/ttyinit.c.orig 2013-08-13 17:49:45.000000000 +0200
-+++ xvt/ttyinit.c 2013-08-26 17:37:10.000000000 +0200
-@@ -37,7 +37,6 @@
- #include <unistd.h>
- #include <signal.h>
- #include <fcntl.h>
--#include <utmp.h>
- #include <sys/param.h>
- #if __FreeBSD_version >= 900007
- # include <utmpx.h>
-@@ -394,7 +393,6 @@
- static char* get_pseudo_tty(int* pmaster, int* pslave)
- {
- int mfd = 0, sfd = 0;
-- char *ttynam = NULL;
- #if defined(BSD_PTY) || defined(__FreeBSD__)
- char *s3, *s4;
- static char ptyc3[] = "pqrstuvwxyz";
-@@ -435,7 +433,9 @@
- error("could not open slave tty %s",ttynam);
- return(NULL);
- }
--#endif /* BSD_PTY */
-+#else /* BSD_PTY */
-+ char *ttynam = NULL;
-+#endif
-
- #ifdef SVR4_PTY
-
diff --git a/x11-fm/xfe/pkg-plist b/x11-fm/xfe/pkg-plist
index bed9c5237611..eee1b3ba3ce7 100644
--- a/x11-fm/xfe/pkg-plist
+++ b/x11-fm/xfe/pkg-plist
@@ -3,29 +3,34 @@ bin/xfi
bin/xfp
bin/xfv
bin/xfw
-share/locale/bs/LC_MESSAGES/xfe.mo
-share/locale/ca/LC_MESSAGES/xfe.mo
-share/locale/cs/LC_MESSAGES/xfe.mo
-share/locale/da/LC_MESSAGES/xfe.mo
-share/locale/de/LC_MESSAGES/xfe.mo
-share/locale/el/LC_MESSAGES/xfe.mo
-share/locale/es/LC_MESSAGES/xfe.mo
-share/locale/es_AR/LC_MESSAGES/xfe.mo
-share/locale/es_CO/LC_MESSAGES/xfe.mo
-share/locale/fr/LC_MESSAGES/xfe.mo
-share/locale/hu/LC_MESSAGES/xfe.mo
-share/locale/it/LC_MESSAGES/xfe.mo
-share/locale/ja/LC_MESSAGES/xfe.mo
-share/locale/nl/LC_MESSAGES/xfe.mo
-share/locale/no/LC_MESSAGES/xfe.mo
-share/locale/pl/LC_MESSAGES/xfe.mo
-share/locale/pt_BR/LC_MESSAGES/xfe.mo
-share/locale/pt_PT/LC_MESSAGES/xfe.mo
-share/locale/ru/LC_MESSAGES/xfe.mo
-share/locale/sv/LC_MESSAGES/xfe.mo
-share/locale/tr/LC_MESSAGES/xfe.mo
-share/locale/zh_CN/LC_MESSAGES/xfe.mo
-share/locale/zh_TW/LC_MESSAGES/xfe.mo
+man/man1/xfe.1.gz
+man/man1/xfi.1.gz
+man/man1/xfp.1.gz
+man/man1/xfv.1.gz
+man/man1/xfw.1.gz
+%%NLS%%share/locale/bs/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/es_AR/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/es_CO/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/no/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfe.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfe.mo
share/pixmaps/xfe.png
share/pixmaps/xfi.png
share/pixmaps/xfp.png
@@ -2834,7 +2839,7 @@ share/applications/xfp.desktop
@dirrm %%DATADIR%%/icons/blue-theme
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
-@dirrmtry share/locale/es_CO/LC_MESSAGES
-@dirrmtry share/locale/es_CO
-@dirrmtry share/locale/es_AR/LC_MESSAGES
-@dirrmtry share/locale/es_AR
+%%NLS%%@dirrmtry share/locale/es_CO/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_CO
+%%NLS%%@dirrmtry share/locale/es_AR/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_AR