aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-09-28 17:01:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-09-28 17:01:46 +0000
commit7691be7ceeef77f469de0733c84f8a445cd050b1 (patch)
treec04109c61bf3608175d18bf74d8256e27edd61f2 /x11-fm
parent1fb4059d03a0f07c65ef04a25415f0858802e8bb (diff)
downloadports-7691be7ceeef77f469de0733c84f8a445cd050b1.tar.gz
ports-7691be7ceeef77f469de0733c84f8a445cd050b1.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/gnome-commander2/Makefile19
-rw-r--r--x11-fm/gnome-commander2/distinfo6
-rw-r--r--x11-fm/gnome-commander2/files/patch-configure11
-rw-r--r--x11-fm/gnome-commander2/files/patch-src::gnome-cmd-dir-indicator.c16
-rw-r--r--x11-fm/gnome-commander2/pkg-plist57
5 files changed, 69 insertions, 40 deletions
diff --git a/x11-fm/gnome-commander2/Makefile b/x11-fm/gnome-commander2/Makefile
index 08a283809a5c..f3c084266ab6 100644
--- a/x11-fm/gnome-commander2/Makefile
+++ b/x11-fm/gnome-commander2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnome-commander
-PORTVERSION= 1.1.6
-PORTREVISION= 3
+PORTVERSION= 1.2.0
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-commander/1.1
+MASTER_SITE_SUBDIR= sources/gnome-commander/1.2
PKGNAMESUFFIX= 2
DIST_SUBDIR= gnome2
@@ -19,12 +18,20 @@ COMMENT= File manager for Gnome2
CONFLICTS= gnome-commander-*
+USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gnomedocutils libgnomeui
+USE_GCC= 3.4+
USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GNOME= gnomeprefix gnomehack gnometarget libgnomeui lthack
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lintl"
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+INSTALLS_OMF= yes
+
+MAN1= gnome-commander.1
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|share/pixmaps|share/gnome/pixmaps|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11-fm/gnome-commander2/distinfo b/x11-fm/gnome-commander2/distinfo
index 99f94e744aa0..94d24b8c12f3 100644
--- a/x11-fm/gnome-commander2/distinfo
+++ b/x11-fm/gnome-commander2/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-commander-1.1.6.tar.bz2) = 972e976ea01663f5b60e8a16721a5348
-SHA256 (gnome2/gnome-commander-1.1.6.tar.bz2) = a1174ddfde5b6195de8060517eca784c779c6d106088254039c663693d5b31b0
-SIZE (gnome2/gnome-commander-1.1.6.tar.bz2) = 600318
+MD5 (gnome2/gnome-commander-1.2.0.tar.bz2) = 2f34596e4c8a927efdb4ab987b82c7f0
+SHA256 (gnome2/gnome-commander-1.2.0.tar.bz2) = 9ff2f8c23793691fe5043a8be5550a3eeb2ddc01a7f15b18d7a406fabcf53152
+SIZE (gnome2/gnome-commander-1.2.0.tar.bz2) = 800904
diff --git a/x11-fm/gnome-commander2/files/patch-configure b/x11-fm/gnome-commander2/files/patch-configure
deleted file mode 100644
index d2b59243a68d..000000000000
--- a/x11-fm/gnome-commander2/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Wed Jun 16 02:32:23 2004
-+++ configure Wed Jun 16 02:33:14 2004
-@@ -9609,7 +9609,7 @@
-
-
- cat >>confdefs.h <<_ACEOF
--#define PIXMAPS_DIR "${PREFIX}/share/pixmaps/${PACKAGE}"
-+#define PIXMAPS_DIR "${PREFIX}/share/gnome/pixmaps/${PACKAGE}"
- _ACEOF
-
-
diff --git a/x11-fm/gnome-commander2/files/patch-src::gnome-cmd-dir-indicator.c b/x11-fm/gnome-commander2/files/patch-src::gnome-cmd-dir-indicator.c
deleted file mode 100644
index 2f1a4fe28e56..000000000000
--- a/x11-fm/gnome-commander2/files/patch-src::gnome-cmd-dir-indicator.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/gnome-cmd-dir-indicator.c.orig Tue Jun 22 19:55:28 2004
-+++ src/gnome-cmd-dir-indicator.c Tue Jun 22 19:56:15 2004
-@@ -91,11 +91,11 @@
- if (event->type == GDK_BUTTON_PRESS && event->button == 1) {
- /* left click - work out the path */
- gchar *chTo;
-+ gint i;
- const gchar *labelText = gtk_label_get_text (GTK_LABEL (indicator->priv->label));
-+ gint x = (gint)event->x;
- chTo = malloc (strlen (labelText) + 1);
- strcpy (chTo, labelText);
-- gint x = (gint)event->x;
-- gint i;
-
- for (i = 0; i < indicator->priv->numPositions; i++) {
- if (x < indicator->priv->slashPixelPosition[i]) {
diff --git a/x11-fm/gnome-commander2/pkg-plist b/x11-fm/gnome-commander2/pkg-plist
index 09070b29b1cb..822b62a24bd0 100644
--- a/x11-fm/gnome-commander2/pkg-plist
+++ b/x11-fm/gnome-commander2/pkg-plist
@@ -4,6 +4,10 @@ lib/gnome-commander/libgcmd.a
lib/gnome-commander/libgcmd.la
lib/gnome-commander/libgcmd.so
lib/gnome-commander/libgcmd.so.0
+lib/gnome-commander/libgviewer.a
+lib/gnome-commander/libgviewer.la
+lib/gnome-commander/libgviewer.so
+lib/gnome-commander/libgviewer.so.0
lib/gnome-commander/plugins/libcvs.a
lib/gnome-commander/plugins/libcvs.la
lib/gnome-commander/plugins/libcvs.so
@@ -17,10 +21,29 @@ lib/gnome-commander/plugins/libtest.la
lib/gnome-commander/plugins/libtest.so
lib/gnome-commander/plugins/libtest.so.0
share/gnome/applications/gnome-commander.desktop
+share/gnome/help/gnome-commander/C/figures/create_archive.png
+share/gnome/help/gnome-commander/C/figures/dev_cd.png
+share/gnome/help/gnome-commander/C/figures/extract_archive.png
+share/gnome/help/gnome-commander/C/figures/mounting.png
+share/gnome/help/gnome-commander/C/gnome-commander.xml
+share/gnome/help/gnome-commander/C/legal.xml
+share/gnome/omf/gnome-commander/gnome-commander-C.omf
+share/gnome/pixmaps/gnome-commander/copy_file_names.xpm
+share/gnome/pixmaps/gnome-commander/desktop.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/bluetooth.xpm
share/gnome/pixmaps/gnome-commander/device-icons/burner.xpm
share/gnome/pixmaps/gnome-commander/device-icons/camera.xpm
share/gnome/pixmaps/gnome-commander/device-icons/cdrom.xpm
share/gnome/pixmaps/gnome-commander/device-icons/floppy.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/harddisk.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/ipod.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/pci.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/removable-1394.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/removable-usb.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/removable.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/usb.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/wavelan-encrypted.xpm
+share/gnome/pixmaps/gnome-commander/device-icons/wavelan.xpm
share/gnome/pixmaps/gnome-commander/device-icons/zip.xpm
share/gnome/pixmaps/gnome-commander/exec.xpm
share/gnome/pixmaps/gnome-commander/exec_wheel.xpm
@@ -31,13 +54,12 @@ share/gnome/pixmaps/gnome-commander/file-type-icons/file_type_fifo.xpm
share/gnome/pixmaps/gnome-commander/file-type-icons/file_type_regular.xpm
share/gnome/pixmaps/gnome-commander/file-type-icons/file_type_socket.xpm
share/gnome/pixmaps/gnome-commander/file-type-icons/file_type_symlink.xpm
+share/gnome/pixmaps/gnome-commander/flip-horizontal-16.xpm
+share/gnome/pixmaps/gnome-commander/flip-vertical-16.xpm
share/gnome/pixmaps/gnome-commander/ftp.xpm
share/gnome/pixmaps/gnome-commander/ftp_connect.xpm
share/gnome/pixmaps/gnome-commander/ftp_disconnect.xpm
-share/gnome/pixmaps/gnome-commander/gcmd-icon1.png
-share/gnome/pixmaps/gnome-commander/gcmd-icon1.xpm
-share/gnome/pixmaps/gnome-commander/gcmd-icon2.png
-share/gnome/pixmaps/gnome-commander/gcmd-icon3.xpm
+share/gnome/pixmaps/gnome-commander/gnome-commander.xpm
share/gnome/pixmaps/gnome-commander/gnome_cmd_arrow_blank.xpm
share/gnome/pixmaps/gnome-commander/gnome_cmd_arrow_down.xpm
share/gnome/pixmaps/gnome-commander/gnome_cmd_arrow_up.xpm
@@ -95,27 +117,54 @@ share/gnome/pixmaps/gnome-commander/overlay_symlink.xpm
share/gnome/pixmaps/gnome-commander/overlay_umount.xpm
share/gnome/pixmaps/gnome-commander/parent_dir.xpm
share/gnome/pixmaps/gnome-commander/root_dir.xpm
+share/gnome/pixmaps/gnome-commander/rotate-180-16.xpm
+share/gnome/pixmaps/gnome-commander/rotate-270-16.xpm
+share/gnome/pixmaps/gnome-commander/rotate-90-16.xpm
share/gnome/pixmaps/gnome-commander/server.xpm
share/gnome/pixmaps/gnome-commander/smb-computer.xpm
share/gnome/pixmaps/gnome-commander/smb-network.xpm
share/gnome/pixmaps/gnome-commander/toggle_horizontal.xpm
share/gnome/pixmaps/gnome-commander/toggle_vertical.xpm
+share/gnome/pixmaps/gnome-commander.png
share/locale/ca/LC_MESSAGES/gnome-commander.mo
share/locale/cs/LC_MESSAGES/gnome-commander.mo
share/locale/de/LC_MESSAGES/gnome-commander.mo
+share/locale/el/LC_MESSAGES/gnome-commander.mo
+share/locale/en_CA/LC_MESSAGES/gnome-commander.mo
+share/locale/en_GB/LC_MESSAGES/gnome-commander.mo
share/locale/es/LC_MESSAGES/gnome-commander.mo
+share/locale/eu/LC_MESSAGES/gnome-commander.mo
share/locale/fr/LC_MESSAGES/gnome-commander.mo
+share/locale/ga/LC_MESSAGES/gnome-commander.mo
+share/locale/hr/LC_MESSAGES/gnome-commander.mo
+share/locale/hu/LC_MESSAGES/gnome-commander.mo
+share/locale/nb/LC_MESSAGES/gnome-commander.mo
+share/locale/ne/LC_MESSAGES/gnome-commander.mo
share/locale/nl/LC_MESSAGES/gnome-commander.mo
+share/locale/pa/LC_MESSAGES/gnome-commander.mo
share/locale/pl/LC_MESSAGES/gnome-commander.mo
share/locale/pt/LC_MESSAGES/gnome-commander.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-commander.mo
+share/locale/ro/LC_MESSAGES/gnome-commander.mo
share/locale/ru/LC_MESSAGES/gnome-commander.mo
+share/locale/rw/LC_MESSAGES/gnome-commander.mo
share/locale/sk/LC_MESSAGES/gnome-commander.mo
+share/locale/sl/LC_MESSAGES/gnome-commander.mo
+share/locale/sq/LC_MESSAGES/gnome-commander.mo
share/locale/sr/LC_MESSAGES/gnome-commander.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-commander.mo
share/locale/sv/LC_MESSAGES/gnome-commander.mo
+share/locale/uk/LC_MESSAGES/gnome-commander.mo
+share/locale/vi/LC_MESSAGES/gnome-commander.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-commander.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-commander.mo
@dirrm share/gnome/pixmaps/gnome-commander/mime-icons
@dirrm share/gnome/pixmaps/gnome-commander/file-type-icons
@dirrm share/gnome/pixmaps/gnome-commander/device-icons
@dirrm share/gnome/pixmaps/gnome-commander
+@dirrm share/gnome/omf/gnome-commander
+@dirrm share/gnome/help/gnome-commander/C/figures
+@dirrm share/gnome/help/gnome-commander/C
+@dirrm share/gnome/help/gnome-commander
@dirrm lib/gnome-commander/plugins
@dirrm lib/gnome-commander