aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2001-08-12 06:51:18 +0000
committerDoug Barton <dougb@FreeBSD.org>2001-08-12 06:51:18 +0000
commita3ea1bc74cefdbb2d237eff9bfbf767fafeb2990 (patch)
tree60faa0795530e114a0518536cc28442c9909474a /x11-fm
parent26b2423814e52c49aa1f97e7a645d9c71e55e73a (diff)
downloadports-a3ea1bc74cefdbb2d237eff9bfbf767fafeb2990.tar.gz
ports-a3ea1bc74cefdbb2d237eff9bfbf767fafeb2990.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/gentoo/Makefile54
-rw-r--r--x11-fm/gentoo/distinfo1
-rw-r--r--x11-fm/gentoo/files/patch-src-Makefile32
-rw-r--r--x11-fm/gentoo/pkg-comment1
-rw-r--r--x11-fm/gentoo/pkg-descr9
-rw-r--r--x11-fm/gentoo/pkg-plist223
7 files changed, 321 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index 068f5d10330c..dee958a8b102 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -9,6 +9,7 @@
SUBDIR += ezfm
SUBDIR += filerunner
SUBDIR += fsv
+ SUBDIR += gentoo
SUBDIR += gnomemc
SUBDIR += jafm
SUBDIR += mtoolsfm
diff --git a/x11-fm/gentoo/Makefile b/x11-fm/gentoo/Makefile
new file mode 100644
index 000000000000..1804ebfc38a8
--- /dev/null
+++ b/x11-fm/gentoo/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: gentoo
+# Date created: 12 August 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gentoo
+PORTVERSION= 0.11.16
+CATEGORIES= x11-fm
+MASTER_SITES= http://www.obsession.se/gentoo/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+
+MAINTAINER= anders@fix.no
+
+USE_GTK= yes
+
+MAN1= gentoo.1
+
+DOCS= BUGS CONFIG-CHANGES CREDITS FIXES-0.11 FIXES-0.9 README \
+ README.NLS README.gtkrc TODO gentoorc-example \
+ gentoogtkrc-example
+
+post-patch:
+ @ ${MV} ${WRKSRC}/gentoorc-example ${WRKSRC}/gentoorc-example.Dist
+ @ ${SED} 's#icons#${PREFIX}/share/gentoo/icons#' \
+ ${WRKSRC}/gentoorc-example.Dist > ${WRKSRC}/gentoorc-example
+
+ @ ${MV} ${WRKSRC}/src/Makefile ${WRKSRC}/src/Makefile.patched
+ @ ${SED} -e 's#/home/emil/data/projects/gentoo#${PREFIX}/share#' \
+ -e 's#gtk-config#${GTK_CONFIG}#' ${WRKSRC}/src/Makefile.patched \
+ > ${WRKSRC}/src/Makefile
+
+ @ ${MV} ${WRKSRC}/widgets/Makefile ${WRKSRC}/widgets/Makefile.Dist
+ @ ${SED} -e 's#gtk-config#${GTK_CONFIG}#' -e 's#^CC.*##' \
+ ${WRKSRC}/widgets/Makefile.Dist > ${WRKSRC}/widgets/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/gentoo ${PREFIX}/bin
+ @${INSTALL} -d -m 0755 ${PREFIX}/share/gentoo
+ ${CP} -R ${WRKSRC}/icons ${PREFIX}/share/gentoo
+ ${CHMOD} 0755 ${PREFIX}/share/gentoo/icons
+ ${INSTALL_DATA} ${WRKSRC}/gentoorc-example ${PREFIX}/etc/gentoorc
+ ${INSTALL_MAN} ${WRKSRC}/docs/gentoo.1x ${PREFIX}/man/man1/gentoo.1
+.if !defined(NOPORTDOCS)
+ ${CP} -R ${WRKSRC}/docs ${PREFIX}/share/doc/gentoo/
+ ${CHMOD} 0755 ${PREFIX}/share/doc/gentoo
+ ${RM} ${PREFIX}/share/doc/gentoo/gentoo.1x
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/gentoo
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fm/gentoo/distinfo b/x11-fm/gentoo/distinfo
new file mode 100644
index 000000000000..a3b9fb923ec5
--- /dev/null
+++ b/x11-fm/gentoo/distinfo
@@ -0,0 +1 @@
+MD5 (gentoo-0.11.16.tar.gz) = be4ad45d7e691785f8c98f7dda1dc2c0
diff --git a/x11-fm/gentoo/files/patch-src-Makefile b/x11-fm/gentoo/files/patch-src-Makefile
new file mode 100644
index 000000000000..5084881b303a
--- /dev/null
+++ b/x11-fm/gentoo/files/patch-src-Makefile
@@ -0,0 +1,32 @@
+--- src/Makefile.Dist Sun Apr 29 02:43:21 2001
++++ src/Makefile Sat Aug 11 22:38:12 2001
+@@ -71,25 +71,23 @@
+ window.o menus.o\
+ ../widgets/odemilbutton.o ../widgets/odscrolledbox.o ../widgets/odlabel.o
+
+-DEBUG = -g -O2 #-Wno-unused
++DEBUG = -g #-Wno-unused
+
+ # Feel free to add any compiler-specific flags you need here.
+
+-CC = gcc
+-
+ # These flags should work even on files that contain code that deals with
+ # 64-bit stuff. Sorry for the possibly counter-intuitive name. :)
+-CFLAGS_64BIT = -Wall -Wmissing-prototypes $(DEBUG) `gtk-config --cflags`\
++CFLAGS_64BIT = $(DEBUG) `gtk-config --cflags`\
+ -I/usr/X11R6/include -I../widgets -DGENTOO_PACKAGE='"gentoo"'\
+ -DGENTOO_LOCALEDIR='"/home/emil/data/projects/gentoo/locale"'
+
+ # Most files compile with the flags that are 64-bit compliant, plus some
+ # more to ensure ANSI compatibility.
+-CFLAGS += $(CFLAGS_64BIT) -ansi -pedantic
++CFLAGS += $(CFLAGS_64BIT)
+
+ # Add names of any required libraries here (only included in final link).
+ #LIBINTL = -lintl
+-LIBS = -L/usr/lib -L/usr/X11R6/lib `gtk-config --libs` -rdynamic -ldl -lXi -lXext -lX11 -lm $(LIBINTL)
++LIBS = -L/usr/lib -L/usr/X11R6/lib `gtk-config --libs` -rdynamic -lXi -lXext -lX11 -lm $(LIBINTL)
+
+ # ----------------------------------------- Targets
+
diff --git a/x11-fm/gentoo/pkg-comment b/x11-fm/gentoo/pkg-comment
new file mode 100644
index 000000000000..824e01a0815a
--- /dev/null
+++ b/x11-fm/gentoo/pkg-comment
@@ -0,0 +1 @@
+Gtk+ based, file manager inspired by DirectoryOpus
diff --git a/x11-fm/gentoo/pkg-descr b/x11-fm/gentoo/pkg-descr
new file mode 100644
index 000000000000..537aed783187
--- /dev/null
+++ b/x11-fm/gentoo/pkg-descr
@@ -0,0 +1,9 @@
+gentoo is a modern, powerful, flexible, and utterly configurable file manager
+for UNIX systems, written using the GTK+ toolkit. It aims to be 100%
+graphically configurable; there's no need to edit config files by hand and then
+restart the application. gentoo is somewhat inspired in its look & feel by the
+classic Amiga program DirectoryOpus.
+
+WWW: http://www.obsession.se/gentoo/
+
+- Anders Nordby <anders@fix.no>
diff --git a/x11-fm/gentoo/pkg-plist b/x11-fm/gentoo/pkg-plist
new file mode 100644
index 000000000000..d430bebe0187
--- /dev/null
+++ b/x11-fm/gentoo/pkg-plist
@@ -0,0 +1,223 @@
+bin/gentoo
+etc/gentoorc
+share/gentoo/icons/xpm2.xpm
+share/gentoo/icons/aiff.xpm
+share/gentoo/icons/Amiga.xpm
+share/gentoo/icons/Animation.xpm
+share/gentoo/icons/Apple.xpm
+share/gentoo/icons/au.xpm
+share/gentoo/icons/avi.xpm
+share/gentoo/icons/Bad.xpm
+share/gentoo/icons/Battery.xpm
+share/gentoo/icons/bmp.xpm
+share/gentoo/icons/bmp2.xpm
+share/gentoo/icons/BSD.xpm
+share/gentoo/icons/c.xpm
+share/gentoo/icons/Card.xpm
+share/gentoo/icons/CDROM.xpm
+share/gentoo/icons/class.xpm
+share/gentoo/icons/conf.xpm
+share/gentoo/icons/COPYING
+share/gentoo/icons/core.xpm
+share/gentoo/icons/cpp.xpm
+share/gentoo/icons/Database.xpm
+share/gentoo/icons/deb.xpm
+share/gentoo/icons/Directory.xpm
+share/gentoo/icons/Directory2.xpm
+share/gentoo/icons/Document.xpm
+share/gentoo/icons/EggTimer.xpm
+share/gentoo/icons/eps.xpm
+share/gentoo/icons/ExcelCalcXLS.xpm
+share/gentoo/icons/exe.xpm
+share/gentoo/icons/Executable.xpm
+share/gentoo/icons/FIFO.xpm
+share/gentoo/icons/Floppy.xpm
+share/gentoo/icons/Font.xpm
+share/gentoo/icons/gentoo.png
+share/gentoo/icons/Ghost.xpm
+share/gentoo/icons/gif.xpm
+share/gentoo/icons/gif2.xpm
+share/gentoo/icons/GnomeCalc.xpm
+share/gentoo/icons/GnomeWord.xpm
+share/gentoo/icons/GNUstep.xpm
+share/gentoo/icons/h.xpm
+share/gentoo/icons/Harddrive.xpm
+share/gentoo/icons/html.xpm
+share/gentoo/icons/html2.xpm
+share/gentoo/icons/iff.xpm
+share/gentoo/icons/iff2.xpm
+share/gentoo/icons/Image.xpm
+share/gentoo/icons/Internet.xpm
+share/gentoo/icons/java.xpm
+share/gentoo/icons/jpeg.xpm
+share/gentoo/icons/jpeg2.xpm
+share/gentoo/icons/KDECalc.xpm
+share/gentoo/icons/KDEWord.xpm
+share/gentoo/icons/Kernel.xpm
+share/gentoo/icons/Keymap.xpm
+share/gentoo/icons/Lego.xpm
+share/gentoo/icons/License.xpm
+share/gentoo/icons/Linux.xpm
+share/gentoo/icons/log.xpm
+share/gentoo/icons/m.xpm
+share/gentoo/icons/Makefile.xpm
+share/gentoo/icons/man.xpm
+share/gentoo/icons/Maya.xpm
+share/gentoo/icons/midi.xpm
+share/gentoo/icons/Mixer.xpm
+share/gentoo/icons/mod.xpm
+share/gentoo/icons/Mouse.xpm
+share/gentoo/icons/Mouse2.xpm
+share/gentoo/icons/mov.xpm
+share/gentoo/icons/mov2.xpm
+share/gentoo/icons/mp3.xpm
+share/gentoo/icons/mpeg.xpm
+share/gentoo/icons/MSWordDoc.xpm
+share/gentoo/icons/NetAmiga.xpm
+share/gentoo/icons/NetApple.xpm
+share/gentoo/icons/NetHD.xpm
+share/gentoo/icons/NetSGI.xpm
+share/gentoo/icons/NetSun.xpm
+share/gentoo/icons/NetWindows.xpm
+share/gentoo/icons/o.xpm
+share/gentoo/icons/Package.xpm
+share/gentoo/icons/Package2.xpm
+share/gentoo/icons/pcx.xpm
+share/gentoo/icons/pcx2.xpm
+share/gentoo/icons/pdb.xpm
+share/gentoo/icons/pdf.xpm
+share/gentoo/icons/pl.xpm
+share/gentoo/icons/png.xpm
+share/gentoo/icons/png2.xpm
+share/gentoo/icons/Port.xpm
+share/gentoo/icons/Port2.xpm
+share/gentoo/icons/PowerButton.xpm
+share/gentoo/icons/prc.xpm
+share/gentoo/icons/Printer.xpm
+share/gentoo/icons/ps.xpm
+share/gentoo/icons/r.xpm
+share/gentoo/icons/ra.xpm
+share/gentoo/icons/README
+share/gentoo/icons/Readme.xpm
+share/gentoo/icons/rom.xpm
+share/gentoo/icons/rpm.xpm
+share/gentoo/icons/SCSI.xpm
+share/gentoo/icons/sh.xpm
+share/gentoo/icons/sid.xpm
+share/gentoo/icons/so.xpm
+share/gentoo/icons/SoundCard.xpm
+share/gentoo/icons/Source.xpm
+share/gentoo/icons/Speaker.xpm
+share/gentoo/icons/Speaker2.xpm
+share/gentoo/icons/Spreadsheet.xpm
+share/gentoo/icons/Tape.xpm
+share/gentoo/icons/targa.xpm
+share/gentoo/icons/targa2.xpm
+share/gentoo/icons/tex.xpm
+share/gentoo/icons/tiff.xpm
+share/gentoo/icons/tiff2.xpm
+share/gentoo/icons/txt.xpm
+share/gentoo/icons/VRML.xpm
+share/gentoo/icons/wav.xpm
+share/gentoo/icons/Windows.xpm
+share/gentoo/icons/xbm.xpm
+share/gentoo/icons/xbm2.xpm
+share/gentoo/icons/xcf.xpm
+share/gentoo/icons/xpm.xpm
+share/gentoo/icons/AbiWord.xpm
+@dirrm share/gentoo/icons
+@dirrm share/gentoo
+%%PORTDOCS%%share/doc/gentoo/config/cfg_types.html
+%%PORTDOCS%%share/doc/gentoo/config/cfg_gui.html
+%%PORTDOCS%%share/doc/gentoo/config/cfg_styles.html
+%%PORTDOCS%%share/doc/gentoo/config/cfg_dirpane.html
+%%PORTDOCS%%share/doc/gentoo/config/gentoorc.html
+%%PORTDOCS%%share/doc/gentoo/config/index.html
+%%PORTDOCS%%share/doc/gentoo/config/template.html
+%%PORTDOCS%%share/doc/gentoo/images/tone3.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_dirpane.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_gui.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_styles.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_styles2.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_styles3.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_types.gif
+%%PORTDOCS%%share/doc/gentoo/images/cfg_types2.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_chmod.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_dialog.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_inp1.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_inp2.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_inp3.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_inp4.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_inp5.gif
+%%PORTDOCS%%share/doc/gentoo/images/cmd_selectre.gif
+%%PORTDOCS%%share/doc/gentoo/images/colsel.jpeg
+%%PORTDOCS%%share/doc/gentoo/images/columnedit.gif
+%%PORTDOCS%%share/doc/gentoo/images/gentoo_logo.gif
+%%PORTDOCS%%share/doc/gentoo/images/gentoo_logo_g.gif
+%%PORTDOCS%%share/doc/gentoo/images/gentoo_logo_g_small.gif
+%%PORTDOCS%%share/doc/gentoo/images/gentoo_logo_small.gif
+%%PORTDOCS%%share/doc/gentoo/images/gentoo_logo_text.gif
+%%PORTDOCS%%share/doc/gentoo/images/iconsel.gif
+%%PORTDOCS%%share/doc/gentoo/images/layout.gif
+%%PORTDOCS%%share/doc/gentoo/images/od__logo_small.gif
+%%PORTDOCS%%share/doc/gentoo/images/popupmenu.gif
+%%PORTDOCS%%share/doc/gentoo/images/popupmenu2.gif
+%%PORTDOCS%%share/doc/gentoo/images/status_error.gif
+%%PORTDOCS%%share/doc/gentoo/images/stylesel.gif
+%%PORTDOCS%%share/doc/gentoo/images/style_tree.gif
+%%PORTDOCS%%share/doc/gentoo/images/tone.gif
+%%PORTDOCS%%share/doc/gentoo/images/tone2.gif
+%%PORTDOCS%%share/doc/gentoo/images/bullet.gif
+%%PORTDOCS%%share/doc/gentoo/scratch/symlinks.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/command_args.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/command_howto.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/command_options.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/dirhistory.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/filestyles.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/filetypes.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/focusing.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/mount.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/outline.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/README
+%%PORTDOCS%%share/doc/gentoo/scratch/renamere.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/search_howto.txt
+%%PORTDOCS%%share/doc/gentoo/scratch/commands.txt
+%%PORTDOCS%%share/doc/gentoo/commands.html
+%%PORTDOCS%%share/doc/gentoo/contribute.html
+%%PORTDOCS%%share/doc/gentoo/dirpanes.html
+%%PORTDOCS%%share/doc/gentoo/FAQ
+%%PORTDOCS%%share/doc/gentoo/BUGS
+%%PORTDOCS%%share/doc/gentoo/gentoo.css
+%%PORTDOCS%%share/doc/gentoo/gentoorc-example
+%%PORTDOCS%%share/doc/gentoo/gentoogtkrc-example
+%%PORTDOCS%%share/doc/gentoo/gpl.html
+%%PORTDOCS%%share/doc/gentoo/history.html
+%%PORTDOCS%%share/doc/gentoo/index.html
+%%PORTDOCS%%share/doc/gentoo/intro.html
+%%PORTDOCS%%share/doc/gentoo/layout.html
+%%PORTDOCS%%share/doc/gentoo/menus.html
+%%PORTDOCS%%share/doc/gentoo/menus.txt
+%%PORTDOCS%%share/doc/gentoo/misc.html
+%%PORTDOCS%%share/doc/gentoo/quick.html
+%%PORTDOCS%%share/doc/gentoo/relnotes.html
+%%PORTDOCS%%share/doc/gentoo/status.html
+%%PORTDOCS%%share/doc/gentoo/styles.html
+%%PORTDOCS%%share/doc/gentoo/template.html
+%%PORTDOCS%%share/doc/gentoo/template_toc.html
+%%PORTDOCS%%share/doc/gentoo/CREDITS
+%%PORTDOCS%%share/doc/gentoo/types.html
+%%PORTDOCS%%share/doc/gentoo/acks.html
+%%PORTDOCS%%share/doc/gentoo/usage.html
+%%PORTDOCS%%share/doc/gentoo/buttons.html
+%%PORTDOCS%%share/doc/gentoo/columns.html
+%%PORTDOCS%%share/doc/gentoo/CONFIG-CHANGES
+%%PORTDOCS%%share/doc/gentoo/FIXES-0.11
+%%PORTDOCS%%share/doc/gentoo/FIXES-0.9
+%%PORTDOCS%%share/doc/gentoo/README
+%%PORTDOCS%%share/doc/gentoo/README.NLS
+%%PORTDOCS%%share/doc/gentoo/README.gtkrc
+%%PORTDOCS%%share/doc/gentoo/TODO
+%%PORTDOCS%%@dirrm share/doc/gentoo/config
+%%PORTDOCS%%@dirrm share/doc/gentoo/images
+%%PORTDOCS%%@dirrm share/doc/gentoo/scratch
+%%PORTDOCS%%@dirrm share/doc/gentoo