aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-02-10 14:41:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-02-10 14:41:18 +0000
commit0086d547b25e9585ded11c0edff6255c062f92ce (patch)
tree33fc7ebe539f45e185e4e2e516ca66f8a2fcef57 /x11-fm
parent98bccede11eacefa0f4175796a33a9c891e4163a (diff)
downloadports-0086d547b25e9585ded11c0edff6255c062f92ce.tar.gz
ports-0086d547b25e9585ded11c0edff6255c062f92ce.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/pcmanfm/Makefile35
-rw-r--r--x11-fm/pcmanfm/distinfo3
-rw-r--r--x11-fm/pcmanfm/pkg-descr5
-rw-r--r--x11-fm/pcmanfm/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index c1de4eeff918..7da06ebc14df 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -22,6 +22,7 @@
SUBDIR += mtoolsfm
SUBDIR += nautilus2
SUBDIR += offix-files
+ SUBDIR += pcmanfm
SUBDIR += py-nautilus
SUBDIR += rox-filer
SUBDIR += rox-mime-editor
diff --git a/x11-fm/pcmanfm/Makefile b/x11-fm/pcmanfm/Makefile
new file mode 100644
index 000000000000..53932a68cb6c
--- /dev/null
+++ b/x11-fm/pcmanfm/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pcmanfm
+# Date created: 2006/02/03
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcmanfm
+PORTVERSION= 0.1.9.5
+CATEGORIES= x11-fm deskutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= PCMan File Manager
+
+USE_GNOME= gtk20 intlhack
+USE_GCC= 3.3+
+USE_AUTOTOOLS= libtool:15
+USE_X_PREFIX= yes
+USE_FAM= yes
+INSTALLS_SHLIB= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fm/pcmanfm/distinfo b/x11-fm/pcmanfm/distinfo
new file mode 100644
index 000000000000..de8fd04e1562
--- /dev/null
+++ b/x11-fm/pcmanfm/distinfo
@@ -0,0 +1,3 @@
+MD5 (pcmanfm-0.1.9.5.tar.gz) = 6a521a88b48f2e466c99d0c61f60acc4
+SHA256 (pcmanfm-0.1.9.5.tar.gz) = f9142ac11d90da59b2656cd21b776cd7836aae3358cd3bcc19e16847d152fddb
+SIZE (pcmanfm-0.1.9.5.tar.gz) = 268278
diff --git a/x11-fm/pcmanfm/pkg-descr b/x11-fm/pcmanfm/pkg-descr
new file mode 100644
index 000000000000..36f140c7d377
--- /dev/null
+++ b/x11-fm/pcmanfm/pkg-descr
@@ -0,0 +1,5 @@
+PCMan File Manager
+An extremly fast and lightweight file manager which features tabbed browsing
+and user-friendly interface
+
+WWW: http://pcmanfm.sourceforge.net/
diff --git a/x11-fm/pcmanfm/pkg-plist b/x11-fm/pcmanfm/pkg-plist
new file mode 100644
index 000000000000..ac6671a8df47
--- /dev/null
+++ b/x11-fm/pcmanfm/pkg-plist
@@ -0,0 +1,5 @@
+bin/pcmanfm
+%%NLS%%share/locale/fr/LC_MESSAGES/pcmanfm.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/pcmanfm.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/pcmanfm.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/pcmanfm.mo