aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-02 03:24:25 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-02 03:24:25 +0000
commitb748c845b6ace6b62203f2d4f4034b3bb374e3a3 (patch)
tree275db39f4edc0298914d4089417cab3aba6d28d7 /x11-fm
parent83c7e06d7a143b6dc256595156db696c21e7fd7c (diff)
downloadports-b748c845b6ace6b62203f2d4f4034b3bb374e3a3.tar.gz
ports-b748c845b6ace6b62203f2d4f4034b3bb374e3a3.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/doublecmd/Makefile268
-rw-r--r--x11-fm/doublecmd/distinfo4
-rw-r--r--x11-fm/doublecmd/files/patch-components__doublecmd__dcosutils.pas16
-rw-r--r--x11-fm/doublecmd/files/patch-plugins__wlx__WlxMplayer__src__wlxMplayer.lpr11
-rw-r--r--x11-fm/doublecmd/files/patch-src__ucmdlineparams.pas14
-rw-r--r--x11-fm/doublecmd/files/pkg-message.in6
6 files changed, 274 insertions, 45 deletions
diff --git a/x11-fm/doublecmd/Makefile b/x11-fm/doublecmd/Makefile
index 42470847c443..ad66a5d9a8ce 100644
--- a/x11-fm/doublecmd/Makefile
+++ b/x11-fm/doublecmd/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= doublecmd
-PORTVERSION= 0.5.5
-PORTREVISION= 1
+PORTVERSION= 0.5.7
CATEGORIES= x11-fm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/Double%20Commander%20Source
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tar.gz ${PORTNAME}-help-${PORTVERSION}-src.tar.gz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tar.gz ${PORTNAME}-help-${HELPVERSION}-src.tar.gz
MAINTAINER= bbtruk@users.sourceforge.net
COMMENT= Total Commander like file manager for the X Window System
@@ -34,14 +33,46 @@ PROJECT_FILE= src/doublecmd.lpi
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
LAZARUS_DIR= ${LOCALBASE}/share/lazarus
+HELPVERSION= 0.5.5
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-DOCSRC= ${WRKDIR}/${PORTNAME}-help-${PORTVERSION}
+DOCSRC= ${WRKDIR}/${PORTNAME}-help-${HELPVERSION}
OPTIONS_DEFINE= DOCS DEBUG
OPTIONS_SINGLE= LCL
OPTIONS_SINGLE_LCL= GTK2 QT4
-
-OPTIONS_DEFAULT= GTK2
+OPTIONS_GROUP= WCX WDX WFX WLX DSX
+WCX_DESC= Packer plugins
+WDX_DESC= Content plugins
+WFX_DESC= File sytem plugins
+WLX_DESC= Lister plugins
+DSX_DESC= Search plugins
+OPTIONS_GROUP_WCX= WCX_CPIO \
+ WCX_DEB \
+ WCX_LZMA \
+ WCX_RPM \
+ WCX_UNRAR \
+ WCX_ZIP
+OPTIONS_GROUP_WDX= WDX_RPM \
+ WDX_DEB \
+ WDX_SVN \
+ WDX_XPI \
+ WDX_SCRIPTS
+OPTIONS_GROUP_WFX= WFX_FTP \
+ WFX_SAMBA
+OPTIONS_GROUP_WLX= WLX_MPLAYER
+OPTIONS_GROUP_DSX= DSX_LOCATE
+
+OPTIONS_DEFAULT= GTK2 \
+ WCX_CPIO \
+ WCX_DEB \
+ WCX_LZMA \
+ WCX_RPM \
+ WDX_RPM \
+ WDX_DEB \
+ WDX_SVN \
+ WDX_SCRIPTS \
+ WDX_XPI \
+ DSX_LOCATE
NO_STAGE= yes
.include <bsd.port.pre.mk>
@@ -59,6 +90,18 @@ LCL_PLATFORM= qt
BUILD_DEPENDS+= ${LOCALBASE}/share/lazarus/lcl/units/${BUILDNAME}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
.endif
+.if ${PORT_OPTIONS:MWCX_UNRAR}
+LIB_DEPENDS+= unrar:${PORTSDIR}/archivers/libunrar
+.endif
+
+.if ${PORT_OPTIONS:MWFX_SAMBA}
+LIB_DEPENDS+= smbclient:${PORTSDIR}/net/samba-libsmbclient
+.endif
+
+.if ${PORT_OPTIONS:MWLX_MPLAYER}
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+.endif
+
.if ${PORT_OPTIONS:MDEBUG}
BUILD_MODE= Debug
.else
@@ -72,6 +115,8 @@ pre-patch:
post-patch:
@${REINPLACE_CMD} -e 's|%%DOCSDIR%%|${DOCSDIR}|g' -e 's|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/src/uGlobsPaths.pas
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/plugins/wlx/WlxMplayer/src/wlxMplayer.lpr
do-build:
.for FILE in chsdet/chsdet.lpk CmdLine/cmdbox.lpk dcpcrypt/dcpcrypt.lpk \
@@ -82,6 +127,67 @@ do-build:
${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "${FILE}"
.endfor
+.if ${PORT_OPTIONS:MWCX_CPIO}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/cpio/src/cpio.lpi"
+.endif
+.if ${PORT_OPTIONS:MWCX_DEB}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/deb/src/deb.lpi"
+.endif
+.if ${PORT_OPTIONS:MWCX_LZMA}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/lzma/src/lzma.lpi"
+.endif
+.if ${PORT_OPTIONS:MWCX_RPM}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/rpm/src/rpm.lpi"
+.endif
+.if ${PORT_OPTIONS:MWCX_UNRAR}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/unrar/src/unrar.lpi"
+.endif
+.if ${PORT_OPTIONS:MWCX_ZIP}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wcx/zip/src/Zip.lpi"
+.endif
+
+.if ${PORT_OPTIONS:MWDX_RPM}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wdx/rpm_wdx/src/rpm_wdx.lpi"
+.endif
+.if ${PORT_OPTIONS:MWDX_DEB}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wdx/deb_wdx/src/deb_wdx.lpi"
+.endif
+.if ${PORT_OPTIONS:MWDX_SVN}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wdx/svn_wdx/src/svn_wdx.lpi"
+.endif
+.if ${PORT_OPTIONS:MWDX_XPI}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wdx/xpi_wdx/src/xpi_wdx.lpi"
+.endif
+
+.if ${PORT_OPTIONS:MWFX_FTP}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wfx/ftp/src/ftp.lpi"
+.endif
+.if ${PORT_OPTIONS:MWFX_SAMBA}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wfx/samba/src/samba.lpi"
+.endif
+
+.if ${PORT_OPTIONS:MWLX_MPLAYER}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "wlx/WlxMplayer/src/wlxMplayer.lpi"
+.endif
+
+.if ${PORT_OPTIONS:MDSX_LOCATE}
+ @cd ${WRKSRC}/plugins && \
+ ${LAZBUILD_CMD} --lazarusdir=${LAZARUS_DIR} --ws=${LCL_PLATFORM} "dsx/DSXLocate/src/DSXLocate.lpi"
+.endif
+
@cd ${WRKSRC} && \
${LAZBUILD_CMD} --ws=${LCL_PLATFORM} --bm="${BUILD_MODE}" --lazarusdir=${LAZARUS_DIR} ${PROJECT_FILE}
@@ -91,9 +197,84 @@ post-build:
pre-install:
@${RM} -f ${PLIST}
+.if ${PORT_OPTIONS:MWCX_CPIO}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/cpio/cpio.wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx/cpio" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWCX_DEB}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/deb/deb.wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx/deb" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWCX_LZMA}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/lzma/lzma.wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx/lzma" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWCX_RPM}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/rpm/rpm.wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx/rpm" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWCX_UNRAR}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/unrar/unrar.wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx/unrar" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWCX_ZIP}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wcx/zip/zip.wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx/zip" >> ${PLIST}
+.endif
+
+.if ${PORT_OPTIONS:MWDX_RPM}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wdx/rpm_wdx/rpm_wdx.wdx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wdx/rpm_wdx" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWDX_DEB}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wdx/deb_wdx/deb_wdx.wdx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wdx/deb_wdx" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWDX_SVN}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wdx/svn_wdx/svn_wdx.wdx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wdx/svn_wdx" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWDX_XPI}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wdx/xpi_wdx/xpi_wdx.wdx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wdx/xpi_wdx" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWDX_SCRIPTS}
+ @cd ${WRKSRC}/plugins/wdx/scripts && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/plugins/wdx/scripts/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/plugins/wdx/scripts/|' >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wdx/scripts" >> ${PLIST}
+.endif
+
+.if ${PORT_OPTIONS:MWFX_FTP}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wfx/ftp/ftp.wfx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wfx/ftp" >> ${PLIST}
+.endif
+.if ${PORT_OPTIONS:MWFX_SAMBA}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wfx/samba/samba.wfx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wfx/samba" >> ${PLIST}
+.endif
+
+.if ${PORT_OPTIONS:MWLX_MPLAYER}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/wlx/wlxmplayer/wlxmplayer.wlx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wlx/wlxmplayer" >> ${PLIST}
+.endif
+
+.if ${PORT_OPTIONS:MDSX_LOCATE}
+ @${ECHO_CMD} "%%DATADIR%%/plugins/dsx/dsxlocate/dsxlocate.dsx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/dsx/dsxlocate" >> ${PLIST}
+.endif
+
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wcx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wdx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wfx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/wlx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins/dsx" >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%/plugins" >> ${PLIST}
+
.for FILE in %%DATADIR%%/doublecmd.ext.example %%DATADIR%%/pixmaps.txt \
%%DATADIR%%/multiarc.ini bin/doublecmd share/applications/doublecmd.desktop \
- share/pixmaps/doublecmd.png share/pixmaps/doublecmd.xpm
+ share/pixmaps/doublecmd.png share/pixmaps/doublecmd.xpm \
+ %%DATADIR%%/doublecmd.xml
@${ECHO_CMD} ${FILE} >> ${PLIST}
.endfor
@@ -117,6 +298,77 @@ pre-install:
@${ECHO_CMD} "@dirrmtry share/applications" >> ${PLIST}
do-install:
+ @${MKDIR} ${DATADIR}/plugins
+ @${MKDIR} ${DATADIR}/plugins/wcx
+ @${MKDIR} ${DATADIR}/plugins/wdx
+ @${MKDIR} ${DATADIR}/plugins/wfx
+ @${MKDIR} ${DATADIR}/plugins/wlx
+ @${MKDIR} ${DATADIR}/plugins/dsx
+.if ${PORT_OPTIONS:MWCX_CPIO}
+ @${MKDIR} ${DATADIR}/plugins/wcx/cpio
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/cpio/lib/cpio.wcx ${DATADIR}/plugins/wcx/cpio/
+.endif
+.if ${PORT_OPTIONS:MWCX_DEB}
+ @${MKDIR} ${DATADIR}/plugins/wcx/deb
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/deb/lib/deb.wcx ${DATADIR}/plugins/wcx/deb/
+.endif
+.if ${PORT_OPTIONS:MWCX_LZMA}
+ @${MKDIR} ${DATADIR}/plugins/wcx/lzma/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/lzma/lib/lzma.wcx ${DATADIR}/plugins/wcx/lzma/
+.endif
+.if ${PORT_OPTIONS:MWCX_RPM}
+ @${MKDIR} ${DATADIR}/plugins/wcx/rpm/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/rpm/lib/rpm.wcx ${DATADIR}/plugins/wcx/rpm/
+.endif
+.if ${PORT_OPTIONS:MWCX_UNRAR}
+ @${MKDIR} ${DATADIR}/plugins/wcx/unrar/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/unrar/lib/unrar.wcx ${DATADIR}/plugins/wcx/unrar/
+.endif
+.if ${PORT_OPTIONS:MWCX_ZIP}
+ @${MKDIR} ${DATADIR}/plugins/wcx/zip/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wcx/zip/lib/zip.wcx ${DATADIR}/plugins/wcx/zip/
+.endif
+
+.if ${PORT_OPTIONS:MWDX_RPM}
+ @${MKDIR} ${DATADIR}/plugins/wdx/rpm_wdx/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wdx/rpm_wdx/lib/rpm_wdx.wdx ${DATADIR}/plugins/wdx/rpm_wdx/
+.endif
+.if ${PORT_OPTIONS:MWDX_DEB}
+ @${MKDIR} ${DATADIR}/plugins/wdx/deb_wdx/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wdx/deb_wdx/lib/deb_wdx.wdx ${DATADIR}/plugins/wdx/deb_wdx/
+.endif
+.if ${PORT_OPTIONS:MWDX_SVN}
+ @${MKDIR} ${DATADIR}/plugins/wdx/svn_wdx/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wdx/svn_wdx/lib/svn_wdx.wdx ${DATADIR}/plugins/wdx/svn_wdx/
+.endif
+.if ${PORT_OPTIONS:MWDX_XPI}
+ @${MKDIR} ${DATADIR}/plugins/wdx/xpi_wdx/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wdx/xpi_wdx/lib/xpi_wdx.wdx ${DATADIR}/plugins/wdx/xpi_wdx/
+.endif
+.if ${PORT_OPTIONS:MWDX_SCRIPTS}
+ @${MKDIR} ${DATADIR}/plugins/wdx/scripts/
+ ${INSTALL_DATA} ${WRKSRC}/plugins/wdx/scripts/* ${DATADIR}/plugins/wdx/scripts/
+.endif
+
+.if ${PORT_OPTIONS:MWFX_FTP}
+ @${MKDIR} ${DATADIR}/plugins/wfx/ftp/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wfx/ftp/lib/ftp.wfx ${DATADIR}/plugins/wfx/ftp/
+.endif
+.if ${PORT_OPTIONS:MWFX_SAMBA}
+ @${MKDIR} ${DATADIR}/plugins/wfx/samba/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wfx/samba/lib/samba.wfx ${DATADIR}/plugins/wfx/samba/
+.endif
+
+.if ${PORT_OPTIONS:MWLX_MPLAYER}
+ @${MKDIR} ${DATADIR}/plugins/wlx/wlxmplayer/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/wlx/WlxMplayer/lib/wlxmplayer.wlx ${DATADIR}/plugins/wlx/wlxmplayer/
+.endif
+
+.if ${PORT_OPTIONS:MDSX_LOCATE}
+ @${MKDIR} ${DATADIR}/plugins/dsx/dsxlocate/
+ ${INSTALL_LIB} ${WRKSRC}/plugins/dsx/DSXLocate/lib/dsxlocate.dsx ${DATADIR}/plugins/dsx/dsxlocate/
+.endif
+
.for DIRE in language pixmaps sdk
@${MKDIR} ${DATADIR}/${DIRE}
@cd ${WRKSRC}/${DIRE} && \
@@ -124,7 +376,7 @@ do-install:
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/${DIRE}/{}" \;
.endfor
-.for FILE in doublecmd.ext.example pixmaps.txt multiarc.ini
+.for FILE in doublecmd.ext.example pixmaps.txt multiarc.ini install/linux/doublecmd.xml
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DATADIR}
.endfor
diff --git a/x11-fm/doublecmd/distinfo b/x11-fm/doublecmd/distinfo
index f1cb530e0686..44a20e30a6ac 100644
--- a/x11-fm/doublecmd/distinfo
+++ b/x11-fm/doublecmd/distinfo
@@ -1,4 +1,4 @@
-SHA256 (doublecmd-0.5.5-src.tar.gz) = 253ec036ec119c067f501247445acdd35d67ffd9693d246dc4e98897c6df6434
-SIZE (doublecmd-0.5.5-src.tar.gz) = 4401472
+SHA256 (doublecmd-0.5.7-src.tar.gz) = 8e2059f986fff26da5d7b98af95be64b12c5cef6b50fe3cacd9a2805947aa343
+SIZE (doublecmd-0.5.7-src.tar.gz) = 4456886
SHA256 (doublecmd-help-0.5.5-src.tar.gz) = 5c5d00187df811df0734bf751a581bce7e1bdd4cf4639b2a1101f1da8743daaf
SIZE (doublecmd-help-0.5.5-src.tar.gz) = 10762769
diff --git a/x11-fm/doublecmd/files/patch-components__doublecmd__dcosutils.pas b/x11-fm/doublecmd/files/patch-components__doublecmd__dcosutils.pas
deleted file mode 100644
index b09429f541ac..000000000000
--- a/x11-fm/doublecmd/files/patch-components__doublecmd__dcosutils.pas
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./components/doublecmd/dcosutils.pas.orig 2013-06-30 21:33:09.530448529 +0200
-+++ ./components/doublecmd/dcosutils.pas 2013-06-30 21:33:24.841789000 +0200
-@@ -184,11 +184,11 @@
- Windows, JwaWinNetWk;
- {$ENDIF}
- {$IF DEFINED(UNIX)}
-- {$IF DEFINED(DARWIN)}
-+ {$IF DEFINED(BSD)}
- {$DEFINE FPC_USE_LIBC}
- {$ENDIF}
- uses
-- {$IF NOT DEFINED(FPC_USE_LIBC)}
-+ {$IF (NOT DEFINED(FPC_USE_LIBC)) OR (DEFINED(BSD) AND NOT DEFINED(DARWIN))}
- SysCall,
- {$ENDIF}
- BaseUnix, Unix, dl, DCStrUtils;
diff --git a/x11-fm/doublecmd/files/patch-plugins__wlx__WlxMplayer__src__wlxMplayer.lpr b/x11-fm/doublecmd/files/patch-plugins__wlx__WlxMplayer__src__wlxMplayer.lpr
new file mode 100644
index 000000000000..04df69bc5103
--- /dev/null
+++ b/x11-fm/doublecmd/files/patch-plugins__wlx__WlxMplayer__src__wlxMplayer.lpr
@@ -0,0 +1,11 @@
+--- ./plugins/wlx/WlxMplayer/src/wlxMplayer.lpr.orig 2013-03-10 11:26:35.000000000 +0100
++++ ./plugins/wlx/WlxMplayer/src/wlxMplayer.lpr 2013-07-22 22:43:52.577214000 +0200
+@@ -258,7 +258,7 @@
+ sPlayerPath: String;
+ p: TMPlayer;
+ begin
+- pf:= TExProcess.Create('which mplayer');
++ pf:= TExProcess.Create('%%LOCALBASE%%/bin/mplayer');
+ try
+ pf.Execute;
+ if (pf.RezList.Count <> 0) then
diff --git a/x11-fm/doublecmd/files/patch-src__ucmdlineparams.pas b/x11-fm/doublecmd/files/patch-src__ucmdlineparams.pas
deleted file mode 100644
index 55731cea0534..000000000000
--- a/x11-fm/doublecmd/files/patch-src__ucmdlineparams.pas
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./src/ucmdlineparams.pas.orig 2013-06-08 17:54:12.000000000 +0200
-+++ ./src/ucmdlineparams.pas 2013-06-30 21:42:23.609940000 +0200
-@@ -20,10 +20,7 @@
- implementation
-
- uses
-- {$IF DEFINED(NIGHTLY_BUILD)}
-- uOSUtils,
-- {$ENDIF}
-- Forms, Dialogs, SysUtils, uDCUtils, uGlobsPaths, getopts, uDebug, uLng;
-+ uOSUtils, Forms, Dialogs, SysUtils, uDCUtils, uGlobsPaths, getopts, uDebug, uLng;
-
- procedure ProcessCommandLineParams;
- var
diff --git a/x11-fm/doublecmd/files/pkg-message.in b/x11-fm/doublecmd/files/pkg-message.in
index 73f1b1d7d9b6..ca27867b4b10 100644
--- a/x11-fm/doublecmd/files/pkg-message.in
+++ b/x11-fm/doublecmd/files/pkg-message.in
@@ -8,10 +8,6 @@ Double Commander was installed
# doublecmd
-3) Plugins are currently not available for FreeBSD. For more information see:
- http://doublecmd.sourceforge.net/mediawiki/index.php/Issues_with_FPC,_Lazarus
- in "Loading shared libraries on FreeBSD doesn't work" section
-
-4) Enjoy it ;)
+3) Enjoy it ;)
###############################################################################