aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-07-17 17:32:15 +0000
committerSteve Wills <swills@FreeBSD.org>2019-07-17 17:32:15 +0000
commitbf63c899b6d5c676716ee191386bee715ea002b6 (patch)
treee28b47f3abcd4ce7512f8e64ddd1efde7d324733 /x11-fm
parent0820bff51b490de653f8197ea5386265c92266e6 (diff)
downloadports-bf63c899b6d5c676716ee191386bee715ea002b6.tar.gz
ports-bf63c899b6d5c676716ee191386bee715ea002b6.zip
x11-fm/nautilus-python: create port
Nautilus-python is a set of python bindings for the Nautilus Extension Framework. With these bindings, you can write extensions for the Nautilus File Manager in python. WWW: https://wiki.gnome.org/Projects/NautilusPython PR: 234548 Submitted by: Daniel Shafer <daniel@shafer.cc> Reviewed by: mat
Notes
Notes: svn path=/head/; revision=506809
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/nautilus-python/Makefile30
-rw-r--r--x11-fm/nautilus-python/distinfo3
-rw-r--r--x11-fm/nautilus-python/pkg-descr5
-rw-r--r--x11-fm/nautilus-python/pkg-plist30
5 files changed, 69 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index 0e6a36be7902..47adb0e6cf73 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -20,6 +20,7 @@
SUBDIR += libtubo
SUBDIR += mucommander
SUBDIR += nautilus
+ SUBDIR += nautilus-python
SUBDIR += nemo
SUBDIR += pcmanfm
SUBDIR += pcmanfm-qt
diff --git a/x11-fm/nautilus-python/Makefile b/x11-fm/nautilus-python/Makefile
new file mode 100644
index 000000000000..a9aeb91079da
--- /dev/null
+++ b/x11-fm/nautilus-python/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= nautilus-python
+DISTVERSION= 1.2.2
+CATEGORIES= x11-fm gnome python
+MASTER_SITES= GNOME
+
+MAINTAINER= daniel@shafer.cc
+COMMENT= Python nautilus bindings
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake gnome libtool localbase pathfix pkgconfig python:3.6+ \
+ tar:xz
+USE_GNOME= cairo gdkpixbuf2 nautilus3 pygobject3
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= GTKDOC
+OPTIONS_SUB= yes
+
+GTKDOC_MESON_TRUE= gtk_doc
+GTKDOC_DESC= Build documentation
+GTKDOC_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+GTKDOC_CONFIGURE_ENABLE= gtk-doc
+
+.include <bsd.port.mk>
diff --git a/x11-fm/nautilus-python/distinfo b/x11-fm/nautilus-python/distinfo
new file mode 100644
index 000000000000..3faafcfd281d
--- /dev/null
+++ b/x11-fm/nautilus-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544101815
+SHA256 (nautilus-python-1.2.2.tar.xz) = 90cda3fd613ed012214e47c2dc6f814db4e204a5af38e840479819ab9c59f112
+SIZE (nautilus-python-1.2.2.tar.xz) = 269220
diff --git a/x11-fm/nautilus-python/pkg-descr b/x11-fm/nautilus-python/pkg-descr
new file mode 100644
index 000000000000..9d322266f0dc
--- /dev/null
+++ b/x11-fm/nautilus-python/pkg-descr
@@ -0,0 +1,5 @@
+Nautilus-python is a set of python bindings for the Nautilus Extension
+Framework. With these bindings, you can write extensions for the Nautilus File
+Manager in python.
+
+WWW: https://wiki.gnome.org/Projects/NautilusPython
diff --git a/x11-fm/nautilus-python/pkg-plist b/x11-fm/nautilus-python/pkg-plist
new file mode 100644
index 000000000000..bfb523dee684
--- /dev/null
+++ b/x11-fm/nautilus-python/pkg-plist
@@ -0,0 +1,30 @@
+lib/nautilus/extensions-3.0/libnautilus-python.so
+libdata/pkgconfig/nautilus-python.pc
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-column-provider.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-column.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-file-info.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-info-provider.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-location-widget-provider.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-menu-item.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-menu-provider.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-menu.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-property-page-provider.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/class-nautilus-python-property-page.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/enum-nautilus-python-operation-result.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/home.png
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/index.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/index.sgml
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/left-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/left.png
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python-class-reference.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python-enum-reference.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python-overview-example.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python-overview-methods.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python-overview.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python-provider-reference.html
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/nautilus-python.devhelp2
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/right-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/right.png
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/style.css
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/up-insensitive.png
+%%GTKDOC%%share/gtk-doc/html/nautilus-python/up.png