aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-01-25 11:05:25 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-01-25 11:05:25 +0000
commited63f66eb66bb0b445fe6e0fed90ff9ea5e7b99b (patch)
treed033d72d9d3aa5af05ac6527704ee4eb9c7d777e /x11-fm
parent4b65027977b6b7827df6cfcb873c8c1d395fe75e (diff)
downloadports-ed63f66eb66bb0b445fe6e0fed90ff9ea5e7b99b.tar.gz
ports-ed63f66eb66bb0b445fe6e0fed90ff9ea5e7b99b.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/thunar/Makefile71
-rw-r--r--x11-fm/thunar/pkg-plist26
2 files changed, 75 insertions, 22 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index db840f56cb21..66098fb8fc4e 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Thunar
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= x11-fm xfce
MASTER_SITES= ${MASTER_SITES_XFCE}
DIST_SUBDIR= xfce4
@@ -26,20 +27,25 @@ USE_LDCONFIG= yes
USE_XFCE= configenv libexo libutil
USE_XLIB= yes
-OPTIONS= DBUS "Enable D-BUS support" on \
- JPEG "Enable JPEG support" on \
- FAM "Enable FAM support" off \
- GCONF "Enable GCONF support" off \
- EXIF "Enable EXIF support" off \
- PCRE "Enable PCRE support" off \
- STARTUP "Enable startup notification support" on
+OPTIONS= DBUS "Enable D-BUS support" on \
+ JPEG "Enable JPEG support" on \
+ FAM "Enable FAM support" off \
+ HAL "Enable HAL support" off \
+ GCONF "Enable GCONF support" off \
+ STARTUP "Enable startup notification support" on \
+ PLUG_APR "Thunar Advanced Properties plugin" off \
+ PLUG_APR_EXIF "Exif support for the APR plugin" off \
+ PLUG_SBR "Thunar Simple Builtin Renamers plugin" off \
+ PLUG_SBR_PCRE "Regular expression support for the SBR plugin" off \
+ PLUG_TPA "Thunar Trash Panel Applet plugin" off \
+ PLUG_UCA "Thunar User Customizable Actions plugin" off
+
MAN1= Thunar.1
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
-.if !defined(WITHOUT_DBUS)
+.if defined(WITH_DBUS)
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= WITH_DBUS=""
@@ -48,13 +54,17 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= WITH_DBUS="@comment "
.endif
-.if !defined(WITHOUT_JPEG)
+.if defined(WITH_JPEG)
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--enable-jpeg
.else
CONFIGURE_ARGS+=--disable-jpeg
.endif
+.if defined(WITH_HAL)
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.endif
+
.if defined(WITH_FAM)
USE_FAM= yes
WANT_FAM_SYSTEM=gamin
@@ -67,19 +77,50 @@ CONFIGURE_ARGS+=--enable-gconf
CONFIGURE_ARGS+=--disable-gconf
.endif
-.if defined(WITH_EXIF)
+.if defined(WITH_PLUG_APR)
+CONFIGURE_ARGS+=--enable-apr-plugin
+PLIST_SUB+= PLUGIN_APR=""
+.if defined(WITH_PLUG_APR_EXIF)
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
CONFIGURE_ARGS+=--enable-exif
.else
CONFIGURE_ARGS+=--disable-exif
.endif
+.else
+CONFIGURE_ARGS+=--disable-apr-plugin --disable-exif
+PLIST_SUB+= PLUGIN_APR="@comment "
+.endif
-.if !defined(WITHOUT_PCRE)
+.if defined(WITH_PLUG_SBR)
+CONFIGURE_ARGS+=--enable-sbr-plugin
+PLIST_SUB+= PLUGIN_SBR=""
+.if defined(WITH_PLUG_SBR_PCRE)
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+=--enable-pcre
.else
CONFIGURE_ARGS+=--disable-pcre
.endif
+.else
+CONFIGURE_ARGS+=--disable-sbr-plugin --disable-pcre
+PLIST_SUB+= PLUGIN_SBR="@comment "
+.endif
+
+.if defined(WITH_PLUG_TPA)
+CONFIGURE_ARGS+=--enable-tpa-plugin
+PLIST_SUB+= PLUGIN_TPA=""
+USE_XFCE+= panel
+.else
+CONFIGURE_ARGS+=--disable-tpa-plugin
+PLIST_SUB+= PLUGIN_TPA="@comment "
+.endif
+
+.if defined(WITH_PLUG_UCA)
+CONFIGURE_ARGS+=--enable-uca-plugin
+PLIST_SUB+= PLUGIN_UCA=""
+.else
+CONFIGURE_ARGS+=--disable-uca-plugin
+PLIST_SUB+= PLUGIN_UCA="@comment "
+.endif
.if !defined(WITHOUT_STARTUP)
LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
@@ -94,7 +135,13 @@ post-patch:
.if !defined(WITH_FAM)
@${REINPLACE_CMD} -e 's|gamin|no-gamin|g' ${WRKSRC}/configure
.endif
+.if !defined(WITH_HAL)
+ @${REINPLACE_CMD} -e 's|hal-storage|no-hal-storage|g' ${WRKSRC}/configure
+.endif
+ @${REINPLACE_CMD} -e 's|enable_val|enableval|g' ${WRKSRC}/configure
post-install:
@-update-desktop-database
+
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/x11-fm/thunar/pkg-plist b/x11-fm/thunar/pkg-plist
index 6125f4c1133d..7a9df8ec6bec 100644
--- a/x11-fm/thunar/pkg-plist
+++ b/x11-fm/thunar/pkg-plist
@@ -1,6 +1,6 @@
bin/Thunar
bin/thunar
-etc/xdg/Thunar/uca.xml
+%%PLUGIN_UCA%%etc/xdg/Thunar/uca.xml
include/thunar-vfs-1/thunar-vfs/thunar-vfs-config.h
include/thunar-vfs-1/thunar-vfs/thunar-vfs-enum-types.h
include/thunar-vfs-1/thunar-vfs/thunar-vfs-info.h
@@ -36,12 +36,12 @@ lib/libthunar-vfs-1.so.4
lib/libthunarx-1.la
lib/libthunarx-1.so
lib/libthunarx-1.so.4
-lib/thunarx-1/thunar-apr.la
-lib/thunarx-1/thunar-apr.so
-lib/thunarx-1/thunar-sbr.la
-lib/thunarx-1/thunar-sbr.so
-lib/thunarx-1/thunar-uca.la
-lib/thunarx-1/thunar-uca.so
+%%PLUGIN_APR%%lib/thunarx-1/thunar-apr.la
+%%PLUGIN_APR%%lib/thunarx-1/thunar-apr.so
+%%PLUGIN_SBR%%lib/thunarx-1/thunar-sbr.la
+%%PLUGIN_SBR%%lib/thunarx-1/thunar-sbr.so
+%%PLUGIN_UCA%%lib/thunarx-1/thunar-uca.la
+%%PLUGIN_UCA%%lib/thunarx-1/thunar-uca.so
libdata/pkgconfig/thunar-vfs-1.pc
libdata/pkgconfig/thunarx-1.pc
libexec/ThunarBulkRename
@@ -51,12 +51,14 @@ libexec/thunar-vfs-font-thumbnailer-1
libexec/thunar-vfs-mime-cleaner-1
libexec/thunar-vfs-pixbuf-thumbnailer-1
libexec/thunar-vfs-update-thumbnailers-cache-1
+%%PLUGIN_TPA%%libexec/xfce4/panel-plugins/thunar-tpa
share/Thunar/sendto/thunar-sendto-email.desktop
share/applications/Thunar-bulk-rename.desktop
share/applications/Thunar-folder-handler.desktop
share/applications/Thunar.desktop
%%WITH_DBUS%%share/dbus-1/services/org.xfce.FileManager.service
%%WITH_DBUS%%share/dbus-1/services/org.xfce.Thunar.service
+%%PLUGIN_TPA%%share/xfce4/panel-plugins/thunar-tpa.desktop
%%DOCSDIR%%/README.gtkrc
%%DOCSDIR%%/README.thunarrc
%%DOCSDIR%%/README.volumes
@@ -269,14 +271,18 @@ share/locale/zh_TW/LC_MESSAGES/Thunar.mo
share/pixmaps/Thunar/Thunar-about-logo.png
share/pixmaps/Thunar/Thunar-fallback-icon.png
share/thumbnailers/thunar-vfs-font-thumbnailer-1.desktop
-@dirrm etc/xdg/Thunar
-@dirrmtry etc/xdg
+%%PLUGIN_UCA%%@dirrm etc/xdg/Thunar
+%%PLUGIN_UCA%%@dirrmtry etc/xdg
@dirrm include/thunar-vfs-1/thunar-vfs
@dirrm include/thunar-vfs-1
@dirrm include/thunarx-1/thunarx
@dirrm include/thunarx-1
-@dirrm lib/thunarx-1
+@dirrmtry lib/thunarx-1
+%%PLUGIN_TPA%%@dirrmtry libexec/xfce4/panel-plugins
+%%PLUGIN_TPA%%@dirrmtry libexec/xfce4
@dirrmtry share/applications
+%%PLUGIN_TPA%%@dirrmtry share/xfce4/panel-plugins
+%%PLUGIN_TPA%%@dirrmtry share/xfce4
@dirrmtry %%DOCSDIR%%/html/C/images
@dirrm %%DOCSDIR%%/html/C
@dirrmtry %%DOCSDIR%%/html/es/images