aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-27 19:29:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-27 19:29:08 +0000
commit70d4758f720bbd7239a078186122b260c13e52c2 (patch)
tree18354407527234df51ef393783556d10f65fe044 /x11-fm
parent0142e71d559238af1d8c08535db48b970b77997d (diff)
downloadports-70d4758f720bbd7239a078186122b260c13e52c2.tar.gz
ports-70d4758f720bbd7239a078186122b260c13e52c2.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/wcmcommander/Makefile1
-rw-r--r--x11-fm/wcmcommander/files/patch-src_swl_swl_wincoreUX.cpp48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-fm/wcmcommander/Makefile b/x11-fm/wcmcommander/Makefile
index 6bb158bbd78d..7a621d071f63 100644
--- a/x11-fm/wcmcommander/Makefile
+++ b/x11-fm/wcmcommander/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wcmcommander
PORTVERSION= 0.20.0
+PORTREVISION= 1
DISTVERSIONPREFIX= release-
CATEGORIES= x11-fm
diff --git a/x11-fm/wcmcommander/files/patch-src_swl_swl_wincoreUX.cpp b/x11-fm/wcmcommander/files/patch-src_swl_swl_wincoreUX.cpp
new file mode 100644
index 000000000000..9031f5e70249
--- /dev/null
+++ b/x11-fm/wcmcommander/files/patch-src_swl_swl_wincoreUX.cpp
@@ -0,0 +1,48 @@
+commit 2fd0f94b4ea96bf3f67d53ebda4f40bc82711bb9
+Author: Oleg Panashchenko <helg.git@helg.com>
+Date: Thu Apr 30 13:53:04 2015 -0400
+
+ Fixed #486
+
+ was a regression from 02bed4d
+
+diff --git src/swl/swl_wincoreUX.cpp src/swl/swl_wincoreUX.cpp
+index a161e24..7926b6a 100644
+--- src/swl/swl_wincoreUX.cpp
++++ src/swl/swl_wincoreUX.cpp
+@@ -1166,22 +1166,22 @@ static const char* getEventName(int id)
+ {
+ // close all popups
+ Win* w = GetWinByID( activeWinId );
+- //dbg_printf("FocusOut %s\n", typeid(*w).name());
+- while(w->parent)
+- w=w->parent;
+- ccollect<WinID> wl;
+- w->PopupTreeList( wl );
+- //dbg_printf("PopupTreeList size=%d\n",wl.count());
+- for(int i=0;i<wl.count();i++)
++ if( w )
+ {
+- Win* popup = GetWinByID( wl[i] );
+- if(popup)
++ while(w->parent)
++ w=w->parent;
++ ccollect<WinID> wl;
++ w->PopupTreeList( wl );
++ for(int i=0;i<wl.count();i++)
+ {
+- //dbg_printf("Closing %s\n", typeid(*w).name());
+- if(popup->parent)
+- popup->Parent()->Command( CMD_MENU_INFO, SCMD_MENU_CANCEL, popup, 0 );
++ Win* popup = GetWinByID( wl[i] );
++ if(popup)
++ {
++ if(popup->parent)
++ popup->Parent()->Command( CMD_MENU_INFO, SCMD_MENU_CANCEL, popup, 0 );
++ }
++
+ }
+-
+ }
+ }
+