aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-01-22 16:52:06 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-01-22 16:52:06 +0000
commite2cdbdd26c44e0e399b2308725dd51c14547f6c1 (patch)
tree3ea9342d85a3d6530aed3c67616652bd93bac941 /x11-fm
parent996536fb055dbe4e3b7d837908f1ebd582f9ebe1 (diff)
downloadports-e2cdbdd26c44e0e399b2308725dd51c14547f6c1.tar.gz
ports-e2cdbdd26c44e0e399b2308725dd51c14547f6c1.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/thunar/Makefile100
-rw-r--r--x11-fm/thunar/distinfo3
-rw-r--r--x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb-jpeg.c25
-rw-r--r--x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb.c20
-rw-r--r--x11-fm/thunar/pkg-descr3
-rw-r--r--x11-fm/thunar/pkg-plist315
7 files changed, 467 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index 9442142c39bd..5bce16c7a15f 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -29,6 +29,7 @@
SUBDIR += rox-mime-editor
SUBDIR += rox-session
SUBDIR += tdfsb
+ SUBDIR += thunar
SUBDIR += tkdesk
SUBDIR += twander
SUBDIR += velocity
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
new file mode 100644
index 000000000000..db840f56cb21
--- /dev/null
+++ b/x11-fm/thunar/Makefile
@@ -0,0 +1,100 @@
+# New ports collection makefile for: thunar
+# Date created: 19.04.2006
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Thunar
+PORTVERSION= 0.8.0
+CATEGORIES= x11-fm xfce
+MASTER_SITES= ${MASTER_SITES_XFCE}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= XFce 4 file manager
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= desktopfileutils glib20 gnomehack gtk20 intltool intlhack pkgconfig
+USE_LDCONFIG= yes
+USE_XFCE= configenv libexo libutil
+USE_XLIB= yes
+
+OPTIONS= DBUS "Enable D-BUS support" on \
+ JPEG "Enable JPEG support" on \
+ FAM "Enable FAM support" off \
+ GCONF "Enable GCONF support" off \
+ EXIF "Enable EXIF support" off \
+ PCRE "Enable PCRE support" off \
+ STARTUP "Enable startup notification support" on
+
+MAN1= Thunar.1
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
+
+.if !defined(WITHOUT_DBUS)
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+CONFIGURE_ARGS+=--enable-dbus
+PLIST_SUB+= WITH_DBUS=""
+.else
+CONFIGURE_ARGS+=--disable-dbus
+PLIST_SUB+= WITH_DBUS="@comment "
+.endif
+
+.if !defined(WITHOUT_JPEG)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+CONFIGURE_ARGS+=--enable-jpeg
+.else
+CONFIGURE_ARGS+=--disable-jpeg
+.endif
+
+.if defined(WITH_FAM)
+USE_FAM= yes
+WANT_FAM_SYSTEM=gamin
+.endif
+
+.if defined(WITH_GCONF)
+USE_GNOME+= gconf2
+CONFIGURE_ARGS+=--enable-gconf
+.else
+CONFIGURE_ARGS+=--disable-gconf
+.endif
+
+.if defined(WITH_EXIF)
+LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
+CONFIGURE_ARGS+=--enable-exif
+.else
+CONFIGURE_ARGS+=--disable-exif
+.endif
+
+.if !defined(WITHOUT_PCRE)
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--enable-pcre
+.else
+CONFIGURE_ARGS+=--disable-pcre
+.endif
+
+.if !defined(WITHOUT_STARTUP)
+LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+CONFIGURE_ARGS+=--enable-startup-notification
+.else
+CONFIGURE_ARGS+=--disable-startup-notification
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|docdir = .*|docdir = ${DOCSDIR}|' \
+ ${WRKSRC}/docs/Makefile.in
+.if !defined(WITH_FAM)
+ @${REINPLACE_CMD} -e 's|gamin|no-gamin|g' ${WRKSRC}/configure
+.endif
+
+post-install:
+ @-update-desktop-database
+.include <bsd.port.post.mk>
diff --git a/x11-fm/thunar/distinfo b/x11-fm/thunar/distinfo
new file mode 100644
index 000000000000..a0be29d53044
--- /dev/null
+++ b/x11-fm/thunar/distinfo
@@ -0,0 +1,3 @@
+MD5 (xfce4/Thunar-0.8.0.tar.bz2) = 9f7b0945d6a235391049f6818fb4d188
+SHA256 (xfce4/Thunar-0.8.0.tar.bz2) = 460484f8397a0e0e4115d1629d2ae027b5052dc2c564d4a4629a3557e4a055f9
+SIZE (xfce4/Thunar-0.8.0.tar.bz2) = 6205993
diff --git a/x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb-jpeg.c b/x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb-jpeg.c
new file mode 100644
index 000000000000..b439f323c740
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb-jpeg.c
@@ -0,0 +1,25 @@
+--- thunar-vfs/thunar-vfs-thumb-jpeg.c.orig Mon Jan 22 09:54:27 2007
++++ thunar-vfs/thunar-vfs-thumb-jpeg.c Mon Jan 22 12:59:03 2007
+@@ -306,22 +306,13 @@
+ guint data_len;
+
+ guint thumb_compression;
+- union
+- {
+- struct /* thumbnail JPEG */
+- {
+ guint thumb_jpeg_length;
+ guint thumb_jpeg_offset;
+- };
+- struct /* thumbnail TIFF */
+- {
+ guint thumb_tiff_length;
+ guint thumb_tiff_offset;
+ guint thumb_tiff_interp;
+ guint thumb_tiff_height;
+ guint thumb_tiff_width;
+- };
+- };
+
+ gboolean big_endian;
+ } TvtjExif;
diff --git a/x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb.c b/x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb.c
new file mode 100644
index 000000000000..3113e0aa1daf
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar-vfs-thunar-vfs-thumb.c
@@ -0,0 +1,20 @@
+--- thunar-vfs/thunar-vfs-thumb.c.orig Thu Sep 7 15:22:21 2006
++++ thunar-vfs/thunar-vfs-thumb.c Thu Sep 7 15:22:32 2006
+@@ -28,14 +28,14 @@
+ #ifdef HAVE_SYS_MMAN_H
+ #include <sys/mman.h>
+ #endif
++#ifdef HAVE_SYS_TIME_H
++#include <sys/time.h>
++#endif
+ #ifdef HAVE_SYS_RESOURCE_H
+ #include <sys/resource.h>
+ #endif
+ #ifdef HAVE_SYS_STAT_H
+ #include <sys/stat.h>
+-#endif
+-#ifdef HAVE_SYS_TIME_H
+-#include <sys/time.h>
+ #endif
+ #ifdef HAVE_SYS_WAIT_H
+ #include <sys/wait.h>
diff --git a/x11-fm/thunar/pkg-descr b/x11-fm/thunar/pkg-descr
new file mode 100644
index 000000000000..96ff5f922bd8
--- /dev/null
+++ b/x11-fm/thunar/pkg-descr
@@ -0,0 +1,3 @@
+XFce 4 file manager. Features samba network share support.
+
+WWW: http://www.xfce.org/
diff --git a/x11-fm/thunar/pkg-plist b/x11-fm/thunar/pkg-plist
new file mode 100644
index 000000000000..6125f4c1133d
--- /dev/null
+++ b/x11-fm/thunar/pkg-plist
@@ -0,0 +1,315 @@
+bin/Thunar
+bin/thunar
+etc/xdg/Thunar/uca.xml
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-config.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-enum-types.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-info.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-interactive-job.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-job.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-mime-action.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-mime-application.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-mime-database.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-mime-handler.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-mime-info.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-monitor.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-path.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-thumb.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-types.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-user.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-util.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs-volume.h
+include/thunar-vfs-1/thunar-vfs/thunar-vfs.h
+include/thunarx-1/thunarx/thunarx-config.h
+include/thunarx-1/thunarx/thunarx-file-info.h
+include/thunarx-1/thunarx/thunarx-menu-provider.h
+include/thunarx-1/thunarx/thunarx-preferences-provider.h
+include/thunarx-1/thunarx/thunarx-property-page-provider.h
+include/thunarx-1/thunarx/thunarx-property-page.h
+include/thunarx-1/thunarx/thunarx-provider-factory.h
+include/thunarx-1/thunarx/thunarx-provider-plugin.h
+include/thunarx-1/thunarx/thunarx-renamer-provider.h
+include/thunarx-1/thunarx/thunarx-renamer.h
+include/thunarx-1/thunarx/thunarx.h
+lib/libthunar-vfs-1.la
+lib/libthunar-vfs-1.so
+lib/libthunar-vfs-1.so.4
+lib/libthunarx-1.la
+lib/libthunarx-1.so
+lib/libthunarx-1.so.4
+lib/thunarx-1/thunar-apr.la
+lib/thunarx-1/thunar-apr.so
+lib/thunarx-1/thunar-sbr.la
+lib/thunarx-1/thunar-sbr.so
+lib/thunarx-1/thunar-uca.la
+lib/thunarx-1/thunar-uca.so
+libdata/pkgconfig/thunar-vfs-1.pc
+libdata/pkgconfig/thunarx-1.pc
+libexec/ThunarBulkRename
+libexec/ThunarHelp
+libexec/thunar-sendto-email
+libexec/thunar-vfs-font-thumbnailer-1
+libexec/thunar-vfs-mime-cleaner-1
+libexec/thunar-vfs-pixbuf-thumbnailer-1
+libexec/thunar-vfs-update-thumbnailers-cache-1
+share/Thunar/sendto/thunar-sendto-email.desktop
+share/applications/Thunar-bulk-rename.desktop
+share/applications/Thunar-folder-handler.desktop
+share/applications/Thunar.desktop
+%%WITH_DBUS%%share/dbus-1/services/org.xfce.FileManager.service
+%%WITH_DBUS%%share/dbus-1/services/org.xfce.Thunar.service
+%%DOCSDIR%%/README.gtkrc
+%%DOCSDIR%%/README.thunarrc
+%%DOCSDIR%%/README.volumes
+%%DOCSDIR%%/ThumbnailersCacheFormat.txt
+%%DOCSDIR%%/html/C/advanced-topics.html
+%%DOCSDIR%%/html/C/copyright.html
+%%DOCSDIR%%/html/C/customizing-thunar.html
+%%DOCSDIR%%/html/C/faq.html
+%%DOCSDIR%%/html/C/images/bulk-rename.png
+%%DOCSDIR%%/html/C/images/file-manager-window.png
+%%DOCSDIR%%/html/C/images/file-properties.png
+%%DOCSDIR%%/html/C/images/preferences-advanced.png
+%%DOCSDIR%%/html/C/images/preferences-behavior.png
+%%DOCSDIR%%/html/C/images/preferences-side-pane.png
+%%DOCSDIR%%/html/C/images/preferences-views.png
+%%DOCSDIR%%/html/C/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/C/images/removable-media-unmount.png
+%%DOCSDIR%%/html/C/images/sendto-menu.png
+%%DOCSDIR%%/html/C/images/visible-columns.png
+%%DOCSDIR%%/html/C/index.html
+%%DOCSDIR%%/html/C/preferences.html
+%%DOCSDIR%%/html/C/support.html
+%%DOCSDIR%%/html/C/the-file-manager-window.html
+%%DOCSDIR%%/html/C/using-removable-media.html
+%%DOCSDIR%%/html/C/working-with-files-and-folders.html
+%%DOCSDIR%%/html/es/advanced-topics.html
+%%DOCSDIR%%/html/es/copyright.html
+%%DOCSDIR%%/html/es/customizing-thunar.html
+%%DOCSDIR%%/html/es/faq.html
+%%DOCSDIR%%/html/es/images/bulk-rename.png
+%%DOCSDIR%%/html/es/images/file-manager-window.png
+%%DOCSDIR%%/html/es/images/file-properties.png
+%%DOCSDIR%%/html/es/images/preferences-advanced.png
+%%DOCSDIR%%/html/es/images/preferences-behavior.png
+%%DOCSDIR%%/html/es/images/preferences-side-pane.png
+%%DOCSDIR%%/html/es/images/preferences-views.png
+%%DOCSDIR%%/html/es/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/es/images/removable-media-unmount.png
+%%DOCSDIR%%/html/es/images/sendto-menu.png
+%%DOCSDIR%%/html/es/images/visible-columns.png
+%%DOCSDIR%%/html/es/index.html
+%%DOCSDIR%%/html/es/preferences.html
+%%DOCSDIR%%/html/es/support.html
+%%DOCSDIR%%/html/es/the-file-manager-window.html
+%%DOCSDIR%%/html/es/using-removable-media.html
+%%DOCSDIR%%/html/es/working-with-files-and-folders.html
+%%DOCSDIR%%/html/eu/advanced-topics.html
+%%DOCSDIR%%/html/eu/copyright.html
+%%DOCSDIR%%/html/eu/customizing-thunar.html
+%%DOCSDIR%%/html/eu/faq.html
+%%DOCSDIR%%/html/eu/images/bulk-rename.png
+%%DOCSDIR%%/html/eu/images/file-manager-window.png
+%%DOCSDIR%%/html/eu/images/file-properties.png
+%%DOCSDIR%%/html/eu/images/preferences-advanced.png
+%%DOCSDIR%%/html/eu/images/preferences-behavior.png
+%%DOCSDIR%%/html/eu/images/preferences-side-pane.png
+%%DOCSDIR%%/html/eu/images/preferences-views.png
+%%DOCSDIR%%/html/eu/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/eu/images/removable-media-unmount.png
+%%DOCSDIR%%/html/eu/images/sendto-menu.png
+%%DOCSDIR%%/html/eu/images/visible-columns.png
+%%DOCSDIR%%/html/eu/index.html
+%%DOCSDIR%%/html/eu/preferences.html
+%%DOCSDIR%%/html/eu/support.html
+%%DOCSDIR%%/html/eu/the-file-manager-window.html
+%%DOCSDIR%%/html/eu/using-removable-media.html
+%%DOCSDIR%%/html/eu/working-with-files-and-folders.html
+%%DOCSDIR%%/html/fr/advanced-topics.html
+%%DOCSDIR%%/html/fr/copyright.html
+%%DOCSDIR%%/html/fr/customizing-thunar.html
+%%DOCSDIR%%/html/fr/faq.html
+%%DOCSDIR%%/html/fr/images/bulk-rename.png
+%%DOCSDIR%%/html/fr/images/file-manager-window.png
+%%DOCSDIR%%/html/fr/images/file-properties.png
+%%DOCSDIR%%/html/fr/images/preferences-advanced.png
+%%DOCSDIR%%/html/fr/images/preferences-behavior.png
+%%DOCSDIR%%/html/fr/images/preferences-side-pane.png
+%%DOCSDIR%%/html/fr/images/preferences-views.png
+%%DOCSDIR%%/html/fr/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/fr/images/removable-media-unmount.png
+%%DOCSDIR%%/html/fr/images/sendto-menu.png
+%%DOCSDIR%%/html/fr/images/visible-columns.png
+%%DOCSDIR%%/html/fr/index.html
+%%DOCSDIR%%/html/fr/preferences.html
+%%DOCSDIR%%/html/fr/support.html
+%%DOCSDIR%%/html/fr/the-file-manager-window.html
+%%DOCSDIR%%/html/fr/using-removable-media.html
+%%DOCSDIR%%/html/fr/working-with-files-and-folders.html
+%%DOCSDIR%%/html/ja/advanced-topics.html
+%%DOCSDIR%%/html/ja/copyright.html
+%%DOCSDIR%%/html/ja/customizing-thunar.html
+%%DOCSDIR%%/html/ja/faq.html
+%%DOCSDIR%%/html/ja/images/bulk-rename.png
+%%DOCSDIR%%/html/ja/images/file-manager-window.png
+%%DOCSDIR%%/html/ja/images/file-properties.png
+%%DOCSDIR%%/html/ja/images/preferences-advanced.png
+%%DOCSDIR%%/html/ja/images/preferences-behavior.png
+%%DOCSDIR%%/html/ja/images/preferences-side-pane.png
+%%DOCSDIR%%/html/ja/images/preferences-views.png
+%%DOCSDIR%%/html/ja/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/ja/images/removable-media-unmount.png
+%%DOCSDIR%%/html/ja/images/sendto-menu.png
+%%DOCSDIR%%/html/ja/images/visible-columns.png
+%%DOCSDIR%%/html/ja/index.html
+%%DOCSDIR%%/html/ja/preferences.html
+%%DOCSDIR%%/html/ja/support.html
+%%DOCSDIR%%/html/ja/the-file-manager-window.html
+%%DOCSDIR%%/html/ja/using-removable-media.html
+%%DOCSDIR%%/html/ja/working-with-files-and-folders.html
+%%DOCSDIR%%/html/pl/advanced-topics.html
+%%DOCSDIR%%/html/pl/copyright.html
+%%DOCSDIR%%/html/pl/customizing-thunar.html
+%%DOCSDIR%%/html/pl/faq.html
+%%DOCSDIR%%/html/pl/images/bulk-rename.png
+%%DOCSDIR%%/html/pl/images/file-manager-window.png
+%%DOCSDIR%%/html/pl/images/file-properties.png
+%%DOCSDIR%%/html/pl/images/preferences-advanced.png
+%%DOCSDIR%%/html/pl/images/preferences-behavior.png
+%%DOCSDIR%%/html/pl/images/preferences-side-pane.png
+%%DOCSDIR%%/html/pl/images/preferences-views.png
+%%DOCSDIR%%/html/pl/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/pl/images/removable-media-unmount.png
+%%DOCSDIR%%/html/pl/images/sendto-menu.png
+%%DOCSDIR%%/html/pl/images/visible-columns.png
+%%DOCSDIR%%/html/pl/index.html
+%%DOCSDIR%%/html/pl/preferences.html
+%%DOCSDIR%%/html/pl/support.html
+%%DOCSDIR%%/html/pl/the-file-manager-window.html
+%%DOCSDIR%%/html/pl/using-removable-media.html
+%%DOCSDIR%%/html/pl/working-with-files-and-folders.html
+%%DOCSDIR%%/html/ru/advanced-topics.html
+%%DOCSDIR%%/html/ru/copyright.html
+%%DOCSDIR%%/html/ru/customizing-thunar.html
+%%DOCSDIR%%/html/ru/faq.html
+%%DOCSDIR%%/html/ru/images/bulk-rename.png
+%%DOCSDIR%%/html/ru/images/file-manager-window.png
+%%DOCSDIR%%/html/ru/images/file-properties.png
+%%DOCSDIR%%/html/ru/images/preferences-advanced.png
+%%DOCSDIR%%/html/ru/images/preferences-behavior.png
+%%DOCSDIR%%/html/ru/images/preferences-side-pane.png
+%%DOCSDIR%%/html/ru/images/preferences-views.png
+%%DOCSDIR%%/html/ru/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/ru/images/removable-media-unmount.png
+%%DOCSDIR%%/html/ru/images/sendto-menu.png
+%%DOCSDIR%%/html/ru/images/visible-columns.png
+%%DOCSDIR%%/html/ru/index.html
+%%DOCSDIR%%/html/ru/preferences.html
+%%DOCSDIR%%/html/ru/support.html
+%%DOCSDIR%%/html/ru/the-file-manager-window.html
+%%DOCSDIR%%/html/ru/using-removable-media.html
+%%DOCSDIR%%/html/ru/working-with-files-and-folders.html
+%%DOCSDIR%%/html/thunar.css
+%%DOCSDIR%%/html/zh_TW/advanced-topics.html
+%%DOCSDIR%%/html/zh_TW/copyright.html
+%%DOCSDIR%%/html/zh_TW/customizing-thunar.html
+%%DOCSDIR%%/html/zh_TW/faq.html
+%%DOCSDIR%%/html/zh_TW/images/bulk-rename.png
+%%DOCSDIR%%/html/zh_TW/images/file-manager-window.png
+%%DOCSDIR%%/html/zh_TW/images/file-properties.png
+%%DOCSDIR%%/html/zh_TW/images/preferences-advanced.png
+%%DOCSDIR%%/html/zh_TW/images/preferences-behavior.png
+%%DOCSDIR%%/html/zh_TW/images/preferences-side-pane.png
+%%DOCSDIR%%/html/zh_TW/images/preferences-views.png
+%%DOCSDIR%%/html/zh_TW/images/removable-drives-and-media.png
+%%DOCSDIR%%/html/zh_TW/images/removable-media-unmount.png
+%%DOCSDIR%%/html/zh_TW/images/sendto-menu.png
+%%DOCSDIR%%/html/zh_TW/images/visible-columns.png
+%%DOCSDIR%%/html/zh_TW/index.html
+%%DOCSDIR%%/html/zh_TW/preferences.html
+%%DOCSDIR%%/html/zh_TW/support.html
+%%DOCSDIR%%/html/zh_TW/the-file-manager-window.html
+%%DOCSDIR%%/html/zh_TW/using-removable-media.html
+%%DOCSDIR%%/html/zh_TW/working-with-files-and-folders.html
+share/icons/hicolor/16x16/apps/Thunar.png
+share/icons/hicolor/16x16/stock/navigation/stock_thunar-shortcuts.png
+share/icons/hicolor/16x16/stock/navigation/stock_thunar-templates.png
+share/icons/hicolor/24x24/apps/Thunar.png
+share/icons/hicolor/48x48/apps/Thunar.png
+share/icons/hicolor/scalable/apps/Thunar.svg
+share/locale/be/LC_MESSAGES/Thunar.mo
+share/locale/ca/LC_MESSAGES/Thunar.mo
+share/locale/cs/LC_MESSAGES/Thunar.mo
+share/locale/de/LC_MESSAGES/Thunar.mo
+share/locale/dz/LC_MESSAGES/Thunar.mo
+share/locale/el/LC_MESSAGES/Thunar.mo
+share/locale/eo/LC_MESSAGES/Thunar.mo
+share/locale/es/LC_MESSAGES/Thunar.mo
+share/locale/et/LC_MESSAGES/Thunar.mo
+share/locale/eu/LC_MESSAGES/Thunar.mo
+share/locale/fi/LC_MESSAGES/Thunar.mo
+share/locale/fr/LC_MESSAGES/Thunar.mo
+share/locale/gl/LC_MESSAGES/Thunar.mo
+share/locale/he/LC_MESSAGES/Thunar.mo
+share/locale/hu/LC_MESSAGES/Thunar.mo
+share/locale/it/LC_MESSAGES/Thunar.mo
+share/locale/ja/LC_MESSAGES/Thunar.mo
+share/locale/ka/LC_MESSAGES/Thunar.mo
+share/locale/ko/LC_MESSAGES/Thunar.mo
+share/locale/lt/LC_MESSAGES/Thunar.mo
+share/locale/mk/LC_MESSAGES/Thunar.mo
+share/locale/nl/LC_MESSAGES/Thunar.mo
+share/locale/pl/LC_MESSAGES/Thunar.mo
+share/locale/pt_BR/LC_MESSAGES/Thunar.mo
+share/locale/ro/LC_MESSAGES/Thunar.mo
+share/locale/ru/LC_MESSAGES/Thunar.mo
+share/locale/sv/LC_MESSAGES/Thunar.mo
+share/locale/uk/LC_MESSAGES/Thunar.mo
+share/locale/zh_CN/LC_MESSAGES/Thunar.mo
+share/locale/zh_TW/LC_MESSAGES/Thunar.mo
+share/pixmaps/Thunar/Thunar-about-logo.png
+share/pixmaps/Thunar/Thunar-fallback-icon.png
+share/thumbnailers/thunar-vfs-font-thumbnailer-1.desktop
+@dirrm etc/xdg/Thunar
+@dirrmtry etc/xdg
+@dirrm include/thunar-vfs-1/thunar-vfs
+@dirrm include/thunar-vfs-1
+@dirrm include/thunarx-1/thunarx
+@dirrm include/thunarx-1
+@dirrm lib/thunarx-1
+@dirrmtry share/applications
+@dirrmtry %%DOCSDIR%%/html/C/images
+@dirrm %%DOCSDIR%%/html/C
+@dirrmtry %%DOCSDIR%%/html/es/images
+@dirrm %%DOCSDIR%%/html/es
+@dirrmtry %%DOCSDIR%%/html/eu/images
+@dirrm %%DOCSDIR%%/html/eu
+@dirrmtry %%DOCSDIR%%/html/fr/images
+@dirrm %%DOCSDIR%%/html/fr
+@dirrmtry %%DOCSDIR%%/html/ja/images
+@dirrm %%DOCSDIR%%/html/ja
+@dirrmtry %%DOCSDIR%%/html/pl/images
+@dirrm %%DOCSDIR%%/html/pl
+@dirrmtry %%DOCSDIR%%/html/ru/images
+@dirrm %%DOCSDIR%%/html/ru
+@dirrmtry %%DOCSDIR%%/html/zh_TW/images
+@dirrm %%DOCSDIR%%/html/zh_TW
+@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
+@dirrm share/Thunar/sendto
+@dirrm share/Thunar
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrm share/pixmaps/Thunar
+@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || true
+@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || true
+@dirrmtry share/icons/hicolor/16x16/stock/navigation
+@dirrmtry share/icons/hicolor/16x16/stock
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrm share/thumbnailers