aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/code2000
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-09 00:55:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-09 00:55:23 +0000
commita77680083d63b5124d2b0d05cc030735a73bc5db (patch)
treef0adca8a7bcf0811d924011610429daed89ada38 /x11-fonts/code2000
parent9188d5103458118751ccdb6f0f4d0f4ba44fa0f5 (diff)
downloadports-a77680083d63b5124d2b0d05cc030735a73bc5db.tar.gz
ports-a77680083d63b5124d2b0d05cc030735a73bc5db.zip
Add Code2000, a shareware Unicode reference font. It contains over 34000 glyphs!
You should pay $5 to the author if you find this useful. PR: ports/60056 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=95438
Diffstat (limited to 'x11-fonts/code2000')
-rw-r--r--x11-fonts/code2000/Makefile118
-rw-r--r--x11-fonts/code2000/distinfo1
-rw-r--r--x11-fonts/code2000/pkg-descr7
-rw-r--r--x11-fonts/code2000/pkg-message23
-rw-r--r--x11-fonts/code2000/pkg-plist8
5 files changed, 157 insertions, 0 deletions
diff --git a/x11-fonts/code2000/Makefile b/x11-fonts/code2000/Makefile
new file mode 100644
index 000000000000..50f47ada02a3
--- /dev/null
+++ b/x11-fonts/code2000/Makefile
@@ -0,0 +1,118 @@
+# New ports collection makefile for: Code2000
+# Date created: 6 Dec 2003
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= code2000
+PORTVERSION= 1.13
+CATEGORIES= x11-fonts
+MASTER_SITES= http://home.att.net/~jameskass/
+DISTFILES= ${PORTNAME:U}${EXTRACT_SUFX:U}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= thierry@pompo.net
+COMMENT= Shareware demo Unicode TrueType font
+
+BUILD_DEPENDS= ttmkfdir:${PORTSDIR}/x11-fonts/ttmkfdir
+
+NO_PACKAGE= Only unmodified original package can be distributed
+
+USE_X_PREFIX= yes
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 3
+RUN_DEPENDS= xfstt:${PORTSDIR}/x11-servers/Xfstt
+.endif
+
+PLIST_SUB= PKG_OLDXF86=${PKG_OLDXF86} \
+ PKG_NSALIAS=${PKG_NSALIAS} \
+ FONTNAME="${FONTNAME}" \
+ FONTSDIR="${FONTSDIR:S|${PREFIX}/||}" \
+ TTFONTSDIR="${TTFONTSDIR:S|${X11BASE}/||}"
+
+MSG_FILE= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.if ${XFREE86_VERSION} == 3
+OLDXF86= ""
+.else
+OLDXF86= "@comment "
+.endif
+
+#
+# Local variables
+#
+
+FONTNAME= ${PORTNAME}
+FONTSDIR?= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+TTFONTSDIR?= ${X11BASE}/lib/X11/fonts/TrueType
+
+TTMKFDIR_CMD?= ${X11BASE}/bin/ttmkfdir
+SORT?= sort
+
+#
+# Post-extract
+#
+
+post-extract: move-fonts rename-license
+
+move-fonts:
+ ${MKDIR} ${WRKSRC}
+ ${MV} ${WRKDIR}/CODE2000.TTF ${WRKSRC}/${FONTNAME}.ttf
+
+rename-license:
+ ${MV} ${WRKDIR}/CODE2000.HTM ${WRKSRC}/${FONTNAME}.html
+
+#
+# Post-patch
+#
+
+post-patch:
+ ${SED} 's|%%FONTSDIR%%|${FONTSDIR}|g' ${MSG_FILE} > ${PKGMESSAGE}
+
+#
+# Build
+#
+
+do-build: make-fonts.scale make-fonts.dir
+
+make-fonts.scale:
+ ${TTMKFDIR_CMD} -c -f JJK -d ${WRKSRC} | ${CAT} -n | ${SED} -e ' \
+ s,^ 1,100000,; \
+ s,JJK,${FONTNAME},; \
+ ' | ${SORT} -r | ${CUT} -c 8- > ${WRKSRC}/fonts.scale
+
+make-fonts.dir:
+ ${CP} ${WRKSRC}/fonts.scale ${WRKSRC}/fonts.dir
+
+#
+# Install
+#
+
+do-install: install-fonts
+
+install-fonts:
+ ${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/* ${FONTSDIR}
+
+#
+# Post-install
+#
+
+post-install: truetype-link display-message
+
+truetype-link:
+.if ${XFREE86_VERSION} == 3
+ ${LN} -fs ${FONTSDIR} ${TTFONTSDIR}/${FONTNAME}
+.endif
+
+display-message:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>
diff --git a/x11-fonts/code2000/distinfo b/x11-fonts/code2000/distinfo
new file mode 100644
index 000000000000..b78f0149c416
--- /dev/null
+++ b/x11-fonts/code2000/distinfo
@@ -0,0 +1 @@
+MD5 (code2000-1.13/CODE2000.ZIP) = ae2bcb9a43af61ab95dd63df56bbf12d
diff --git a/x11-fonts/code2000/pkg-descr b/x11-fonts/code2000/pkg-descr
new file mode 100644
index 000000000000..785bd10647d6
--- /dev/null
+++ b/x11-fonts/code2000/pkg-descr
@@ -0,0 +1,7 @@
+This famous TrueType font contains a lot of Unicode glyphs (over 34000 in
+version 1.13).
+
+With Unicode-aware applications you'll be able to display and use special
+characters and a lot of languages.
+
+WWW: http://home.att.net/~jameskass/
diff --git a/x11-fonts/code2000/pkg-message b/x11-fonts/code2000/pkg-message
new file mode 100644
index 000000000000..2ead417af145
--- /dev/null
+++ b/x11-fonts/code2000/pkg-message
@@ -0,0 +1,23 @@
+IMPORTANT - READ CAREFULLY: Code2000 is *NOT* free software!
+It is offered as a shareware demo. If you like it and use it after a
+reasonable evaluation period, you are obliged to register the
+font by sending $5 (Five U.S. Dollars, or equivalent in any currency)
+to the author. See %%FONTSDIR%%/Code2000.html.
+You can start using the font by following these instructions:
+
+--- XFree86 4.x.x (using the freetype module)
+
+Make sure that the freetype module is loaded. If it is not, add the following
+line to the "Modules" section of XF86Config:
+
+ Load "freetype"
+
+Add the following line to the "Files" section of XF86Config:
+
+ FontPath "%%FONTSDIR%%/"
+
+--- XFree86 3.x.x (using Xfstt)
+
+Add the following line to the "Files" section of XF86Config:
+
+ FontPath "unix/:7101"
diff --git a/x11-fonts/code2000/pkg-plist b/x11-fonts/code2000/pkg-plist
new file mode 100644
index 000000000000..f9c7b2faa7e0
--- /dev/null
+++ b/x11-fonts/code2000/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%FONTSDIR%%/code2000.html
+%%FONTSDIR%%/code2000.ttf
+%%FONTSDIR%%/fonts.dir
+%%FONTSDIR%%/fonts.scale
+@dirrm %%FONTSDIR%%
+%%PKG_OLDXF86%%@exec ln -fs %D/%%FONTSDIR%% %D/%%TTFONTSDIR%%/%%FONTNAME%%
+%%PKG_OLDXF86%%@unexec rm -f %D/%%TTFONTSDIR%%/%%FONTNAME%%