aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/croscorefonts-fonts-ttf
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-01-19 23:13:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-01-19 23:13:34 +0000
commitf16cba880d3a8572eca57475afbfd50899e75cf2 (patch)
tree3f737f0b50f8041025280bc4243f5505d93b0647 /x11-fonts/croscorefonts-fonts-ttf
parent5c67a7dbf07cbda970e16910bc56b0866f565b36 (diff)
downloadports-f16cba880d3a8572eca57475afbfd50899e75cf2.tar.gz
ports-f16cba880d3a8572eca57475afbfd50899e75cf2.zip
Notes
Diffstat (limited to 'x11-fonts/croscorefonts-fonts-ttf')
-rw-r--r--x11-fonts/croscorefonts-fonts-ttf/Makefile56
-rw-r--r--x11-fonts/croscorefonts-fonts-ttf/distinfo2
-rw-r--r--x11-fonts/croscorefonts-fonts-ttf/files/pkg-message.in5
-rw-r--r--x11-fonts/croscorefonts-fonts-ttf/pkg-descr8
-rw-r--r--x11-fonts/croscorefonts-fonts-ttf/pkg-plist18
5 files changed, 89 insertions, 0 deletions
diff --git a/x11-fonts/croscorefonts-fonts-ttf/Makefile b/x11-fonts/croscorefonts-fonts-ttf/Makefile
new file mode 100644
index 000000000000..b2a79c8e8d3f
--- /dev/null
+++ b/x11-fonts/croscorefonts-fonts-ttf/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: ChromeOS fonts
+# Date created: 17 May 2007
+# Whom: Pedro Giffuni
+#
+# $FreeBSD$
+#
+
+PORTNAME= croscorefonts
+PORTVERSION= 1.21.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://gsdview.appspot.com/chromeos-localmirror/distfiles/
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Fonts created from by Google for ChromeOS to replace MS TTF
+
+LICENSE= OFL
+LICENSE_NAME= SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= auto-accept
+
+BUILD_DEPENDS= mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+FETCH_ARGS= -Fpr
+
+USE_XORG= x11
+
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+FONTNAME= ChromeOS
+FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT= LICENSE fonts.dir fonts.scale
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+
+do-build:
+ cd ${WRKSRC} && ${MKFONTSCL_CMD}
+ ${REINPLACE_CMD} -e 's|-misc-|-google-|' ${WRKSRC}/fonts.scale
+ cd ${WRKSRC} && ${MKFONTDIR_CMD}
+
+do-install:
+ ${MKDIR} ${FONTDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${INSTDAT} *.ttf ${FONTDIR}
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/croscorefonts-fonts-ttf/distinfo b/x11-fonts/croscorefonts-fonts-ttf/distinfo
new file mode 100644
index 000000000000..455e7d0310b7
--- /dev/null
+++ b/x11-fonts/croscorefonts-fonts-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (croscorefonts-1.21.0.tar.gz) = 370e55428729174f2801e9cfb4bce0f20b6f5b26c08d6488ac8b5b765c322703
+SIZE (croscorefonts-1.21.0.tar.gz) = 2605014
diff --git a/x11-fonts/croscorefonts-fonts-ttf/files/pkg-message.in b/x11-fonts/croscorefonts-fonts-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..dca252c8f1d3
--- /dev/null
+++ b/x11-fonts/croscorefonts-fonts-ttf/files/pkg-message.in
@@ -0,0 +1,5 @@
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your x.org configuration file:
+
+ FontPath "%%FONTDIR%%/"
diff --git a/x11-fonts/croscorefonts-fonts-ttf/pkg-descr b/x11-fonts/croscorefonts-fonts-ttf/pkg-descr
new file mode 100644
index 000000000000..e3820e4e12e0
--- /dev/null
+++ b/x11-fonts/croscorefonts-fonts-ttf/pkg-descr
@@ -0,0 +1,8 @@
+Google has created a set of fonts for it's ChromeOS Operating system.
+
+The three standard ones closely mimic the most popular ones for
+the Windows platform and the linuxso-called Liberation fonts but
+are available under an OpenFont license.
+
+Tinos, Arimo and Cousine, appear to be variations of the old
+standard Times, Arial and Courier.
diff --git a/x11-fonts/croscorefonts-fonts-ttf/pkg-plist b/x11-fonts/croscorefonts-fonts-ttf/pkg-plist
new file mode 100644
index 000000000000..ff5aac4e1353
--- /dev/null
+++ b/x11-fonts/croscorefonts-fonts-ttf/pkg-plist
@@ -0,0 +1,18 @@
+%%FONTDIR%%/Arimo-Bold.ttf
+%%FONTDIR%%/Arimo-BoldItalic.ttf
+%%FONTDIR%%/Arimo-Italic.ttf
+%%FONTDIR%%/Arimo-Regular.ttf
+%%FONTDIR%%/Cousine-Bold.ttf
+%%FONTDIR%%/Cousine-BoldItalic.ttf
+%%FONTDIR%%/Cousine-Italic.ttf
+%%FONTDIR%%/Cousine-Regular.ttf
+%%FONTDIR%%/LICENSE
+%%FONTDIR%%/SymbolNeu.ttf
+%%FONTDIR%%/Tinos-Bold.ttf
+%%FONTDIR%%/Tinos-BoldItalic.ttf
+%%FONTDIR%%/Tinos-Italic.ttf
+%%FONTDIR%%/Tinos-Regular.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%