aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/crosextrafonts-caladea-ttf
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-05-06 04:44:22 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-05-06 04:44:22 +0000
commitc2570e0d5646600d41c01cbd8a2c6010f0a29192 (patch)
tree4b645e5c0815aada187dbf3075db0f2b23b4b104 /x11-fonts/crosextrafonts-caladea-ttf
parent302280a4db66ec4db6efc025285878af832d8b97 (diff)
downloadports-c2570e0d5646600d41c01cbd8a2c6010f0a29192.tar.gz
ports-c2570e0d5646600d41c01cbd8a2c6010f0a29192.zip
Notes
Diffstat (limited to 'x11-fonts/crosextrafonts-caladea-ttf')
-rw-r--r--x11-fonts/crosextrafonts-caladea-ttf/Makefile42
-rw-r--r--x11-fonts/crosextrafonts-caladea-ttf/distinfo2
-rw-r--r--x11-fonts/crosextrafonts-caladea-ttf/files/pkg-message.in5
-rw-r--r--x11-fonts/crosextrafonts-caladea-ttf/pkg-descr4
-rw-r--r--x11-fonts/crosextrafonts-caladea-ttf/pkg-plist8
5 files changed, 61 insertions, 0 deletions
diff --git a/x11-fonts/crosextrafonts-caladea-ttf/Makefile b/x11-fonts/crosextrafonts-caladea-ttf/Makefile
new file mode 100644
index 000000000000..2f55eba71ab6
--- /dev/null
+++ b/x11-fonts/crosextrafonts-caladea-ttf/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= crosextrafonts
+PORTVERSION= 20130214
+CATEGORIES= x11-fonts
+MASTER_SITES= http://gsdview.appspot.com/chromeos-localmirror/distfiles/
+PKGNAMESUFFIX= -caladea
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Font created by Google for ChromeOS to replace MS Cambria
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+USE_XORG= x11
+
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+FONTNAME= Caladea
+FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT= fonts.dir fonts.scale
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+
+do-build:
+ cd ${WRKSRC} && ${MKFONTSCL_CMD}
+ ${REINPLACE_CMD} -e 's|-misc-|-google-|' ${WRKSRC}/fonts.scale
+ cd ${WRKSRC} && ${MKFONTDIR_CMD}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${INSTDAT} *.ttf ${STAGEDIR}${FONTDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/crosextrafonts-caladea-ttf/distinfo b/x11-fonts/crosextrafonts-caladea-ttf/distinfo
new file mode 100644
index 000000000000..38f8d3d2abf7
--- /dev/null
+++ b/x11-fonts/crosextrafonts-caladea-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (crosextrafonts-20130214.tar.gz) = c48d1c2fd613c9c06c959c34da7b8388059e2408d2bb19845dc3ed35f76e4d09
+SIZE (crosextrafonts-20130214.tar.gz) = 112756
diff --git a/x11-fonts/crosextrafonts-caladea-ttf/files/pkg-message.in b/x11-fonts/crosextrafonts-caladea-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..dca252c8f1d3
--- /dev/null
+++ b/x11-fonts/crosextrafonts-caladea-ttf/files/pkg-message.in
@@ -0,0 +1,5 @@
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your x.org configuration file:
+
+ FontPath "%%FONTDIR%%/"
diff --git a/x11-fonts/crosextrafonts-caladea-ttf/pkg-descr b/x11-fonts/crosextrafonts-caladea-ttf/pkg-descr
new file mode 100644
index 000000000000..9c0782f8b5de
--- /dev/null
+++ b/x11-fonts/crosextrafonts-caladea-ttf/pkg-descr
@@ -0,0 +1,4 @@
+Caladea is metric-compatible with Cambria font.
+This font is sans-serif typeface family based on Lato.
+
+WWW: https://code.google.com/p/chromium/issues/detail?id=168879
diff --git a/x11-fonts/crosextrafonts-caladea-ttf/pkg-plist b/x11-fonts/crosextrafonts-caladea-ttf/pkg-plist
new file mode 100644
index 000000000000..b83d24be768e
--- /dev/null
+++ b/x11-fonts/crosextrafonts-caladea-ttf/pkg-plist
@@ -0,0 +1,8 @@
+%%FONTDIR%%/Caladea-Bold.ttf
+%%FONTDIR%%/Caladea-BoldItalic.ttf
+%%FONTDIR%%/Caladea-Italic.ttf
+%%FONTDIR%%/Caladea-Regular.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%