aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/cyr-rfx/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-01-25 21:16:01 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-01-25 21:16:01 +0000
commita03a788790301a783c395a008abc4e534df5a1e0 (patch)
tree0e643ca807703c03012931c11e68a11e24cbb6e3 /x11-fonts/cyr-rfx/Makefile
parent1345357a3f7f754d84f606fa36b1666814180ac2 (diff)
downloadports-a03a788790301a783c395a008abc4e534df5a1e0.tar.gz
ports-a03a788790301a783c395a008abc4e534df5a1e0.zip
Notes
Diffstat (limited to 'x11-fonts/cyr-rfx/Makefile')
-rw-r--r--x11-fonts/cyr-rfx/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-fonts/cyr-rfx/Makefile b/x11-fonts/cyr-rfx/Makefile
new file mode 100644
index 000000000000..d450c7fb8b1d
--- /dev/null
+++ b/x11-fonts/cyr-rfx/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cyr-rfx
+# Date created: Jan 20, 2003
+# Whom: mi@aldan.algebra.com
+#
+# $NetBSD: Makefile.common,v 1.2 2002/07/13 15:43:36 wiz Exp $
+# $FreeBSD$
+
+PORTNAME= cyr-rfx-${CYR_RFX_ENCODING}
+PORTVERSION= 1.1
+CATEGORIES= x11-fonts ukrainian russian
+MASTER_SITES= ftp://ftp.ptc.spbu.ru/mirror/%SUBDIR%/ \
+ ftp://%SUBDIR%/
+MASTER_SITE_SUBDIR= ftp.inp.nsk.su/pub/BINP/X11/fonts/cyr-rfx/srctgz
+EXTRACT_SUFX= .bdfs.tgz
+
+MAINTAINER= mi@aldan.algebra.com
+
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients \
+ mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+
+# See WWW for other available encodings
+CYR_RFX_ENCODING?= koi8-o
+
+WRKSRC= ${WRKDIR}/${CYR_RFX_ENCODING}
+NCPUS!= sysctl -n hw.ncpu 2> /dev/null || echo 1
+MAKE_ARGS+= -j ${NCPUS}
+MAKEFILE= ${FILESDIR}/Makefile.bdf2pcf
+INST_DIR= "lib/X11/fonts/${PORTNAME}"
+MAKE_ENV+= INST_DIR="${X11BASE}/${INST_DIR}" MKDIR="${MKDIR}"
+PLIST_SUB+= INST_DIR="${INST_DIR}"
+
+post-install:
+ @${SED} -e 's,/usr/X11R6,${X11BASE},g' -e \
+ 's,koi8-o,${CYR_RFX_ENCODING},g' < ${PKGMESSAGE}
+
+.include <bsd.port.mk>