aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fantasque-sans-mono/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-02-12 23:05:10 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-02-12 23:05:10 +0000
commit0a3a883a65f6cc0b6fb113fe65ba0d9d36e2a156 (patch)
treefe6fc0b232e52d4f3680fa89815bfde2ee0a9bf5 /x11-fonts/fantasque-sans-mono/Makefile
parent0b9eb91f521407c9b0d03819fe3924b61fd44661 (diff)
downloadports-0a3a883a65f6cc0b6fb113fe65ba0d9d36e2a156.tar.gz
ports-0a3a883a65f6cc0b6fb113fe65ba0d9d36e2a156.zip
Rename x11-fonts/cosmic-sans-neue-mono to x11-fonts/fantasque-sans-mono, update to 1.6.1.
The font was renamed upstream, so follow suit and rename the port. Changes since 1.3.1: 1.3.2 - Various fixes: playing again with bold m, moving accents again, taking care again of Powerline symbols, clean 8 and R. Add a few box drawing characters (for use with vim-indentline). Generate webfonts (goal: this font used for code samples on all cool languages' websites). Add a WIP medium version of the proportional font. 1.4 - Rename font to Fantasque Sans, because fantasque is the new cosmic. Make W look symetrical at big size. 1.4.1 - Drop Reserved Font Name. You can now subset, compress, hint and whatnot without worrying about renaming. Many small improvements (8, s , t, a, e, {, }, W, i, l, g...). 1.5 - Add regular italic version. Some small changes (Q, w, y, n). 1.6 - Add bold italic version. 1.6.1 - Simplify @ to make it look sharp at all sizes. Various fixes.
Notes
Notes: svn path=/head/; revision=344028
Diffstat (limited to 'x11-fonts/fantasque-sans-mono/Makefile')
-rw-r--r--x11-fonts/fantasque-sans-mono/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-fonts/fantasque-sans-mono/Makefile b/x11-fonts/fantasque-sans-mono/Makefile
new file mode 100644
index 000000000000..01c4e775a83e
--- /dev/null
+++ b/x11-fonts/fantasque-sans-mono/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= fantasque-sans-mono
+PORTVERSION= 1.6.1
+CATEGORIES= x11-fonts
+MASTER_SITES= http://openfontlibrary.org/assets/downloads/${PORTNAME}/1baf065481fd4829a407040743378130/
+DISTNAME= fantasque-sans-mono
+
+MAINTAINER= rakuco@FreeBSD.org
+COMMENT= Programming font, designed with functionality in mind
+
+LICENSE= OFL11
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+
+FONTDIR= ${STAGEDIR}${PREFIX}/lib/X11/fonts/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${MKDIR} ${FONTDIR}
+ cd ${WRKSRC}/OTF && \
+ ${INSTALL_DATA} *.otf ${FONTDIR}
+
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>