aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fira
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-27 14:15:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-27 14:15:43 +0000
commit48969de7e32c103805954497e64bf58811f2023f (patch)
treef6e20eea1435290e0cb1819172745e113ef9ee25 /x11-fonts/fira
parent2a912e1c5e4be08da2ea6566287d72dc0f3ea08a (diff)
downloadports-48969de7e32c103805954497e64bf58811f2023f.tar.gz
ports-48969de7e32c103805954497e64bf58811f2023f.zip
Notes
Diffstat (limited to 'x11-fonts/fira')
-rw-r--r--x11-fonts/fira/Makefile46
-rw-r--r--x11-fonts/fira/distinfo10
-rw-r--r--x11-fonts/fira/files/pkg-message.in23
-rw-r--r--x11-fonts/fira/pkg-descr15
-rw-r--r--x11-fonts/fira/pkg-plist61
5 files changed, 95 insertions, 60 deletions
diff --git a/x11-fonts/fira/Makefile b/x11-fonts/fira/Makefile
index 1f59347b8a03..560ed52aadaf 100644
--- a/x11-fonts/fira/Makefile
+++ b/x11-fonts/fira/Makefile
@@ -2,45 +2,61 @@
# $FreeBSD$
PORTNAME= fira
-PORTVERSION= 1.0
+PORTVERSION= 3.108
CATEGORIES= x11-fonts
+MASTER_SITES= http://dev.carrois.com/wordpress/downloads/${PORTNAME}_3_1/ \
+ SF/horia/${CATEGORIES}/${PORTNAME}/
+DISTNAME= ${PORTNAME:S|f|F|}Fonts${PORTVERSION:S|.||}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME:S|f|F|}PDF${PORTVERSION:S|.||}${EXTRACT_SUFX} \
+ ${PORTNAME:S|f|F|}UFO_beta${PORTVERSION:S|.||}${EXTRACT_SUFX} \
+ Version_Report.rtf
+EXTRACT_ONLY= ${DISTFILES:C|Version.*||}
MAINTAINER= horia@racoviceanu.com
COMMENT= Sans-serif and monospaced typeface for small screens
LICENSE= OFL11
-BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GITHUB= yes
-GH_ACCOUNT= mozilla
-GH_PROJECT= Fira
-GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 705ffff
-
+USES= zip
USE_XORG= x11
FONTLIBPATH= lib/X11/fonts
FONTROOTDIR= ${PREFIX}/${FONTLIBPATH}
FONTDIR= ${FONTROOTDIR}/${PORTNAME}
NO_BUILD= yes
-SUB_LIST= FONTDIR="${FONTDIR}"
+SUB_FILES= pkg-message
PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
-PORTDOCS= README.md
+PORTDOCS= Version_Report.rtf \
+ ${PORTNAME:S|f|F|}*.pdf
-OPTIONS_DEFINE= DOCS
+PORTEXAMPLES= *
-SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS EXAMPLES
+EXAMPLES_DESC= UFO source files
+
+.include <bsd.port.options.mk>
do-install:
@${MKDIR} ${STAGEDIR}${FONTDIR}
- ${INSTALL_DATA} ${WRKSRC}/ttf/${GH_PROJECT}*.ttf ${STAGEDIR}${FONTDIR}
- ${INSTALL_DATA} ${WRKSRC}/otf/${GH_PROJECT}*.otf ${STAGEDIR}${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME:S|f|F|}*${PORTVERSION:S|.||}/OTF/${PORTNAME:S|f|F|}*.otf \
+ ${STAGEDIR}${FONTDIR}
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${CP} ${DISTDIR}/Version_Report.rtf ${WRKSRC}/
+ @${CP} ${WRKDIR}/${PORTNAME:S|f|F|}PDF${PORTVERSION:S|.||}/${PORTNAME:S|f|F|}*.pdf ${WRKSRC}/
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKDIR}/${PORTNAME:S|f|F|}UFO_beta${PORTVERSION:S|.||} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+.endif
.include <bsd.port.mk>
diff --git a/x11-fonts/fira/distinfo b/x11-fonts/fira/distinfo
index 0a0c7df79646..078af241f1aa 100644
--- a/x11-fonts/fira/distinfo
+++ b/x11-fonts/fira/distinfo
@@ -1,2 +1,8 @@
-SHA256 (fira-1.0.tar.gz) = f87bd7d1380e5a93a3743edd3d038b44c7460ea14c204b152b750f5551fd2531
-SIZE (fira-1.0.tar.gz) = 3973356
+SHA256 (FiraFonts3108.zip) = 1276faad9079547d49e320acf30f2d35c569aa0a8dc4fbaed58535122efc1859
+SIZE (FiraFonts3108.zip) = 12452926
+SHA256 (FiraPDF3108.zip) = fb876e5271bfa4c06050e1854458be5eeaac897708e114481939332204c77159
+SIZE (FiraPDF3108.zip) = 18991895
+SHA256 (FiraUFO_beta3108.zip) = 8edd2f1a768055c949ccfb6f20aa4a900b327c8bd7e63bd1d261ab987f611f2a
+SIZE (FiraUFO_beta3108.zip) = 7088932
+SHA256 (Version_Report.rtf) = 6a32e9c54abf66a49adcb61223fb23465850bd8f48f1eb512f647eb4eb7bb71c
+SIZE (Version_Report.rtf) = 4671
diff --git a/x11-fonts/fira/files/pkg-message.in b/x11-fonts/fira/files/pkg-message.in
index 818944d500ec..101bbff6a7a2 100644
--- a/x11-fonts/fira/files/pkg-message.in
+++ b/x11-fonts/fira/files/pkg-message.in
@@ -2,16 +2,19 @@
Fira has been installed.
-Make sure that the freetype module is loaded. If it is not, add the following
-line to the "Modules" section of your X Windows configuration file:
-
- Load "freetype"
-
-Add the following line to the "Files" section of X Windows configuration file:
-
- FontPath "%%FONTDIR%%/"
-
-Note: your X Windows configuration file is typically /etc/X11/xorg.conf
+Fira has advanced Open Type typographic layout features and language support.
+Please refer to the Technical Documentation installed by this port or online at
+
+ http://dev.carrois.com/fira-3-1/
+
+For details about OpenType Layout Features see the OpenType Layout tag registry
+
+ http://www.microsoft.com/typography/otspec/featurelist.htm
+
+or
+
+ https://www.fontfont.com/staticcontent/downloads/FF_OT_User_Guide.pdf
+ http://en.wikipedia.org/wiki/List_of_typographic_features
For Web Font please use www/fira-webfont port.
diff --git a/x11-fonts/fira/pkg-descr b/x11-fonts/fira/pkg-descr
index 36ca448fe5eb..64928bbb4938 100644
--- a/x11-fonts/fira/pkg-descr
+++ b/x11-fonts/fira/pkg-descr
@@ -1,9 +1,10 @@
-The Fira font family was designed to cover the legibility needs for a
-large range of handsets varying in screen quality and rendering. It
-comes in a Sans Serif with 4 weights (light, regular, medium and bold)
-all accompanied by italic styles. The package also includes a Mono
-Spaced variant with 2 weights (regular and bold).
+The Fira font family was designed to cover the legibility needs for a large
+range of handsets varying in screen quality and rendering. It comes in a
+Sans Serif with 16 weights all accompanied by italic styles. The package also
+includes a Mono Spaced variant with 3 weights (regular, medium and bold). The
+UFO source files are included in examples.
-Available formats: Open Type, True Type
+Available formats: Open Type
+*supports advanced Open Type typographic layout features and languages
-WWW: http://mozilla.github.io/Fira/
+WWW: http://dev.carrois.com/fira-3-1/
diff --git a/x11-fonts/fira/pkg-plist b/x11-fonts/fira/pkg-plist
index de426a6147f1..193dcbbdc939 100644
--- a/x11-fonts/fira/pkg-plist
+++ b/x11-fonts/fira/pkg-plist
@@ -1,29 +1,38 @@
-%%FONTDIR%%/FiraMono-Bold.ttf
-%%FONTDIR%%/FiraMono-Regular.ttf
-%%FONTDIR%%/FiraMonoOT-Bold.otf
-%%FONTDIR%%/FiraMonoOT-Regular.otf
-%%FONTDIR%%/FiraSans-Bold.ttf
-%%FONTDIR%%/FiraSans-BoldItalic.ttf
-%%FONTDIR%%/FiraSans-Light.ttf
-%%FONTDIR%%/FiraSans-LightItalic.ttf
-%%FONTDIR%%/FiraSans-Medium.ttf
-%%FONTDIR%%/FiraSans-MediumItalic.ttf
-%%FONTDIR%%/FiraSans-Regular.ttf
-%%FONTDIR%%/FiraSans-RegularItalic.ttf
-%%FONTDIR%%/FiraSansOT-Bold.otf
-%%FONTDIR%%/FiraSansOT-BoldItalic.otf
-%%FONTDIR%%/FiraSansOT-Light.otf
-%%FONTDIR%%/FiraSansOT-LightItalic.otf
-%%FONTDIR%%/FiraSansOT-Medium.otf
-%%FONTDIR%%/FiraSansOT-MediumItalic.otf
-%%FONTDIR%%/FiraSansOT-Regular.otf
-%%FONTDIR%%/FiraSansOT-RegularItalic.otf
+%%FONTDIR%%/FiraMono-Bold.otf
+%%FONTDIR%%/FiraMono-Medium.otf
+%%FONTDIR%%/FiraMono-Regular.otf
+%%FONTDIR%%/FiraSans-Bold.otf
+%%FONTDIR%%/FiraSans-BoldItalic.otf
+%%FONTDIR%%/FiraSans-Book.otf
+%%FONTDIR%%/FiraSans-BookItalic.otf
+%%FONTDIR%%/FiraSans-Eight.otf
+%%FONTDIR%%/FiraSans-EightItalic.otf
+%%FONTDIR%%/FiraSans-ExtraBold.otf
+%%FONTDIR%%/FiraSans-ExtraBoldItalic.otf
+%%FONTDIR%%/FiraSans-ExtraLight.otf
+%%FONTDIR%%/FiraSans-ExtraLightItalic.otf
+%%FONTDIR%%/FiraSans-Four.otf
+%%FONTDIR%%/FiraSans-FourItalic.otf
+%%FONTDIR%%/FiraSans-Hair.otf
+%%FONTDIR%%/FiraSans-HairItalic.otf
+%%FONTDIR%%/FiraSans-Heavy.otf
+%%FONTDIR%%/FiraSans-HeavyItalic.otf
+%%FONTDIR%%/FiraSans-Italic.otf
+%%FONTDIR%%/FiraSans-Light.otf
+%%FONTDIR%%/FiraSans-LightItalic.otf
+%%FONTDIR%%/FiraSans-Medium.otf
+%%FONTDIR%%/FiraSans-MediumItalic.otf
+%%FONTDIR%%/FiraSans-Regular.otf
+%%FONTDIR%%/FiraSans-SemiBold.otf
+%%FONTDIR%%/FiraSans-SemiBoldItalic.otf
+%%FONTDIR%%/FiraSans-Thin.otf
+%%FONTDIR%%/FiraSans-ThinItalic.otf
+%%FONTDIR%%/FiraSans-Two.otf
+%%FONTDIR%%/FiraSans-TwoItalic.otf
+%%FONTDIR%%/FiraSans-Ultra.otf
+%%FONTDIR%%/FiraSans-UltraItalic.otf
+%%FONTDIR%%/FiraSans-UltraLight.otf
+%%FONTDIR%%/FiraSans-UltraLightItalic.otf
@exec fc-cache -s -v %D/%%FONTDIR%% 2>/dev/null || true
-@exec mkfontscale %D/%%FONTDIR%% 2>/dev/null || true
-@unexec mkfontscale %D/%%FONTDIR%% 2>/dev/null || true
-@unexec if [ -e %D/%%FONTDIR%%/fonts.scale -a "`stat -f '%%z' %D/%%FONTDIR%%/fonts.scale 2>/dev/null`" = '2' ]; then rm %D/%%FONTDIR%%/fonts.scale; fi
-@exec mkfontdir %D/%%FONTDIR%% 2>/dev/null || true
-@unexec mkfontdir %D/%%FONTDIR%% 2>/dev/null || true
-@unexec if [ -e %D/%%FONTDIR%%/fonts.dir -a "`stat -f '%%z' %D/%%FONTDIR%%/fonts.dir 2>/dev/null`" = '2' ]; then rm %D/%%FONTDIR%%/fonts.dir; fi
@dirrm %%FONTDIR%%
@unexec fc-cache -s -v %D/%%FONTDIR%% 2>/dev/null || true