aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fontconfig/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-01-24 04:58:53 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-01-24 04:58:53 +0000
commitf681cbe4c606f0eb4c464cd6b9e8f88cb2419620 (patch)
tree52423390664659caa2b4e8175964dbd3eb391722 /x11-fonts/fontconfig/Makefile
parenta4ad73ca23759c5396e8dc8e4bda613b44805484 (diff)
downloadports-f681cbe4c606f0eb4c464cd6b9e8f88cb2419620.tar.gz
ports-f681cbe4c606f0eb4c464cd6b9e8f88cb2419620.zip
Notes
Diffstat (limited to 'x11-fonts/fontconfig/Makefile')
-rw-r--r--x11-fonts/fontconfig/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index 6ddb7d338c86..74e5019008f2 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_GMAKE= yes
-USE_X_PREFIX= yes
+PREFIX?= ${X11BASE}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
@@ -30,6 +30,13 @@ CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc/fonts \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME}/fontconfig
+.include <bsd.port.pre.mk>
+.if ${XFREE86_VERSION} == 3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
@@ -38,4 +45,4 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>